1063785
столько раз учителя, ученики и родители
посетили сайт «Инфоурок»
за прошедшие 24 часа
+Добавить материал
и получить бесплатное
свидетельство о публикации
в СМИ №ФС77-60625 от 20.01.2015
Дистанционные курсы профессиональной переподготовки и повышения квалификации для педагогов

Дистанционные курсы для педагогов - курсы профессиональной переподготовки от 1.410 руб.;
- курсы повышения квалификации от 430 руб.
Московские документы для аттестации

ВЫБРАТЬ КУРС СО СКИДКОЙ ДО 90%

ВНИМАНИЕ: Скидка действует ТОЛЬКО до конца апреля!

(Лицензия на осуществление образовательной деятельности №038767 выдана ООО "Столичный учебный центр", г.Москва)

ИнфоурокИнформатикаДругие методич. материалыИсполнитель Робот. Подготовка к ОГЭ 9 класс

Исполнитель Робот. Подготовка к ОГЭ 9 класс

библиотека
материалов
Скачать материал целиком можно бесплатно по ссылке внизу страницы.

Исполнитель РОБОТ. 1 вариант

Условие.

На бесконечном поле есть горизонтальная и вертикальная стены. Левый конец горизонтальной стены соединен с нижним концом вертикальной стены. Длины стен неизвестны. В горизонтальной стене есть ровно один проход, точное место прохода и его ширина неизвестны. Робот находится в клетке, расположенной непосредственно справа от вертикальной стены у ее конца.

Рисунок. Возможный способ расположения стен и робота (Робот обозначен буквой «Р»)










Р







































Задание. Напишите для Робота алгоритм, закрашивающий все клетки, расположенные непосредственно выше и ниже горизонтальной стены. Проход должен остаться не закрашенным. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведенного выше рисунка Робот должен закрасить следующие клетки (см. рисунок ниже)



Результат.









Р







































Требования. При исполнении алгоритма Робот не должен разрушиться, выполнение алгоритма должно завершиться. Конечное расположение Робота может быть произвольным.

Сохрани алгоритм в текстовый файл. Название файла и каталог для сохранения Вам сообщит организатор.

Выполнение

  1. Открыть программу Кумир. Создать новую программу – Программа, новая программа.

использовать Робот

алг

нач



кон

2. Создай СТАРТОВУЮ ОБСТАНОВКУ ДЛЯ РЕШЕНИЯ ЗАДАЧИ – смотри рисунок ниже

Аhello_html_4d2f595a.png) Создай 1 версию обстановки – Инструменты, Создать стартовую обстановку для Робота.

Сохрани – выбери в меню Обстановка, Сохранить как, выбери папку своего класса и сохрани, имя файла – 1 вариант (1 версия)



  1. Напиши алгоритм – он должен быть универсальным, правильно работать и для 1 версии и для второй версии стартовой обстановки

    использовать Робот
    алг
    нач
    . | Спуститься вниз вдоль стены
    . нц пока снизу свободно
    . . вниз
    . кц
    . | Закрасить клетки сверху до прохода
    . нц пока не снизу свободно
    . . закрасить
    . . вправо
    . кц
    . | пройти проход независимо сколько он клеток
    . нц пока снизу свободно
    . . вправо
    . кц
    . | Закрасить клетки сверху после прохода
    . нц пока не снизу свободно
    . . закрасить
    . . вправо
    . кц
    . | спуститься вниз и влево
    . вниз
    . влево
    . | Закрасить клетки снизу справа налево до прохода
    . нц пока не сверху свободно
    . . закрасить
    . . влево
    . кц
    . | пройти проход справа налево независимо сколько он клеток
    . нц пока сверху свободно
    . . влево
    . кц
    . | Закрасить клетки снизу справа налево после прохода
    . нц пока не сверху свободно
    . . закрасить
    . . влево
    . кц
    кон







































  2. Проверить выполнение алгоритма (F9) на данной стартовой обстановки. Если получилось, то покажи учителю, в противном случае исправь алгоритм.



hello_html_4d294faf.png

  1. Создай другую стартовую обстановку, сохрани ее (смотри пункт 2, имя файла – 3 вариант (2 версия)).



hello_html_68216748.png

  1. Проверь выполнение алгоритма на другой стартовой обстановке. Должно получиться следующее:

Еhello_html_3df00086.pngсли получилось, то покажи учителю, в противном случае исправь алгоритм.







  1. Сохранить алгоритм в среде Кумир в папке своего класса( например 8 Б класс) под именем –

Робот, 1 вариант







Исполнитель РОБОТ. 2 вариант

Условие.

На бесконечном поле есть горизонтальная и вертикальная стены. Левый конец горизонтальной стены соединен с нижним концом вертикальной стены. Длины стен неизвестны. В горизонтальной стене есть ровно один проход, точное место прохода и его ширина неизвестны. Робот находится в клетке, расположенной непосредственно слева от вертикальной стены у ее конца.

Рисунок. Возможный способ расположения стен и робота (Робот обозначен буквой «Р»)









Р








































Задание. Напишите для Робота алгоритм, закрашивающий все клетки, расположенные непосредственно над участком горизонтальной стены правее прохода. Проход должен остаться не закрашенным. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведенного выше рисунка Робот должен закрасить следующие клетки (см. рисунок ниже)



Результат.









Р







































Требования. При исполнении алгоритма Робот не должен разрушиться, выполнение алгоритма должно завершиться. Конечное расположение Робота может быть произвольным.

Сохрани алгоритм в текстовом файле. Название файла и каталог для сохранения Вам сообщит организатор.

Выполнение

  1. Открыть программу Кумир; в меню выбрать Файл, Новая программа

использовать Робот

алг

нач


кон

2. Создай СТАРТОВУЮ ОБСТАНОВКУ ДЛЯ РЕШЕНИЯ ЗАДАЧИ – смотри рисунок ниже

Сhello_html_m190b4b89.pngоздай 1 версию обстановки – Инструменты, Создать стартовую обстановку для Робота или Редактировать стартовую обстановку (нажатие лев. Клавиши мыши – поставить или убрать стену, перетаскивание квадратика в нужную клетку (лев. Кл. мыши) - начальное положение Робота.)

Сохрани (Внимательно!!!) – выбери в меню Обстановка, Сохранить как, выбери папку своего класса, сохрани обстановку, имя файла – 2 вариант (1 версия).






  1. Напиши алгоритм – он должен быть универсальным, правильно работать для лестницы с различным количеством ступеней и положением Робота

использовать Робот

алг

нач

нц пока не справа свободно

вниз

кц

вправо

нц пока не сверху свободно

вправо

кц

нц пока сверху свободно

вправо

кц

нц пока не сверху свободно

вправо

кц

вверх

влево

нц пока не снизу свободно

закрасить

влево

кц

кон


  1. Проверить выполнение алгоритма (F9) на данной стартовой обстановки. Если получилось покажи учителю, в противном случае исправь алгоритм.

hello_html_19d78056.png

  1. Создай другую стартовую обстановку, сохрани ее (смотри пункт 2, имя файла – 2 вариант (2 версия)).

hello_html_726902a8.png



  1. Проверь выполнение алгоритма на другой стартовой обстановке. Должно получиться следующее:

Если получилось покажи учителю, в противном случае исправь алгоритм.

hello_html_m45e4ae99.png



  1. Сохранить алгоритм в среде Кумир в папке своего класса( например 8 Б класс) под именем –

Исполнитель Робот, 2 вариант



Исполнитель РОБОТ. 3 вариант

Условие.

На бесконечном поле имеется лестница, которая сначала поднимается вверх, затем спускается вниз. Ширина каждой ступени 1 клетка, высота 2 клетки. Количество ступеней ведущих от верхней ступени вниз неизвестно, ни для направления влево, ни для направления вправо. Робот находиться в клетке, расположенной над верхней ступенью.

Рисунок. Возможный способ расположения лестницы и робота (Робот обозначен буквой «Р»)





Р













































































Задание. Напишите для Робота алгоритм, закрашивающий все клетки, расположенные непосредственно над ступенями лестницы, спускающийся слева направо. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведенного выше рисунка Робот должен закрасить следующие клетки (см. рисунок ниже).


Результат.




Р













































































Требования. При исполнении алгоритма Робот не должен

разрушиться, выполнение алгоритма должно завершиться. Конечное расположение Робота может быть произвольным.

Сохраните алгоритм в текстовом файле. Название файла и каталог для сохранения Вам сообщит организатор.

Выполнение

  1. Открыть программу Кумир; в меню выбрать Файл, Новая

использовать Робот

алг

нач



кон

2. Создай СТАРТОВУЮ ОБСТАНОВКУ ДЛЯ РЕШЕНИЯ ЗАДАЧИ – смотри рисунок ниже

Сhello_html_64aa10b9.pngоздай 1 версию обстановки – Инструменты, Создать стартовую обстановку для Робота или Редактировать стартовую обстановку (нажатие лев. Клавиши мыши – поставить или убрать стену, перетаскивание квадратика в нужную клетку (лев. Кл. мыши) - начальное положение Робота.)

Сохрани (Внимательно!!!) – выбери в меню Обстановка, Сохранить как, выбери папку своего класса, сохрани обстановку, имя файла – 3 вариант (1 версия).

  1. Напиши алгоритм – он должен быть универсальным, правильно работать для лестницы с различным количеством ступеней и положением Робота

использовать Робот
алг
нач
. нц пока снизу свободно
. . вниз
. кц
. вправо
. вниз
. вниз
. нц пока не снизу свободно
. . закрасить
. . вправо
. . вниз
. . вниз
. кц
кон

















  1. Проверить выполнение алгоритма (F9) на данной стартовой обстановки. Если получилось покажи учителю, в противном случае исправь алгоритм.



  1. Создай другую стартовую обстановку, сохрани ее (смотри пункт 2, имя файла – 3 вариант (2 версия)).



hello_html_5afcfc9a.png

  1. Проверь выполнение алгоритма на другой стартовой обстановке. Должно получиться следующее:

Если получилось покажи учителю, в противном случае исправь алгоритм.

hello_html_127b23a9.png













  1. Сохранить алгоритм в среде Кумир в папке своего класса( например 8 Б класс) под именем –

Робот, 3 вариант








Исполнитель РОБОТ. 4 вариант

Условие.

На бесконечном поле имеется лестница, которая сначала поднимается вверх, затем спускается вниз. Ширина каждой ступени 1 клетка, высота 2 клетки. Количество ступеней ведущих от верхней ступени вниз неизвестно, ни для направления влево, ни для направления вправо. Робот находиться в клетке, расположенной над верхней ступенью.

Рисунок. Возможный способ расположения лестницы и робота (Робот обозначен буквой «Р»)




Р













































































Задание. Напишите для Робота алгоритм, закрашивающий все клетки, расположенные непосредственно справа от ступеней лестницы, спускающейся слева направо. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведенного выше рисунка Робот должен закрасить следующие клетки (см. рисунок ниже).


Результат.




Р













































































Требования. При исполнении алгоритма Робот не должен разрушиться, выполнение алгоритма должно завершиться. Конечное расположение Робота может быть произвольным.

Сохраните алгоритм в текстовом файле. Название файла и каталог для сохранения Вам сообщит организатор.

Выполнение

  1. Открыть программу Кумир; в меню выбрать Файл, Новая

использовать Робот

алг

нач



кон

2. Создай СТАРТОВУЮ ОБСТАНОВКУ ДЛЯ РЕШЕНИЯ ЗАДАЧИ – смотри рисунок ниже

Сhello_html_m22017f86.pngоздай 1 версию обстановки – Инструменты, Создать стартовую обстановку для Робота или Редактировать стартовую обстановку (нажатие лев. Клавиши мыши – поставить или убрать стену, перетаскивание квадратика в нужную клетку (лев. Кл. мыши) - начальное положение Робота.)

Сохрани (Внимательно!!!) – выбери в меню Обстановка, Сохранить как, выбери папку своего класса, сохрани обстановку, имя файла – 4 вариант (1 версия).



  1. Напиши алгоритм – он должен быть универсальным, правильно работать для лестницы с различным количеством ступеней и положением Робота

использовать Робот
алг
нач
. нц пока снизу свободно
. . вниз
. кц
. вправо
. вниз
. закрасить
. вниз
. закрасить
. нц пока не снизу свободно
. . вправо
. . вниз
. . закрасить
. . вниз
. . закрасить
. кц
кон





































  1. Проверить выполнение алгоритма (F9) на данной стартовой обстановки. Если получилось покажи учителю, в противном случае исправь алгоритм.

hello_html_21ec8e2d.png

  1. Создай другую стартовую обстановку, сохрани ее (смотри пункт 2, имя файла – 4 вариант (2 версия)).



hello_html_5afcfc9a.png

  1. Проверь выполнение алгоритма на другой стартовой обстановке. Должно получиться следующее:

Если получилось покажи учителю, в противном случае исправь алгоритм.



hello_html_38739e96.png





  1. Сохранить алгоритм в среде Кумир в папке своего класса( например 8 Б класс) под именем –

Робот, 4 вариант











Краткое описание документа:

Подробно разобрано решение 3 заданий 20.1 ОГЭ.

Исполнитель Робот.

Объяснено как работать в среде КУМИР (создавать обстановку для Исполнителя Робот).

Учащимся предлагается для выполнения 3 варианта.

Задания выполняются по следующему плану:

1. Необходимо создать обстановку.

2. Написать алгоритм.

3. Проверить правильность ее работы.

4. Сохранить алгоритм.

4. Изменить обстановку.

5. Проверить правильность ее работы.

Подробно прописаны алгоритмы . В алгоритмах используются циклические алгоритмы. Учащиеся увидят,  когда нужна циклическая структура, а когда в алгоритме используется участок линейного алгоритма.

 

 

 

 

Общая информация

Номер материала: 175063

Вам будут интересны эти курсы:

Курс повышения квалификации «Методика преподавания информатики в начальных классах»
Курс повышения квалификации «Современные информационные технологии и их использование в работе преподавателей. Системы автоматизированного проектирования одежды и организация технологического процесса»
Курс повышения квалификации «Организация работы по формированию медиаграмотности и повышению уровня информационных компетенций всех участников образовательного процесса»
Курс профессиональной переподготовки «Информатика: теория и методика преподавания в образовательной организации»
Курс повышения квалификации «Облачные технологии в образовании»
Курс «Оператор персонального компьютера»
Курс «WEB-ВЕРСТКА (HTML, CSS)»
Курс повышения квалификации «Сетевые и дистанционные (электронные) формы обучения в условиях реализации ФГОС по ТОП-50»
Курс повышения квалификации «Использование компьютерных технологий в процессе обучения в условиях реализации ФГОС»
Курс повышения квалификации «Специфика преподавания информатики в начальных классах с учетом ФГОС НОО»
Курс повышения квалификации «Применение MS Word, Excel в финансовых расчетах»
Курс профессиональной переподготовки «Теория и методика обучения информатике в начальной школе»
Курс профессиональной переподготовки «Математика и информатика: теория и методика преподавания в образовательной организации»
Курс повышения квалификации «Современные тенденции цифровизации образования»
Курс повышения квалификации «Специфика преподавания дисциплины «Информационные технологии» в условиях реализации ФГОС СПО по ТОП-50»
Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.