339078
столько раз учителя, ученики и родители
посетили сайт «Инфоурок»
за прошедшие 24 часа
+Добавить материал
и получить бесплатное
свидетельство о публикации
в СМИ №ФС77-60625 от 20.01.2015
Дистанционные курсы профессиональной переподготовки и повышения квалификации для педагогов

Дистанционные курсы для педагогов - курсы профессиональной переподготовки от 6.900 руб.;
- курсы повышения квалификации от 1.500 руб.
Престижные документы для аттестации

ВЫБРАТЬ КУРС СО СКИДКОЙ 50%

ВНИМАНИЕ: Скидка действует ТОЛЬКО сейчас!

(Лицензия на осуществление образовательной деятельности № 5201 выдана ООО "Инфоурок")

ИнфоурокИнформатикаДругие методич. материалыКонтрольная работа по информатике на тему "Алгоритмизация и программирование"

Контрольная работа по информатике на тему "Алгоритмизация и программирование"

библиотека
материалов
Скачать материал целиком можно бесплатно по ссылке внизу страницы.

Контрольная работа на тему

«Алгоритмизация и программирование»

9 класс

вариант 1


b:=4

a:=14-b*2

a:=a+a/3


a:=15

b:=14-a/3

a:=a+b*2

a:=5

b:=a*2

a:=(b+a)/2

b:=4*a-b

Задание 2.

алг

нач

цел s,k

s:=95

нц для k от 19 до 14 шаг -1

s:=s-4

кц

вывод s

кон

алг

нач

цел s,k

s:=5

нц для k от 11 до 17

s:=s+7

кц

вывод s

кон

алг

нач

цел s,k

s:=20;

k:=5

нц пока s<50

s:=s+5

k:=k+1

кц

вывод k

кон

Задание 3.

var p,i:integer;

Mas: array[1..11] of integer;

begin

Mas[1]:=15;

Mas[2]:=12;

Mas[3]:=10;

Mas[4]:=15;

Mas[5]:=10;

Mas[6]:=32;

Mas[7]:=14;

Mas[8]:=15;

Mas[9]:=20;

Mas[10]:=31;

Mas[11]:=13;

p:=1;

for i:=1 to 11 do

if i<4 then p:=p*Mas[i];

write (p)

end.


var s,i:integer;

Mas: array[1..11] of integer;

begin

Mas[1]:=15;

Mas[2]:=12;

Mas[3]:=10;

Mas[4]:=15;

Mas[5]:=10;

Mas[6]:=32;

Mas[7]:=14;

Mas[8]:=15;

Mas[9]:=20;

Mas[10]:=31;

Mas[11]:=13;

s:=0;

for i:=1 to 11 do

if i>6 then s:=s+Mas[i];

write (s)

end.

var m,k,i:integer;

Mas: array[1..7] of integer;

begin

Mas[1]:=10;

Mas[2]:=5;

Mas[3]:=7;

Mas[4]:=3;

Mas[5]:=9;

Mas[6]:=2;

Mas[7]:=4;

k:=0;

m:=2

for i:=2 to 7 do

if Mas[i]-Mas[i-1}>m then k:=k+1;

write (k)

end.









вариант 2

a:=30

b:=a/3

a:=a-b/2

b:=a-b


a:=6

b:=4

b:=a/3+b

a:=5*a-2*b

a:=8

b:=7

a:=a/2+2*b

b:=b-a/6

Задание 2.

алг

нач

цел s,k

s:=20;

k:=5

нц пока s<50

s:=s+k*2

k:=k+1

кц

вывод k

кон

алг

нач

цел s,k

s:=60

нц для k от 5 до 10

s:=s-k

кц

вывод s

кон

алг

нач

цел s,k

s:=60;

нц для k от -4 до 6

s:=s+2*k

кц

вывод s

кон

Задание 3.

var m,k,i:integer;

Mas: array[1..7] of integer;

begin

Mas[1]:=10;

Mas[2]:=5;

Mas[3]:=7;

Mas[4]:=3;

Mas[5]:=9;

Mas[6]:=2;

Mas[7]:=4;

k:=0;

m:=4;

for i:=2 to 7 do

if Mas[i]-Mas[i-1}

write (k)

end.


var k,m,l:integer;

Dat: array[1..11] of integer;

begin

Dat [1]:=35;

Dat [2]:=32;

Dat [3]:=31;

Dat [4]:=38;

Dat [5]:=37;

Dat [6]:=43;

Dat [7]:=34;

Dat [8]:=32;

Dat [9]:=39;

Dat [10]:=34;

Dat [11]:=36

l:=0;

m:=0

for k:=1 to 11 do

if Dat [k]>34 then

begin

m:=m+1;

l:=l+Dat[k]

end;

write (l/m)

end.

var m,k,i:integer;

Mas: array[1..7] of integer;

begin

Mas[1]:=10;

Mas[2]:=5;

Mas[3]:=7;

Mas[4]:=3;

Mas[5]:=9;

Mas[6]:=2;

Mas[7]:=4;

k:=0;

m:=2

for i:=2 to 7 do

if Mas[i]-Mas[i-1}>m then k:=k+1;

write (k)

end.






Общая информация

К учебнику: Информатика. Учебник для 8 класса.  Босова Л.Л., Босова А.Ю. 2-е изд., испр. - М.: 2014. - 160 с.

К уроку: Глава 3. Начала программирования

Показать все

Номер материала: ДБ-190571

Вам будут интересны эти курсы:

Курс повышения квалификации «Методика преподавания информатики в начальных классах»
Курс повышения квалификации «Современные информационные технологии и их использование в работе преподавателей. Системы автоматизированного проектирования одежды и организация технологического процесса»
Курс повышения квалификации «Основы создания интерактивного урока: от презентации до видеоурока»
Курс профессиональной переподготовки «Информатика: теория и методика преподавания в образовательной организации»
Курс «Фирменный стиль» (Corel Draw, Photoshop)
Курс «Оператор персонального компьютера»
Курс «3D Studio MAX»
Курс повышения квалификации «Сетевые и дистанционные (электронные) формы обучения в условиях реализации ФГОС по ТОП-50»
Курс профессиональной переподготовки «Информационные технологии в профессиональной деятельности: теория и методика преподавания в образовательной организации»
Курс повышения квалификации «Специфика преподавания информатики в начальных классах с учетом ФГОС НОО»
Курс повышения квалификации «Применение MS Word, Excel в финансовых расчетах»
Курс профессиональной переподготовки «Теория и методика обучения информатике в начальной школе»
Курс профессиональной переподготовки «Математика и информатика: теория и методика преподавания в образовательной организации»
Курс повышения квалификации «Современные тенденции цифровизации образования»
Курс повышение квалификации «Применение интерактивных образовательных платформ на примере платформы Moodle»

Благодарность за вклад в развитие крупнейшей онлайн-библиотеки методических разработок для учителей

Опубликуйте минимум 3 материала, чтобы БЕСПЛАТНО получить и скачать данную благодарность

Сертификат о создании сайта

Добавьте минимум пять материалов, чтобы получить сертификат о создании сайта

Грамота за использование ИКТ в работе педагога

Опубликуйте минимум 10 материалов, чтобы БЕСПЛАТНО получить и скачать данную грамоту

Свидетельство о представлении обобщённого педагогического опыта на Всероссийском уровне

Опубликуйте минимум 15 материалов, чтобы БЕСПЛАТНО получить и скачать данное cвидетельство

Грамота за высокий профессионализм, проявленный в процессе создания и развития собственного учительского сайта в рамках проекта "Инфоурок"

Опубликуйте минимум 20 материалов, чтобы БЕСПЛАТНО получить и скачать данную грамоту

Грамота за активное участие в работе над повышением качества образования совместно с проектом "Инфоурок"

Опубликуйте минимум 25 материалов, чтобы БЕСПЛАТНО получить и скачать данную грамоту

Почётная грамота за научно-просветительскую и образовательную деятельность в рамках проекта "Инфоурок"

Опубликуйте минимум 40 материалов, чтобы БЕСПЛАТНО получить и скачать данную почётную грамоту

Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.