Инфоурок / Информатика / Другие методич. материалы / Контрольная работа по информатике на тему "Алгоритмизация и программирование"
Обращаем Ваше внимание, что в соответствии с Федеральным законом N 273-ФЗ «Об образовании в Российской Федерации» в организациях, осуществляющих образовательную деятельность, организовывается обучение и воспитание обучающихся с ОВЗ как совместно с другими обучающимися, так и в отдельных классах или группах.

Педагогическая деятельность в соответствии с новым ФГОС требует от учителя наличия системы специальных знаний в области анатомии, физиологии, специальной психологии, дефектологии и социальной работы.

Только сейчас Вы можете пройти дистанционное обучение прямо на сайте "Инфоурок" со скидкой 40% по курсу повышения квалификации "Организация работы с обучающимися с ограниченными возможностями здоровья (ОВЗ)" (72 часа). По окончании курса Вы получите печатное удостоверение о повышении квалификации установленного образца (доставка удостоверения бесплатна).

Автор курса: Логинова Наталья Геннадьевна, кандидат педагогических наук, учитель высшей категории. Начало обучения новой группы: 27 сентября.

Подать заявку на этот курс    Смотреть список всех 216 курсов со скидкой 40%

Контрольная работа по информатике на тему "Алгоритмизация и программирование"

библиотека
материалов

Контрольная работа на тему

«Алгоритмизация и программирование»

9 класс

вариант 1


b:=4

a:=14-b*2

a:=a+a/3


a:=15

b:=14-a/3

a:=a+b*2

a:=5

b:=a*2

a:=(b+a)/2

b:=4*a-b

Задание 2.

алг

нач

цел s,k

s:=95

нц для k от 19 до 14 шаг -1

s:=s-4

кц

вывод s

кон

алг

нач

цел s,k

s:=5

нц для k от 11 до 17

s:=s+7

кц

вывод s

кон

алг

нач

цел s,k

s:=20;

k:=5

нц пока s<50

s:=s+5

k:=k+1

кц

вывод k

кон

Задание 3.

var p,i:integer;

Mas: array[1..11] of integer;

begin

Mas[1]:=15;

Mas[2]:=12;

Mas[3]:=10;

Mas[4]:=15;

Mas[5]:=10;

Mas[6]:=32;

Mas[7]:=14;

Mas[8]:=15;

Mas[9]:=20;

Mas[10]:=31;

Mas[11]:=13;

p:=1;

for i:=1 to 11 do

if i<4 then p:=p*Mas[i];

write (p)

end.


var s,i:integer;

Mas: array[1..11] of integer;

begin

Mas[1]:=15;

Mas[2]:=12;

Mas[3]:=10;

Mas[4]:=15;

Mas[5]:=10;

Mas[6]:=32;

Mas[7]:=14;

Mas[8]:=15;

Mas[9]:=20;

Mas[10]:=31;

Mas[11]:=13;

s:=0;

for i:=1 to 11 do

if i>6 then s:=s+Mas[i];

write (s)

end.

var m,k,i:integer;

Mas: array[1..7] of integer;

begin

Mas[1]:=10;

Mas[2]:=5;

Mas[3]:=7;

Mas[4]:=3;

Mas[5]:=9;

Mas[6]:=2;

Mas[7]:=4;

k:=0;

m:=2

for i:=2 to 7 do

if Mas[i]-Mas[i-1}>m then k:=k+1;

write (k)

end.









вариант 2

a:=30

b:=a/3

a:=a-b/2

b:=a-b


a:=6

b:=4

b:=a/3+b

a:=5*a-2*b

a:=8

b:=7

a:=a/2+2*b

b:=b-a/6

Задание 2.

алг

нач

цел s,k

s:=20;

k:=5

нц пока s<50

s:=s+k*2

k:=k+1

кц

вывод k

кон

алг

нач

цел s,k

s:=60

нц для k от 5 до 10

s:=s-k

кц

вывод s

кон

алг

нач

цел s,k

s:=60;

нц для k от -4 до 6

s:=s+2*k

кц

вывод s

кон

Задание 3.

var m,k,i:integer;

Mas: array[1..7] of integer;

begin

Mas[1]:=10;

Mas[2]:=5;

Mas[3]:=7;

Mas[4]:=3;

Mas[5]:=9;

Mas[6]:=2;

Mas[7]:=4;

k:=0;

m:=4;

for i:=2 to 7 do

if Mas[i]-Mas[i-1}

write (k)

end.


var k,m,l:integer;

Dat: array[1..11] of integer;

begin

Dat [1]:=35;

Dat [2]:=32;

Dat [3]:=31;

Dat [4]:=38;

Dat [5]:=37;

Dat [6]:=43;

Dat [7]:=34;

Dat [8]:=32;

Dat [9]:=39;

Dat [10]:=34;

Dat [11]:=36

l:=0;

m:=0

for k:=1 to 11 do

if Dat [k]>34 then

begin

m:=m+1;

l:=l+Dat[k]

end;

write (l/m)

end.

var m,k,i:integer;

Mas: array[1..7] of integer;

begin

Mas[1]:=10;

Mas[2]:=5;

Mas[3]:=7;

Mas[4]:=3;

Mas[5]:=9;

Mas[6]:=2;

Mas[7]:=4;

k:=0;

m:=2

for i:=2 to 7 do

if Mas[i]-Mas[i-1}>m then k:=k+1;

write (k)

end.








Самые низкие цены на курсы переподготовки

Специально для учителей, воспитателей и других работников системы образования действуют 50% скидки при обучении на курсах профессиональной переподготовки.

После окончания обучения выдаётся диплом о профессиональной переподготовке установленного образца с присвоением квалификации (признаётся при прохождении аттестации по всей России).

Обучение проходит заочно прямо на сайте проекта "Инфоурок", но в дипломе форма обучения не указывается.

Начало обучения ближайшей группы: 27 сентября. Оплата возможна в беспроцентную рассрочку (10% в начале обучения и 90% в конце обучения)!

Подайте заявку на интересующий Вас курс сейчас: https://infourok.ru

Общая информация

К учебнику: Информатика. Учебник для 8 класса.  Босова Л.Л., Босова А.Ю. 2-е изд., испр. - М.: 2014. - 160 с.

К уроку: Глава 3. Начала программирования

Показать все
Номер материала: ДБ-190571

Похожие материалы

2017 год объявлен годом экологии и особо охраняемых природных территорий в Российской Федерации. Министерство образования и науки рекомендует в 2017/2018 учебном году включать в программы воспитания и социализации образовательные события, приуроченные к году экологии.

Учителям 1-11 классов и воспитателям дошкольных ОУ вместе с ребятами рекомендуем принять участие в международном конкурсе «Законы экологии», приуроченном к году экологии. Участники конкурса проверят свои знания правил поведения на природе, узнают интересные факты о животных и растениях, занесённых в Красную книгу России. Все ученики будут награждены красочными наградными материалами, а учителя получат бесплатные свидетельства о подготовке участников и призёров международного конкурса.

Конкурс "Законы экологии"