Инфоурок / Информатика / Конспекты / Урок «Конструирование алгоритмов»
Обращаем Ваше внимание: Министерство образования и науки рекомендует в 2017/2018 учебном году включать в программы воспитания и социализации образовательные события, приуроченные к году экологии (2017 год объявлен годом экологии и особо охраняемых природных территорий в Российской Федерации).

Учителям 1-11 классов и воспитателям дошкольных ОУ вместе с ребятами рекомендуем принять участие в международном конкурсе «Я люблю природу», приуроченном к году экологии. Участники конкурса проверят свои знания правил поведения на природе, узнают интересные факты о животных и растениях, занесённых в Красную книгу России. Все ученики будут награждены красочными наградными материалами, а учителя получат бесплатные свидетельства о подготовке участников и призёров международного конкурса.

ПРИЁМ ЗАЯВОК ТОЛЬКО ДО 15 ДЕКАБРЯ!

Конкурс "Я люблю природу"

Урок «Конструирование алгоритмов»




Московские документы для аттестации!

124 курса профессиональной переподготовки от 4 795 руб.
274 курса повышения квалификации от 1 225 руб.

Для выбора курса воспользуйтесь поиском на сайте KURSY.ORG


Вы получите официальный Диплом или Удостоверение установленного образца в соответствии с требованиями государства (образовательная Лицензия № 038767 выдана ООО "Столичный учебный центр" Департаментом образования города МОСКВА).

ДИПЛОМ от Столичного учебного центра: KURSY.ORG


библиотека
материалов

Тема урока: «Конструирование алгоритмов»

Планируемые образовательные результаты:

предметные – представления о методах конструирования алгоритма; умения представлять план действий формального исполнителя по решению задачи укрупненными шагами (модулями), осуществлять детализацию каждого из укрупненных шагов формального исполнителя с помощью понятных ему команд;

метапредметные – умение самостоятельно планировать пути достижения целей; умение соотносить свои действия с планируемыми результатами, осуществлять контроль своей деятельности, определять способы действий в рамках предложенных условий, корректировать свои действия в соответствии с изменяющейся ситуацией; умение оценивать правильность выполнения учебной задачи;

личностные – алгоритмическое мышление, необходимое для профессиональной деятельности в современном обществе.

Решаемые учебные задачи:

  • познакомить учащихся с методом конструирования алгоритмов – методом пошаговой детализации;

  • рассмотреть пример разработки алгоритма методом пошаговой детализации для исполнителя Робот.

Основные понятия, рассматриваемые на уроке:

  • алгоритм;

  • последовательное построение алгоритма;

  • вспомогательный алгоритм;

  • формальные параметры;

  • фактические параметры;

  • рекурсивный алгоритм.

Используемые на уроке средства ИКТ:

  • персональный компьютер (ПК) учителя, мультимедийный проектор, экран, интерактивная доска;

  • ПК учащихся.

Электронные образовательные ресурсы:

Презентация «Конструирование алгоритмов».

Особенности изложения содержания темы урока

Предусмотрена работа с исполнителем Робот (среда Кумир).

Ход урока


I. Орг. момент.

II. Вопросы учащимся:

Назовите основные алгоритмические конструкции.

Дайте определение алгоритмической конструкции «следование».

Дайте определение алгоритмической конструкции «ветвление»

Дайте определение алгоритмической конструкции «повторение»

Какой схемой описывается каждая конструкция (слайд 1)

hello_html_m53a8dc1c.gif

III. 1)Попробуйте сформулировать известные русские пословицы по их блок-схемам (слайды 2-6)


hello_html_6e2cc252.gifhello_html_6b9c3b31.gif

hello_html_243c63c5.gifhello_html_4129d113.gif

hello_html_m15084a2.gif

2) Задача1. Реализован некоторый алгоритм в виде блок-схемы. Что получится на выходе блок-схемы, если:

А) х=0, у=1 б) х=2, у=4

hello_html_m6671801b.gifhello_html_m3ed59af2.gifhello_html_m41cc3a17.gifhello_html_m5ee72bad.gif

Z=у/х

hello_html_77f93098.gifhello_html_m32636c2c.gifhello_html_m32636c2c.gifhello_html_m32636c2c.gifhello_html_m650de166.gifhello_html_m10a314fd.gifhello_html_6867cbfb.gifhello_html_74027084.gifhello_html_6f7e72e4.gif
















3) Задача 2. Определите значение переменной F после выполнения фрагмента алгоритма.

F:=1

Нц для i от 1 до 5

F:=F*i

кц


трассировочная таблица

шаг

i

F

1

1

1

2

2

2

3

3

6

4

4

24

5

5

120

Ответ: 120

IV. Задания для исполнителя Робот. (работа за ПК учащихся)

Повторим набор команд входящих в СКИ.

Решение задач с обсуждением.

  1. Задача

hello_html_6d96d86.gif

Уточним условие. Считаем, что Робот находится, в самой крайней снизу клетке расположенной справа от стены.

Укрупнено план действий представим так:

  1. Закрасить клетки правее стены.

  2. Закрасить клетки над стеной.

использовать Робот
алг
нач
. нц пока слева стена
. . закрасить
. . вверх
. кц
. закрасить
. влево
. нц пока снизу стена
. . закрасить
. . влево
. кц
. вправо
кон




















2)Задача2. Робот закрашивает стену справа, сверху и возвращается в клетку, с которой начал.

Как нужно доработать задачу?


использовать Робот
алг
нач
. нц пока слева стена
. . закрасить
. . вверх
. кц
. закрасить
. влево
. нц пока снизу стена
. . закрасить
. . влево
. кц
. вправо
. нц пока клетка закрашена
. . вправо
. кц
. влево
. вниз
. нц пока клетка закрашена
. . вниз
. кц
. вверх
кон

























V. Самостоятельная работа.

3 варианта разного уровня сложности.

1 уровень:

hello_html_142b8022.gif

hello_html_m7d94b2c3.gif



2 уровень



hello_html_m5bd5551d.png

















3 уровень


hello_html_m1e0814be.png

hello_html_5fd4b4fc.png

Итог урока.

Домашнее задание. пар.3.5, 3.6. подготовиться к тесту.

9


Самые низкие цены на курсы переподготовки

Специально для учителей, воспитателей и других работников системы образования действуют 50% скидки при обучении на курсах профессиональной переподготовки.

После окончания обучения выдаётся диплом о профессиональной переподготовке установленного образца с присвоением квалификации (признаётся при прохождении аттестации по всей России).

Обучение проходит заочно прямо на сайте проекта "Инфоурок", но в дипломе форма обучения не указывается.

Начало обучения ближайшей группы: 13 декабря. Оплата возможна в беспроцентную рассрочку (10% в начале обучения и 90% в конце обучения)!

Подайте заявку на интересующий Вас курс сейчас: https://infourok.ru


Краткое описание документа:

Урок информатики для 9 класса. Информатика не является профилирующим предметом в   9-м классе, и изучается 2 часа в неделю. Согласно тематическому планированию на изучение темы «Конструирование алгоритмов» отведено 2 часа. По данной теме это 2-й урок. Учащиеся уже ознакомлены с понятием  алгоритма  и способами  описания  алгоритма. Тема «Конструирование алгоритмов» в среде исполнителя Робот включена в ГИА по информатике. Цель урока: познакомить учащихся с методом конструирования алгоритмов – методом пошаговой детализации; рассмотреть пример разработки алгоритма методом пошаговой детализации для исполнителя Робот.Для достижения поставленных целей я выбрала комбинированный урок. Дидактическая задача первого этапа урока - подготовка учащихся к активной работе на уроке, повторение пройденного материала по теме.  Второй этап урока - подготовка учащихся к активному и сознательному усвоению материала. Разбор задачи для исполнителя Робот, с последующим усложнением задания. Третий этап - самостоятельная работа учащихся с правом выбора уровня сложности. В результате проведения урока у учащихся должны быть закреплены знания и умения, которые необходимы для создания простейших  алгоритмов в среде исполнителя Робот. Сформированы навыки самостоятельной  отладки  программ в среде  исполнителя Робот.

Общая информация

Номер материала: 48643033030
Курсы профессиональной переподготовки
133 курса

Выдаем дипломы установленного образца

Заочное обучение - на сайте «Инфоурок»
(в дипломе форма обучения не указывается)

Начало обучения: 13 декабря
(набор групп каждую неделю)

Лицензия на образовательную деятельность
(№5201 выдана ООО «Инфоурок» 20.05.2016)


Скидка 50%

от 13 800  6 900 руб. / 300 часов

от 17 800  8 900 руб. / 600 часов

Выберите квалификацию, которая должна быть указана в Вашем дипломе:
... и ещё 87 других квалификаций, которые Вы можете получить

Похожие материалы

Получите наградные документы сразу с 38 конкурсов за один орг.взнос: Подробнее ->>