Добавить материал и получить бесплатное свидетельство о публикации в СМИ
Эл. №ФС77-60625 от 20.01.2015
Инфоурок / Информатика / Другие методич. материалы / Методические материалы для занятия "Логомиры. Черепашья геометрия"

Методические материалы для занятия "Логомиры. Черепашья геометрия"



Осталось всего 2 дня приёма заявок на
Международный конкурс "Мириады открытий"
(конкурс сразу по 24 предметам за один оргвзнос)


  • Информатика

Документы в архиве:

193.56 КБ Проект В деревне(для объясн).mwx
1.29 МБ Диплом начин. программиста.docx
101.07 КБ perexod.mwx
27.81 КБ fishing.mwx
2.62 МБ Черепашья геометрия.ppt
1.6 МБ маршр.лист Черепашья геометрия.docx
59.48 КБ черепашья геометрия(для объясн).mwx

Название документа Диплом начин. программиста.docx

Поделитесь материалом с коллегами:

hello_html_7798be98.pnghello_html_75fcfde4.gifначинающего программиста

в программе ЛогоМиры3.0

_______________________

_______________________

ученика(цы)_____________

_______________________



Городской физико-математический лагерь

МБОУ «Средняя общеобразовательная школа №39»

Рязань

25.03.2015

hello_html_7798be98.pnghello_html_75fcfde4.gifначинающего программиста

в программе ЛогоМиры3.0

_______________________

_______________________

ученика(цы)_____________

_______________________



Городской физико-математический лагерь

МБОУ «Средняя общеобразовательная школа №39»

Рязань

25.03.2015

hello_html_m3da45098.pngC:\Users\Елена Викторовна\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.IE5\JVSSMH3M\MC900441417[1].wmf



Название документа Черепашья геометрия.ppt

шаблон презентации Шумарина Вера Алексеевна,учитель ГКС(К)ОУ С(К)ОШ №11 VIIIв...
Ссылка на Интернет-сайт: http://пролого.рф/chto_takoe_logo_miri/
Проект «Переход»
Проект «Рыбалка»
Образец вашего проекта
Она могла перемещаться вперед-назад, вправо-влево. Кроме того, в нее был встр...
Изучая проблемы и решения управления роботами, ученые «играли» с механической...
Автором-отцом Лого является Сеймур Папер (Seymour Papert). Лого родился в 196...
Лого объединяет в себе черты многих языков программирования. 	Изучение Лого...
Черепашья геометрия
Познакомиться с программой ЛогоМиры 3.0: Программировать геометрические фигур...
Примеры проектов «Переход» и «Рыбалка» взяты на Интернет-сайте: http://пролог...
1 из 17

Описание презентации по отдельным слайдам:

№ слайда 1 шаблон презентации Шумарина Вера Алексеевна,учитель ГКС(К)ОУ С(К)ОШ №11 VIIIв
Описание слайда:

шаблон презентации Шумарина Вера Алексеевна,учитель ГКС(К)ОУ С(К)ОШ №11 VIIIвида. г. Балашов Сайт:http://pedsovet.su/ Счастливого пути!

№ слайда 2
Описание слайда:

№ слайда 3
Описание слайда:

№ слайда 4
Описание слайда:

№ слайда 5
Описание слайда:

№ слайда 6 Ссылка на Интернет-сайт: http://пролого.рф/chto_takoe_logo_miri/
Описание слайда:

Ссылка на Интернет-сайт: http://пролого.рф/chto_takoe_logo_miri/

№ слайда 7 Проект «Переход»
Описание слайда:

Проект «Переход»

№ слайда 8 Проект «Рыбалка»
Описание слайда:

Проект «Рыбалка»

№ слайда 9
Описание слайда:

№ слайда 10 Образец вашего проекта
Описание слайда:

Образец вашего проекта

№ слайда 11 Она могла перемещаться вперед-назад, вправо-влево. Кроме того, в нее был встр
Описание слайда:

Она могла перемещаться вперед-назад, вправо-влево. Кроме того, в нее был встроен опускающийся карандаш. Перемещая черепашку, можно было рисовать на листе бумаги. Позже появилась "компьютерная копия" этой игрушки. Язык управления черепашкой был назван Лого (по-гречески это означает «слово»).

№ слайда 12 Изучая проблемы и решения управления роботами, ученые «играли» с механической
Описание слайда:

Изучая проблемы и решения управления роботами, ученые «играли» с механической игрушкой — черепашкой, понимающей некоторые очень простые команды.

№ слайда 13 Автором-отцом Лого является Сеймур Папер (Seymour Papert). Лого родился в 196
Описание слайда:

Автором-отцом Лого является Сеймур Папер (Seymour Papert). Лого родился в 1967 году в Лаборатории Искусственного Интеллекта Массачусетского технологического института. (В том же институте появились первые компьютерные игры, там же зародилось движение хакеров). История создания Лого

№ слайда 14 Лого объединяет в себе черты многих языков программирования. 	Изучение Лого
Описание слайда:

Лого объединяет в себе черты многих языков программирования. Изучение Лого как начального языка значительно облегчает дальнейшее изучение профессиональных языков программирования.

№ слайда 15 Черепашья геометрия
Описание слайда:

Черепашья геометрия

№ слайда 16 Познакомиться с программой ЛогоМиры 3.0: Программировать геометрические фигур
Описание слайда:

Познакомиться с программой ЛогоМиры 3.0: Программировать геометрические фигуры. Создать свой мультфильм. Цель занятия:

№ слайда 17 Примеры проектов «Переход» и «Рыбалка» взяты на Интернет-сайте: http://пролог
Описание слайда:

Примеры проектов «Переход» и «Рыбалка» взяты на Интернет-сайте: http://пролого.рф/chto_takoe_logo_miri/

Название документа маршр.лист Черепашья геометрия.docx

Поделитесь материалом с коллегами:

hello_html_m5f863458.gifhello_html_m5f863458.gifhello_html_4c9bf25d.gifhello_html_m5f863458.gifhello_html_m6e2e65b3.gifМаршрутный листhello_html_7664a98b.pnghello_html_m7a41ed33.png

  1. Запустите программу ЛогоМиры 3.0

  2. В окне приветствия выберите «Новый проект».

  3. Выполните по шагам проект «Черепашья геометрия»



Проект «Черепашья геометрия»

Создайте черепашек, рисующих геометрические фигуры.C:\Users\Елена\Desktop\Для ЛОГО 2015\Скриншоты проекта\2015-03-21 12-05-10 Скриншот экрана.png



Остановить

Штамп

Рисование

Текст

Создание

черепашки




Шаг 1. Сначала установите размер листа проекта. Файл, Новый размер проекта, Полноэкранный.

Шаг 2. Сделайте заголовок проекта «Черепашья геометрия». Для этого создайте диалоговое окно с помощью кнопки с буквой А и напечатайте текст. Щелкните на текстовом окне правой кнопкой мыши и выберите пункт Прозрачный. Если надпись надо зафиксировать, используйте Штамп.

Шаг 3. Выберите инструмент Создание черепашки. Щелкните мышью в левой верхней части листа – там появится черепашка. Прикажите черепашке нарисовать квадрат. Для этого правой кнопкой мыши на черепашке вызовите контекстное меню и выберите Открыть рюкзак. На вкладке Процедуры напечатайте: C:\Users\Елена\Desktop\Для ЛОГО 2015\Скриншоты проекта\2015-03-21 12-27-56 Скриншот экрана.pngC:\Users\Елена\YandexDisk\Скриншоты\2015-03-21 22-18-39 Скриншот экрана.png

это квадрат

по

повтори 4 [вперед 60 направо 90] пп

конец

(по – перо опусти, пп – перо подними)

Затем закройте рюкзак и щелкните мышью по черепашке. Она нарисует квадрат черного цвета.

Шаг 4. С помощью контекстного меню откопируйте черепашку в нижний правый угол. Откройте рюкзак и измените процедуру:C:\Users\Елена\YandexDisk\Скриншоты\2015-03-21 22-54-32 Скриншот экрана.png

это квадрат3

по нц 15

повтори 4 [вперед 60 направо 90]

повтори 4 [вперед 40 направо 90]

повтори 4 [вперед 80 направо 90]

конец

(нц 15 – новый цвет 15). Затем закройте рюкзак и щелкните мышью по черепашке. Она нарисует три вложенных квадрата красного цвета с общей вершиной.

Шаг 5. Создайте новую черепашку в правом верхнем углу. Откройте рюкзак и напечатайте процедуру:

это треугольник
по
нц 68
нрп 5
повтори 3 [вп 80 пр 120]
пп
конец

(нрп 5 – новый размер пера 5). Затем закройте рюкзак и щелкните мышью по черепашке. Она нарисует треугольник зеленого цвета.

Шаг 6. Аналогично нарисуйте снежинку и восьмиконечную звезду, используя процедуры:


это снежинка
нрп 4
по
нц 108
повтори 32 [ вп 60 нд 60 пр 15 ]
конец


это звезда8
по нц 95 нрп 8
повтори 8 [вп 100 пр 135]
пп
конец



Шаг 7. Двойным щелчком по ластику удалите рисунки. Сделайте на листе кнопку. Для этого щелкните в любом месте листа инструментом C:\Program Files (x86)\ИНТ\ЛогоМиры 3.0\Techniques\content\images_content\Techniques_html_m3e8a5c11.png. Напишите в появившемся диалоговом окне в поле Надпись слово Пуск, в поле Инструкция - каждая [включить]. C:\Users\Елена\YandexDisk\Скриншоты\2015-03-22 12-32-47 Скриншот экрана.png

Сохраните проект.

Шаг 8. Скопируйте этот лист. Меню Листы, команда Копируй лист. Сохраните проект.

Шаг 9. В рюкзаке черепашки на вкладке Правила выберите Много раз и имя процедуры квадраты. На вкладке процедура напечатайте команды:

это квадраты

повтори 4 [вперед 60 направо 90]

направо 10

конец

Затем закройте рюкзак и щелкните мышью по черепашке. Она будет рисовать фигуру бесконечно. Нажмите в меню красную кнопку Остановить. Затем переместите черепашку в другое место (измените цвет и размер пера) и щелкните по ней. Получилась такая же фигура, но другого цвета. Нарисуйте с помощью этой черепашки узор из разноцветных фигур.

Шаг 10. Создайте новый лист. Придумайте свои фигуры. Создайте из них орнамент.


  1. Физкульт-пауза. Упражнения для глаз.

  2. После объяснения учителя выполните по шагам второй проект. Создайте мультфильм «В деревне».

Проект «В деревне»

Шаг 1. Создайте новый лист. Создайте новую черепашку.

Шаг 2. Щелкните по кнопке Рисование. Используйте встроенную картинку или нарисуйте сами дом, дорогу, тучи, деревья, цветы.

Шаг 3. Создайте новую черепашку в левом нижнем углу. Откройте рюкзак и напечатайте процедуру:

это забор

по нрп 4 нц 37

повтори 18 [вп 70 пр 45 вп 30 пр 90 вп 30 пр 45 вп 70 пр 180 жди 6]

пп

конец

Затем закройте рюкзак и щелкните мышью по черепашке. Она нарисует забор.

Шаг 4. Создайте новую черепашку на дороге. Поверните мышью её голову в сторону движения «мотоциклиста» и наденьте форму «мотоциклист». Правой кнопкой мыши вызовите контекстное меню и выберите команду оживить.

Шаг 5. Создайте новую черепашку на дороге. Поверните мышью её голову в сторону движения лошади (на панели Рисование, набор форм Движение). Выберите в наборе форм Движение сразу все «кадры» своего будущего мультфильма. Для этого нажмите и держите клавишу <shift> и щелкайте на формах-кадрах движущейся лошади. Теперь щелкните по черепашке. Она превратилась в лошадь. Нажмите на ней правой кнопкой мыши и выберите пункт Оживить.

Ссылка на Интернет-сайт: hello_html_m1649ead8.png

http://пролого.рф/chto_takoe_logo_miri/

3




57 вебинаров для учителей на разные темы
ПЕРЕЙТИ к бесплатному просмотру
(заказ свидетельства о просмотре - только до 11 декабря)


Краткое описание документа:

Публикация «ЛогоМиры. Черепашья геометрия» содержит методические материалы для проведения занятия по информатике в программе ЛогоМиры 3.0. для учащихся 7-8 класса. Методические материалы включают в себя: презентацию, маршрутный лист, примеры проектов, шаблон диплома начинающего программиста.

В презентации обозначены цели занятия, дан краткий экскурс в историю создания языка ЛогоМиры, по гиперссылкам демонстрируются готовые проекты «Переход» и «Рыбалка», взятые на Интернет-сайте http://пролого.рф/chto_takoe_logo_miri/.

С помощью маршрутного листа учащиеся выполняют на компьютерах проекты «Черепашья геометрия» и «В деревне». Примеры этих проектов для объяснения учащимся также содержатся в публикации.

Автор
Дата добавления 05.08.2015
Раздел Информатика
Подраздел Другие методич. материалы
Просмотров412
Номер материала ДA-001008
Получить свидетельство о публикации
Похожие материалы

Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.
Специальное предложение
Вверх