Добавить материал и получить бесплатное свидетельство о публикации в СМИ
Эл. №ФС77-60625 от 20.01.2015
Инфоурок / Информатика / Другие методич. материалы / Методическое пособие "Исполнитель Черепаха"

Методическое пособие "Исполнитель Черепаха"


  • Информатика

Документы в архиве:

10.46 КБ 254.gif
15.66 КБ ff2.jpg
3.1 КБ themedata.thmx
47.91 КБ lit.htm
8.45 КБ logo2.jpg
2 КБ menu.css
3.73 КБ menu.gif
3.62 КБ menu11.gif
3.08 КБ themedata.thmx
84.91 КБ plan.htm
12.76 КБ image001.png
13.1 КБ image002.png
6.56 КБ image003.png
3.32 КБ image004.png
6.38 КБ image005.png
3.27 КБ image006.png
8.4 КБ image007.png
5.19 КБ image008.png
8.41 КБ image009.png
5.24 КБ image010.png
2.56 КБ image011.png
2.04 КБ image012.png
6.87 КБ image013.png
3.67 КБ image014.png
7.48 КБ image015.png
3.95 КБ image016.png
7.38 КБ image017.png
4.58 КБ image018.png
2.35 КБ image019.png
3.1 КБ themedata.thmx
49.48 КБ primeri.htm
54.04 КБ 梥⮪.docx
1.34 МБ rec.PDF
69 КБ rep.gif
6.12 МБ prezent.pptx
541.97 КБ shema.jpg
2.38 КБ header.htm
3.08 КБ themedata.thmx
102.41 КБ t1.htm
14.36 КБ zadanie.docx
24.03 КБ Тема 1.docx
18.92 КБ Zadanie.docx
2.13 МБ prezent2.ppt
56.48 КБ pult.docx
58.94 КБ pult.png
2.38 КБ header.htm
337.4 КБ image001.png
4.39 КБ image002.jpg
319.64 КБ image003.png
4.14 КБ image004.jpg
58.94 КБ image005.png
3.08 КБ themedata.thmx
359.42 КБ t2.htm
741.81 КБ Тема 2.docx
670.45 КБ Черепаха.docx
2.38 КБ header.htm
3.08 КБ themedata.thmx
323.83 КБ t3.htm
25.54 КБ Тема 3.docx
2.38 КБ header.htm
13.54 КБ image001.png
6.05 КБ image002.jpg
12.9 КБ image003.png
5.04 КБ image004.jpg
9.14 КБ image005.png
3.2 КБ image006.jpg
9.22 КБ image009.png
3.96 КБ image010.jpg
14.33 КБ image011.png
5.15 КБ image012.jpg
14.41 КБ image015.png
5.14 КБ image016.jpg
106.89 КБ image017.png
3.69 КБ image018.jpg
108.66 КБ image019.png
6.17 КБ image020.jpg
107.15 КБ image021.png
6.69 КБ image022.jpg
107.39 КБ image023.png
5.35 КБ image024.jpg
3.08 КБ themedata.thmx
167.27 КБ t4.htm
535.54 КБ Тема 4.docx
2.38 КБ header.htm
9.21 КБ image001.png
3.93 КБ image002.jpg
14.25 КБ image003.png
5.43 КБ image004.jpg
16.44 КБ image005.png
9.17 КБ image006.jpg
3.08 КБ themedata.thmx
130.66 КБ t5.htm
660.3 КБ zvezda.docx
66.29 КБ Тема 5.docx
15.34 КБ image001.png
10.47 КБ image002.jpg
14.08 КБ image003.png
10.08 КБ image004.jpg
9.81 КБ image005.png
7.61 КБ image006.jpg
17.41 КБ image007.png
10.04 КБ image008.jpg
20.77 КБ image009.png
11.26 КБ image010.jpg
14.48 КБ image011.png
9.81 КБ image012.jpg
3.1 КБ themedata.thmx
109.35 КБ t6.htm
110.5 КБ Тема 6.docx
128.04 КБ Документ Microsoft Word.docx

Название документа 梥⮪.docx

Поделитесь материалом с коллегами:

использовать Черепаха

алг узор

нач

нц 12 раз

круг

влево (360/12)

кц

кон

алг круг

нач

нц 360 раз

вперед(1)

вправо (1)

кц

кон


hello_html_124e45ca.png

использовать Черепаха

алг узор

нач

нц n раз

круг

влево (360/n)

кц

кон

алг круг

нач

нц 360 раз

вперед(1)

вправо (1)

кц

кон


hello_html_m41437367.png




Название документа prezent.pptx

Поделитесь материалом с коллегами:

Разнообразие исполнителей Формальные исполнители Автоматизация ИСПОЛНИТЕЛИ ВО...
Ключевые слова Исполнитель Формальный исполнитель Система команд исполнителя...
Исполнитель – человек, группа людей, животное или техническое устройство, спо...
Более сложный исполнитель. Работает по программам, созданным человеком. Прог...
Исполнители-роботы
Система команд исполнителя Команды, которые может выполнять конкретный исполн...
 Замачивание Стирка Полоскание Отжим Сушка СКИ стиральной машины
Наименьшее общее кратное 42 30 2 3 5   2 3 7  
Что такое алгоритм Алгоритм – это конечная последовательность шагов в решении...
Самое главное Алгоритм – конечная последовательность шагов в решении задачи д...
Типы исполнителей Исполнители Формальные Неформальные
Неформальные и формальные исполнители В роли неформального исполнителя чаще в...
Неформальный исполнитель Неформальный исполнитель не всегда может выполнять о...
Формальный исполнитель Формальный исполнитель всегда одинаково выполняет одну...
Круг решаемых задач Ан-22: для перевозки грузов Ту-204: пассажирский самолёт...
Среда исполнителя - область, обстановка, условия, в которых действует исполни...
Система отказов исполнителя Отказ «Не понимаю» возникает, если подается коман...
Режимы работы исполнителя Непосредственный Программный СВЧ-печь может выполня...
Автоматизация - замена части труда человека работой машины: процесс решения з...
Самое главное Исполнитель – это человек, группа людей, животное или техническ...
Приведите 2-3 примера формальных исполнителей. Приведите пример, когда челове...
Охарактеризуйте следующих исполнителей: Давайте обсудим ?
1 из 22

Описание презентации по отдельным слайдам:

№ слайда 1 Разнообразие исполнителей Формальные исполнители Автоматизация ИСПОЛНИТЕЛИ ВО
Описание слайда:

Разнообразие исполнителей Формальные исполнители Автоматизация ИСПОЛНИТЕЛИ ВОКРУГ НАС

№ слайда 2 Ключевые слова Исполнитель Формальный исполнитель Система команд исполнителя
Описание слайда:

Ключевые слова Исполнитель Формальный исполнитель Система команд исполнителя Автоматизация

№ слайда 3 Исполнитель – человек, группа людей, животное или техническое устройство, спо
Описание слайда:

Исполнитель – человек, группа людей, животное или техническое устройство, способные выполнять определенный набор команд. Примеры: Объект - исполнитель ! Кнопка вкл/выкл электропитания на корпусе компьютера

№ слайда 4 Более сложный исполнитель. Работает по программам, созданным человеком. Прог
Описание слайда:

Более сложный исполнитель. Работает по программам, созданным человеком. Программы выбирает человек. Машина работает автоматически. Исполнитель - стиральная машина

№ слайда 5 Исполнители-роботы
Описание слайда:

Исполнители-роботы

№ слайда 6 Система команд исполнителя Команды, которые может выполнять конкретный исполн
Описание слайда:

Система команд исполнителя Команды, которые может выполнять конкретный исполнитель, образуют систему команд исполнителя (СКИ). Исполнитель формально выполняет алгоритмы, составленные из команд, входящих в его СКИ.                          

№ слайда 7  Замачивание Стирка Полоскание Отжим Сушка СКИ стиральной машины
Описание слайда:

Замачивание Стирка Полоскание Отжим Сушка СКИ стиральной машины

№ слайда 8 Наименьшее общее кратное 42 30 2 3 5   2 3 7  
Описание слайда:

Наименьшее общее кратное 42 30 2 3 5   2 3 7  

№ слайда 9 Что такое алгоритм Алгоритм – это конечная последовательность шагов в решении
Описание слайда:

Что такое алгоритм Алгоритм – это конечная последовательность шагов в решении задачи, приводящая от исходных данных к требуемому результату. ! 1. 2. 3...

№ слайда 10 Самое главное Алгоритм – конечная последовательность шагов в решении задачи д
Описание слайда:

Самое главное Алгоритм – конечная последовательность шагов в решении задачи для получения результатов из исходных данных Разрабатывает алгоритмы человек. Исполняет алгоритмы исполнитель.

№ слайда 11 Типы исполнителей Исполнители Формальные Неформальные
Описание слайда:

Типы исполнителей Исполнители Формальные Неформальные

№ слайда 12 Неформальные и формальные исполнители В роли неформального исполнителя чаще в
Описание слайда:

Неформальные и формальные исполнители В роли неформального исполнителя чаще всего выступает человек В роли формального исполнителя чаще всего выступает техническое устройство Неформальный исполнитель сам отвечает за свои действия За действия формального исполнителя отвечает управляющий им объект

№ слайда 13 Неформальный исполнитель Неформальный исполнитель не всегда может выполнять о
Описание слайда:

Неформальный исполнитель Неформальный исполнитель не всегда может выполнять одни и те же команды совершенно одинаково. Экскурсовод в Царскосельском лицее

№ слайда 14 Формальный исполнитель Формальный исполнитель всегда одинаково выполняет одну
Описание слайда:

Формальный исполнитель Формальный исполнитель всегда одинаково выполняет одну и ту же команду. Автоматический фасовочно-упаковочный аппарат Для каждого формального исполнителя можно указать: круг решаемых задач; среду; систему команд; систему отказов; режимы работы.

№ слайда 15 Круг решаемых задач Ан-22: для перевозки грузов Ту-204: пассажирский самолёт
Описание слайда:

Круг решаемых задач Ан-22: для перевозки грузов Ту-204: пассажирский самолёт ЯК-52: тренировочный самолёт

№ слайда 16 Среда исполнителя - область, обстановка, условия, в которых действует исполни
Описание слайда:

Среда исполнителя - область, обстановка, условия, в которых действует исполнитель. Среда исполнителя

№ слайда 17 Система отказов исполнителя Отказ «Не понимаю» возникает, если подается коман
Описание слайда:

Система отказов исполнителя Отказ «Не понимаю» возникает, если подается команда, не входящая в СКИ. Отказ «Не могу» возникает, если команда из СКИ не может быть выполнена в конкретных условиях среды. ? Стиральная машина не может выполнить команду «полоскание», если к машине не подведена вода. ?

№ слайда 18 Режимы работы исполнителя Непосредственный Программный СВЧ-печь может выполня
Описание слайда:

Режимы работы исполнителя Непосредственный Программный СВЧ-печь может выполнять отдельную команду – разогревать пищу СВЧ-печь способна приготовить сложное блюдо по заданной программе

№ слайда 19 Автоматизация - замена части труда человека работой машины: процесс решения з
Описание слайда:

Автоматизация - замена части труда человека работой машины: процесс решения задачи представляется в виде последовательности простейших операций; создаётся машина, способная выполнять эти операции в заданной последовательности; выполнение алгоритма поручается автоматическому устройству; человек освобождается от рутинной деятельности. Автоматизация

№ слайда 20 Самое главное Исполнитель – это человек, группа людей, животное или техническ
Описание слайда:

Самое главное Исполнитель – это человек, группа людей, животное или техническое устройство, способные выполнять заданные команды. Формальный исполнитель одну и ту же команду всегда выполняет одинаково. Для каждого формального исполнителя можно указать: круг решаемых задач; среду; систему команд; систему отказов; режимы работы.

№ слайда 21 Приведите 2-3 примера формальных исполнителей. Приведите пример, когда челове
Описание слайда:

Приведите 2-3 примера формальных исполнителей. Приведите пример, когда человек выступает в роли формального исполнителя. Приведите примеры исполнителей, встречающихся в русских народных сказках. Определите их типы. Давайте обсудим ?

№ слайда 22 Охарактеризуйте следующих исполнителей: Давайте обсудим ?
Описание слайда:

Охарактеризуйте следующих исполнителей: Давайте обсудим ?

Название документа zadanie.docx

Поделитесь материалом с коллегами:

  1. Напишите в столбик последовательность своих действий при:

    1. ежедневной чистке зубов:

______________________________________________________

______________________________________________________

______________________________________________________

______________________________________________________

______________________________________________________

    1. пришивании оторванной пуговицы:

______________________________________________________

______________________________________________________

______________________________________________________

______________________________________________________

______________________________________________________

  1. Продолжите фразы:

    1. Алгоритм – это ___________________________________

______________________________________________________

______________________________________________________

    1. Разрабатывать алгоритмы может только _____________

______________________________________________________

    1. Исполняют алгоритмы ____________________________

______________________________________________________

  1. Укажите истинное высказывание (отметьте точкой).

Алгоритм всегда представляет собой некоторую последовательность вычислений.

Алгоритм может представлять собой некоторую последовательность вычислений, а может – последовательность действий нематематического характера.

Алгоритм всегда представляет собой последовательность действий нематематического характера.

  1. Напишите в столбик последовательность своих действий при:

    1. ежедневной чистке зубов:

______________________________________________________

______________________________________________________

______________________________________________________

______________________________________________________

______________________________________________________

    1. пришивании оторванной пуговицы:

______________________________________________________

______________________________________________________

______________________________________________________

______________________________________________________

______________________________________________________

  1. Продолжите фразы:

    1. Алгоритм – это ___________________________________

______________________________________________________

______________________________________________________

    1. Разрабатывать алгоритмы может только _____________

______________________________________________________

    1. Исполняют алгоритмы ____________________________

______________________________________________________

  1. Укажите истинное высказывание (отметьте точкой).

Алгоритм всегда представляет собой некоторую последовательность вычислений.

Алгоритм может представлять собой некоторую последовательность вычислений, а может – последовательность действий нематематического характера.

Алгоритм всегда представляет собой последовательность действий нематематического характера.

  1. Продолжите фразы:

    1. Исполнитель – это __________________________________

________________________________________________________

    1. Система команд исполнителя (СКИ) - это _______________

________________________________________________________

    1. Робот – это ________________________________________

________________________________________________________

  1. Укажите истинные высказывания (отметьте «галочками»)

    1. Человек разрабатывает алгоритмы.

Человек управляет работой других исполнителей по выполнению алгоритмов.

Человек выполняет алгоритмы.

    1. Компьютер разрабатывает алгоритмы.

Компьютер управляет работой связанных с ним технических устройств по выполнению алгоритмов.

Компьютер сам выполняет алгоритмы (программы).

    1. Исполнитель разрабатывает алгоритмы.

Исполнитель управляет работой связанных с ним технических устройств по выполнению алгоритмов.

Исполнитель чётко и безошибочно выполняет алгоритмы, составленные из команд, входящих в его СКИ.

  1. Продолжите фразы:

  1. Исполнитель – это __________________________________

________________________________________________________

  1. Система команд исполнителя (СКИ) - это _______________

________________________________________________________

  1. Робот – это ________________________________________

________________________________________________________

  1. Укажите истинные высказывания (отметьте «галочками»)

  1. Человек разрабатывает алгоритмы.

Человек управляет работой других исполнителей по выполнению алгоритмов.

Человек выполняет алгоритмы.

  1. Компьютер разрабатывает алгоритмы.

Компьютер управляет работой связанных с ним технических устройств по выполнению алгоритмов.

Компьютер сам выполняет алгоритмы (программы).

  1. Исполнитель разрабатывает алгоритмы.

Исполнитель управляет работой связанных с ним технических устройств по выполнению алгоритмов.

Исполнитель чётко и безошибочно выполняет алгоритмы, составленные из команд, входящих в его СКИ.


Название документа Тема 1.docx

Поделитесь материалом с коллегами:

Тема 1: Понятие исполнителя. Формальный и неформальный исполнитель.

Планируемые образовательные результаты:

  • предметные – представления об исполнителе алгоритмов;

  • метапредметные – умения самостоятельно планировать пути достижения целей; соотносить свои действия с планируемыми результатами, осуществлять контроль своей деятельности, определять способы действий в рамках предложенных условий, корректировать свои действия в соответствии с изменяющейся ситуацией; оценивать правильность выполнения учебной задачи;

  • личностные – способность увязать учебное содержание с собственным жизненным опытом, понять значение развитого алгоритмического мышления для современного человека.

Решаемые учебные задачи:

  • закрепить представления об алгоритмах;

  • систематизировать представления учащихся об исполнителях;

  • сформировать представление о формальном исполнителе и его характеристиках;

  • сформировать общие представления о функциях, выполняемых человеком, компьютером и исполнителем алгоритмов.

Основные понятия, рассматриваемые на уроке:

  • алгоритм;

  • исполнитель;

  • система команд исполнителя; формальный исполнитель.

Электронные приложения:

  • презентация «Алгоритмы и исполнители». Издательство БИНОМ. Лаборатория знаний. Авторская мастерская Л.Л. Босовой

  • плакат «Алгоритмы и исполнители». Издательство БИНОМ. Лаборатория знаний. Авторская мастерская Л.Л. Босовой

Свободное программное обеспечение

Исполнитель Кузнечик в системе КуМир ( http://www.niisi.ru/kumir/ )

Особенности изложения содержания темы урока

Детям предлагается синонимичный ряд:

Синонимы:

актер, акын, артист, ашуг, аэд, бахиш, вагант, вокалист, выполнитель, гудошник, гусан, гусляр, девтерагонист, дудошник, ералашник, жирши, кантор, киноактер, лирник, мелод, музыкант, певец, песенник, песнопевец, подпевала, престидижитатор, производитель, протагонист, разработчик, рапсод, рожечник, сазандари, сателлит, сказитель, соисполнитель, солист, стрелочник, судисполнитель, судоисполнитель, танцор, тапер, трубач, фанфарист, фрилансер, шансонье, шахир, шестерка, шпрехшталмейстер, экзекутор



- Каким словом можно заменить все эти слова? (Исполнитель)

- Как мы видим, слово «исполнитель» имеет много различных значений. О каких исполнителях мы будем говорить на уроках информатики? (ИСПОЛНИТЕЛЬ в информатике -человек или автоматическое устройство, которому поручается исполнить алгоритм или программу.)

Современного человека окружает множество разнообразных технических устройств: телевизор, магнитофон, фотоаппарат, телефон, стиральная машина, автомобиль и пр. Каждое из этих устройств предназначено для решения своей задачи и способно выполнять некоторый ограниченный набор действий, или команд.

Исполнитель – это некоторый объект (человек, группа людей, животное, техническое устройство), способный выполнять определенный набор команд. Команды, которые может выполнить конкретный исполнитель, образуют систему команд исполнителя (СКИ).

Исполнители бывают разные. Одним из самых простых исполнителей можно считать кнопку включения/выключения электропитания на корпусе монитора.

Система команд исполнителя – CD-плеера приведена на слайде №3.

Более сложным исполнителем является современная стиральная машина, в электронную память которой заложены разработанные инженерами различные программы стирки белья. Весь процесс стирки (замачивание, отстирывание, полоскание, отжим, сушка) машина выполняет автоматически, без участия человека, но по программе, выбранной человеком.(для сравнения можно привести пример, как стирали с помощью стиральных машин прошлого поколения, тем самым сказать о ручном или непосредственном управлении).

Еще один пример исполнителя – компьютер. Его отличительная черта – универсальность. Вы знакомы с компьютерными программами, предназначенными для обработки текстовой, числовой и графической информации, с обучающими программами и компьютерными играми. Кроме того, существуют программы, с помощью которых компьютер управляет работой других связанных с ним устройств (исполнителей).

Во многих случаях и сам человек является исполнителем алгоритмов.

Задание №1 (1,2) на листе.

Исполнителями большого количества алгоритмов становятся школьники, выполняющие многочисленные письменные и устные задания.

Рассмотрите схему. Слайд №8. Какой процесс она описывает? (Нахождение наименьшего общего кратного - НОК). Можно ли данную схему назвать алгоритмом?

- Так что такое алгоритм? (Слайд №9)

Алгоритм может представлять собой описание некоторой последовательности вычислений, а может – описание последовательности действий нематематического характера. Но в любом случае, перед его составлением должны быть четко определены начальные условия и то, что предстоит получить.

- Кто может разрабатывать алгоритмы? (Разработчиком алгоритмов является только человек)

- Кто может исполнять алгоритмы? (Исполняют алгоритмы люди и всевозможные устройства – компьютеры, роботы, станки, спутники, сложная бытовая техника и даже некоторые детские игрушки)

Итак, исполнителями могут быть, как живые, так и неживые объекты. Как вы думаете, одинаково ли они будут подходить к исполнению алгоритмов? (Например, стирка вручную и с помощью стиральной машины). Нет. Стиральная машина одну и ту же программу каждый раз будет выполнять абсолютно одинаково, а человек при стирке одной и той же вещи каждый раз будет выполнять по-разному.

Выделяют два типа исполнителей: формальных и неформальных. Формальный исполнитель одну и ту же команду всегда выполняет одинаково. Неформальный исполнитель может выполнять команды по-разному.

Например, при многократном прослушивании диска с любимой музыкой вы можете быть уверены, что она воспроизводится проигрывателем (формальным исполнителем) одинаково. Но вряд ли кому-нибудь из певцов (неформальному исполнителю) удастся несколько раз совершенно одинаково исполнить песню из своего репертуара.

Как правило, человек выступает в роли неформального исполнителя. Формальными исполнителями являются преимущественно технические устройства. Человек в роли неформального исполнителя сам отвечает за свои действия. За действия формального исполнителя отвечает управляющий им объект.

Рассмотрим более подробно множество формальных исполнителей. Формальные исполнители необычайно разнообразны, но для каждого из них можно указать круг решаемых задач, среду, СКИ, систему отказов и режимы работы.

  1. Круг решаемых задач. Каждый исполнитель создается для решения определенного класса задач.

  2. Среда исполнителя. Область, обстановку, условия, в которых действует исполнитель, принято называть средой данного исполнителя.

  3. СКИ. Предписание о выполнении отдельного законченного действия исполнителя называется командой. Совокупность всех команд, которые могут быть выполнены некоторым исполнителем, образует СКИ – систему команд исполнителя.

  4. Система отказов исполнителя. Отказ «не понимаю» возникает тогда, когда исполнителю подается команда, не входящая в его СКИ. Отказ «не могу» возникает тогда, когда команда из СКИ не может быть им выполнена в конкретных условиях среды.

  5. Режимы работы исполнителя. Для большинства исполнителей предусмотрены режимы непосредственного и программного управления. В первом случае исполнитель ожидает команд от управляющего объекта и немедленно выполняет каждую поступившую команду. Во втором случае исполнителю сначала задается полная последовательность команд (программа), а затем он выполняет все эти команды в автоматическом режиме. Ряд исполнителей работает только в одном из названных режимов.

При наличии соответствующего программного обеспечения на этом уроке следует организовать работу учащихся по управлению некоторым исполнителем или в виртуальной лаборатории.

Домашнее задание

Выучить записи в тетради. Выполнить задания на листах.

3


Название документа Zadanie.docx

Поделитесь материалом с коллегами:













































































































































































































































































































































































































































































































































































































































































































































































































































































Название документа prezent2.ppt

Поделитесь материалом с коллегами:

Ключевые слова Исполнитель Черепаха Вспомогательный алгоритм Основной алгорит...
Знакомимся с Черепахой Исполнитель Черепаха предназначен для построения рисун...
Знакомимся с Черепахой Черепаха имеет хвост. Если хвост опущен, то при переме...
ПОДНЯТЬ ХВОСТ ОПУСТИТЬ ХВОСТ ВПЕРЕД() НАЗАД() ВПРАВО() ВЛЕВО() СКИ Черепахи !
Перемещение вперед/назад Команда ВПЕРЕД()	 НАЗАД(). !
Повороты вправо/влево Команда вправо() 			влево() !
Пример алгоритма Построен квадрат со стороной 100 пикселей(точек)
Строим прямоугольник
Черепаха учится Алгоритм рисования цифры 0 алг цифра_0 нач опустить хвост нц...
Индекс Красноярска алг ИНДЕКС КРАСНОЯРСКА нач ЦИФРА_6 ЦИФРА_6 ЦИФРА_0 ЦИФРА_0...
использовать Черепаха алг ряд ромбов нач 	влево(90) 	вперед(190) 	вправо(90)...
Самое главное Исполнитель Черепаха предназначен для построения рисунков на пл...
Самое главное Команда	Действие ПОДНЯТЬ ХВОСТ	Черепаха поднимает хвост ОПУСТИТ...
Охарактеризуйте исполнителя Черепаха. Составьте для Черепахи алгоритм рисован...
1 из 15

Описание презентации по отдельным слайдам:

№ слайда 1
Описание слайда:

№ слайда 2 Ключевые слова Исполнитель Черепаха Вспомогательный алгоритм Основной алгорит
Описание слайда:

Ключевые слова Исполнитель Черепаха Вспомогательный алгоритм Основной алгоритм Цикл n раз

№ слайда 3 Знакомимся с Черепахой Исполнитель Черепаха предназначен для построения рисун
Описание слайда:

Знакомимся с Черепахой Исполнитель Черепаха предназначен для построения рисунков на плоскости.

№ слайда 4 Знакомимся с Черепахой Черепаха имеет хвост. Если хвост опущен, то при переме
Описание слайда:

Знакомимся с Черепахой Черепаха имеет хвост. Если хвост опущен, то при перемещении остаётся след. При поднятом хвосте след не остаётся.

№ слайда 5 ПОДНЯТЬ ХВОСТ ОПУСТИТЬ ХВОСТ ВПЕРЕД() НАЗАД() ВПРАВО() ВЛЕВО() СКИ Черепахи !
Описание слайда:

ПОДНЯТЬ ХВОСТ ОПУСТИТЬ ХВОСТ ВПЕРЕД(<расстояние>) НАЗАД(<расстояние>) ВПРАВО(<угол>) ВЛЕВО(<угол>) СКИ Черепахи !

№ слайда 6 Перемещение вперед/назад Команда ВПЕРЕД()	 НАЗАД(). !
Описание слайда:

Перемещение вперед/назад Команда ВПЕРЕД(<расстояние>) НАЗАД(<расстояние>). !

№ слайда 7 Повороты вправо/влево Команда вправо() 			влево() !
Описание слайда:

Повороты вправо/влево Команда вправо(<угол>) влево(<угол>) !

№ слайда 8 Пример алгоритма Построен квадрат со стороной 100 пикселей(точек)
Описание слайда:

Пример алгоритма Построен квадрат со стороной 100 пикселей(точек)

№ слайда 9 Строим прямоугольник
Описание слайда:

Строим прямоугольник

№ слайда 10 Черепаха учится Алгоритм рисования цифры 0 алг цифра_0 нач опустить хвост нц
Описание слайда:

Черепаха учится Алгоритм рисования цифры 0 алг цифра_0 нач опустить хвост нц 4 раз вперед(50) вправо(90) кц вправо(90) поднять хвост вперед(60) влево(90) кон Алгоритм рисования цифры 6 алг цифра_6 нач опустить хвост нц 5 раз вперед(50) вправо(90) кц влево(45) вперед(50) поднять хвост назад(50) влево(45) назад(50) вправо(90) вперед(60) влево(90) кон

№ слайда 11 Индекс Красноярска алг ИНДЕКС КРАСНОЯРСКА нач ЦИФРА_6 ЦИФРА_6 ЦИФРА_0 ЦИФРА_0
Описание слайда:

Индекс Красноярска алг ИНДЕКС КРАСНОЯРСКА нач ЦИФРА_6 ЦИФРА_6 ЦИФРА_0 ЦИФРА_0 ЦИФРА_0 ЦИФРА_0 кон

№ слайда 12 использовать Черепаха алг ряд ромбов нач 	влево(90) 	вперед(190) 	вправо(90)
Описание слайда:

использовать Черепаха алг ряд ромбов нач влево(90) вперед(190) вправо(90) ромб ромб ромб ромб кон алг ромб нач нц 2 раз влево(30) вперед(100) вправо(60) вперед(100) вправо(150) кц вправо(90) вперед(100) влево(90) кон Цикл ПОВТОРИТЬ n РАЗ

№ слайда 13 Самое главное Исполнитель Черепаха предназначен для построения рисунков на пл
Описание слайда:

Самое главное Исполнитель Черепаха предназначен для построения рисунков на плоскости. Алгоритм, решающий некоторую подзадачу основной задачи, называется вспомогательным алгоритмом. Приказ на выполнение вспомогательного алгоритма записывается в основном алгоритме. Для повторения n раз некоторой команды используют конструкцию повторения – нц n раз

№ слайда 14 Самое главное Команда	Действие ПОДНЯТЬ ХВОСТ	Черепаха поднимает хвост ОПУСТИТ
Описание слайда:

Самое главное Команда Действие ПОДНЯТЬ ХВОСТ Черепаха поднимает хвост ОПУСТИТЬ ХВОСТ Черепаха опускает хвост ВПЕРЕД (А) / НАЗАД (А) Черепаха сдвигается вперед(назад) на А пикселей ВПРАВО (Б) / ВЛЕВО (Б) Черепаха поворачивается вправо(влево) на Б градусов

№ слайда 15 Охарактеризуйте исполнителя Черепаха. Составьте для Черепахи алгоритм рисован
Описание слайда:

Охарактеризуйте исполнителя Черепаха. Составьте для Черепахи алгоритм рисования прямоугольника Придумайте свои задачи для Черепахи. Давайте обсудим ?

Название документа pult.docx

Поделитесь материалом с коллегами:

hello_html_68f21731.png

Название документа Тема 2.docx

Поделитесь материалом с коллегами:

Тема 2: Исполнитель Черепаха. Режим непосредственного управления.

Планируемые образовательные результаты:

  • предметные – умения разработки алгоритмов для управления исполнителем;

  • метапредметные – умения самостоятельно планировать пути достижения целей; соотносить свои действия с планируемыми результатами, осуществлять контроль своей деятельности, определять способы действий в рамках предложенных условий, корректировать свои действия в соответствии с изменяющейся ситуацией; оценивать правильность выполнения учебной задачи; опыт и принятия решений и управления исполнителями с помощью составленных для них алгоритмов;

  • личностные – способность увязать учебное содержание с собственным жизненным опытом, понять значение развитого алгоритмического мышления для современного человека.

Решаемые учебные задачи:

  • развить представления учащихся об исполнителях;

  • дать представление об алгоритме как модели деятельности исполнителя;

  • познакомить с исполнителем Черепашка (среда, круг решаемых задач, СКИ, режимы работы, отказы).

Основные понятия, рассматриваемые на уроке:

  • алгоритм;

  • исполнитель;

  • формальный исполнитель;

  • круг решаемых задач;

  • среда исполнителя;

  • система команд исполнителя;

  • система отказов исполнителя;

  • режимы работы исполнителя (непосредственный, программный);

  • управление.

Электронные приложения:

  • презентация «Управление исполнителем Черепаха»

  • плакат «Алгоритмы и исполнители». Издательство БИНОМ. Лаборатория знаний. Авторская мастерская Л.Л. Босовой

Свободное программное обеспечение

Исполнитель Черепаха в системе КуМир ( http://www.niisi.ru/kumir/ )

Особенности изложения содержания темы урока



Среда исполнителя:

Черепаха – Исполнитель, способный передвигаться по плоскости. Только плоскость не разделена на квадраты и не имеет координат; это просто чистая и пустая плоскость. Можете считать её большой песчаной пустыней, размеры которой 500х500 шагов. Если Черепаха движется по пустыне с опущенным хвостом, то от неё остается след, если с поднятым, то следа нет. Хвостом управляют две команды:


ПОДНЯТЬ ХВОСТ hello_html_3533dea3.pngОПУСТИТЬ ХВОСТhello_html_4177242e.png





У Черепахи есть голова. Черепаха может двигаться только по прямой и только вперёд (в том направлении, куда она смотрит) или назад:

ВПЕРЕД (<расстояние>)

НАЗАД (<расстояние>)

Вместо слова <расстояние> мы должны поставить число. Расстояние измеряется в шагах.

Чтобы изменить направление движения Черепахи, мы должны приказать ей повернуться. Заставляют Черепаху повернуться две команды:

ВПРАВО (<угол>)

ВЛЕВО (<угол>)

Углы измеряются в градусах. Команда ВПРАВО (90) означает «повернись на 90 градусов вправо». Вместо слова <угол> вы можете записывать любое число.

При запуске исполнителя (команда верхнего меню Миры Черепаха) Черепаха находится в центре поля, хвост опущен, смотрит вниз.

Система команд исполнителя:

команда

комментарии

поднять хвост

Используется для рисования

опустить хвост

вперед (х)

Черепаха перемещается в указанном направлении на Х пикселей

назад (х)

вправо (х)

Черепаха поворачивается направо или налево на Х градусов

влево (х)



Замечание: Х может быть числом или арифметическим выражением.





Непосредственное управление Черепахой

Для непосредственного управления Черепахой используют пульт управления (команда верхнего меню Миры → Черепаха → Пульт).

Поле для ввода значения угла поворота

Циферблат для выбора угла поворота

Протокол – список выполненных команд

Поле для ввода значения для команд вперед и назад

Передача протокола в КуМир

Поле очищается, Черепаха перемещается в центр

hello_html_68f21731.png

Чтобы скрыть изображение Черепахи, щелкните по ней мышью. Второй щелчок возвращает Черепаху на поле.

Задание 1. Используя пульт управления, выполните программу:

опустить хвост

вперед (100)

вправо (120)

вперед (100)

вправо (120)

вперед (100)


  • Какую фигуру нарисовала Черепаха?

  • Как надо изменить программу, чтобы Черепаха нарисовала ту же самую фигуру, но в два раза больше?

  • Как изменится картинка, если все команды вперед заменить на команды назад?

  • Как изменится картинка, если все команды вправо заменить на команды влево?



Задание 2. Какой длины отрезок нарисует Черепаха при выполнении фрагмента программы:



  1. опустить хвост

назад (4)

вперед (5)

назад (1)

вперед (5)

назад (1)

  1. опустить хвост

вперед (2)

назад (3)

вперед (6)

назад (8)

вперед (2)

  1. опустить хвост

назад (2)

вперед (4)

назад (5)

вперед (4)

назад (1)

  1. опустить хвост

вперед (1)

назад (2)

вперед (1)

назад (2)

вперед (1)

Задание 3. На какой угол вправо повернется Черепаха после выполнения фрагмента программы:



  1. вправо (90)

влево (30)

вправо (10)

влево (20)

влево (50)

вправо (90)

  1. влево (180)

вправо (45)

вправо (45)

влево (20)

вправо (10)

влево (50)

  1. вправо (100)

влево (45)

вправо (50)

влево (45)

влево (10)

вправо (50)

  1. вправо (30)

влево (25)

влево (25)

вправо (30)

влево (50)

вправо (30)



Задание 4. На сколько пикселей относительно исходного положения сдвинется Черепаха после выполнения программы:



  1. поднять хвост

вперед (5)

назад (3)

вперед (5)

назад (4)

назад (3)

  1. поднять хвост

назад (5)

вперед (10)

назад (6)

вперед (5)

назад (1)

  1. поднять хвост

назад (1)

вперед (4)

назад (5)

вперед (2)

назад (1)

  1. поднять хвост

вперед (2)

назад (1)

вперед (3)

назад (2)

вперед (4)



Задание 5. На сколько пикселей относительно исходного положения сдвинется Черепаха после выполнения программы:



  1. опустить хвост

вперед (5)

вперед (5)

влево (45)

влево (45)

назад (5)

вперед (10)

  1. опустить хвост

вперед (4)

вперед (6)

влево (90)

влево (90)

влево (90)

вперед (5)



  1. опустить хвост

назад (6)

вправо (30)

вправо (60)

вперед (6)

назад (6)

назад (6)

  1. опустить хвост

вправо (90)

вправо (90)

вправо (90)

вперед (5)

назад (2)

назад (8)



Задание 6. Считая, что сторона одной клетки равна 20 пикселям, с помощью пульта управления нарисуй собаку.













































































































































































































Задание 7. Считая, что сторона одной клетки равна 20 пикселям, с помощью пульта управления нарисуй слона.











































































































































































































8


Название документа Черепаха.docx

Поделитесь материалом с коллегами:

Черепаха – Исполнитель, способный передвигаться по плоскости. Только плоскость не разделена на квадраты и не имеет координат; это просто чистая и пустая плоскость. Можете считать её большой песчаной пустыней. Если Черепаха движется по пустыне с опущенным хвостом, то от неё остается след, если с поднятым, то следа нет. Хвостом управляют две команды:



ПОДНЯТЬ ХВОСТ hello_html_3533dea3.pngОПУСТИТЬ ХВОСТhello_html_4177242e.png





У Черепахи есть голова. Черепаха может двигаться только по прямой и только вперёд (в том направлении, куда она смотрит) или назад:

ВПЕРЕД (<расстояние>)

НАЗАД (<расстояние>)

Вместо слова <расстояние> мы должны поставить число. Расстояние измеряется в шагах.

Чтобы изменить направление движения Черепахи, мы должны приказать ей повернуться. Заставляют Черепаху повернуться две команды:

ВПРАВО (<угол>)

ВЛЕВО (<угол>)

Углы измеряются в градусах. Команда ВПРАВО (90) означает «повернись на 90 градусов вправо». Вместо слова <угол> вы можете записывать любое число.



Название документа Тема 3.docx

Поделитесь материалом с коллегами:

Тема 3: Линейные алгоритмы в режиме непосредственного управления.

Планируемые образовательные результаты:

  • предметные – представления о линейных алгоритмах; умения разработки алгоритмов для управления исполнителем;

  • метапредметные – умения самостоятельно планировать пути достижения целей; соотносить свои действия с планируемыми результатами, осуществлять контроль своей деятельности, определять способы действий в рамках предложенных условий, корректировать свои действия в соответствии с изменяющейся ситуацией; оценивать правильность выполнения учебной задачи; опыт и принятия решений и управления исполнителями с помощью составленных для них алгоритмов;

  • личностные – способность увязать учебное содержание с собственным жизненным опытом, понять значение развитого алгоритмического мышления для современного человека.

Решаемые учебные задачи:

  • разить представления учащихся об исполнителях;

  • сформировать понятие линейного алгоритма;

  • научить составлению линейных алгоритмов для формальных исполнителей с заданной системой команд;

  • закрепить навыки управления исполнителем Черепаха.

Основные понятия, рассматриваемые на уроке:

  • алгоритм;

  • исполнитель;

  • формальный исполнитель;

  • круг решаемых задач;

  • среда исполнителя;

  • система команд исполнителя;

  • система отказов исполнителя;

  • режимы работы исполнителя (непосредственный, программный);

  • управление;

  • линейный алгоритм.

Электронные приложения:

  • презентация «Управление исполнителем Черепаха»

  • плакат «Алгоритмы и исполнители». Издательство БИНОМ. Лаборатория знаний. Авторская мастерская Л.Л. Босовой

Свободное программное обеспечение

Исполнитель Черепаха в системе КуМир ( http://www.niisi.ru/kumir/ )

Особенности изложения содержания темы урока

- Кого или что называют исполнителем алгоритма?

- Определите типы исполнителей в предложенных ситуациях:

  1. Симфонический оркестр исполняет музыкальное произведение. (формальный)

  2. Ученик 5 класса выполняет домашнее задание по информатике. (неформальный)

  3. Фармацевт готовит лекарство по рецепту. (формальный)

  4. Врач устанавливает причину плохого самочувствия пациента. (неформальный)

  5. Автомат на конвейере наполняет бутылки лимонадом. (формальный)

  6. Компьютер выполняет программу проверки правописания. (формальный)

- Продолжите предложения:

  1. Система команд исполнителя – это …

  2. Алгоритм – это …

  3. Разрабатывать алгоритм может только …

  4. Исполняют алгоритмы …

- С каким исполнителем мы познакомились на прошлом уроке?

- К какому типу исполнителей он относится?

- Каков его круг решаемых задач?

- В какой среде он работает?

- Какова его система команд?

- Когда может возникнуть ситуация отказа?

- В каких режимах может работать данный исполнитель?




круг решаемых задач

Исполнитель Черепаха предназначен для построения рисунков на плоскости.


среда

Черепаха живёт на квадратном поле со стороной 500 пикселей (точек). Поле ограничено рвом с водой. Черепаха может перемещаться по полю, но не может его покинуть. Черепаха рисует кончиком хвоста, перемещаясь вперёд или назад на указанное количество пикселей. Поворот Черепахи происходит относительно кончика хвоста либо по часовой стрелке (команда вправо), либо против часовой стрелки (команда влево) на указанное количество градусов.

При запуске исполнителя Черепаха находится в центре поля, хвост опущен, смотрит вниз.


система команд

поднять хвост

опустить хвост

Используется для рисования

вперед (Х)

назад (Х)

Черепаха перемещается в указанном направлении на Х пикселей.

вправо (Х)

влево (Х)

Черепаха поворачивается направо или налево на Х градусов.


Х может быть числом или арифметическим выражением.

система отказов

Не могу

Возникает, если команда из СКИ
не может быть выполнена в конкретных условиях среды.

Не понимаю

Возникает, если подается команда, не входящая в СКИ

режимы работы

Непосредственный

Для непосредственного управления Черепахой используют пульт управления

Программный



Чтобы скрыть изображение Черепахи, щелкните по ней мышью. Второй щелчок возвращает Черепаху на поле.

- В каком режиме мы управляли исполнителем Черепаха на прошлом уроке? (В режиме непосредственного управления).

- Как вы думаете, зачем это нужно?

Программистам часто приходится разбираться, почему не работает какой-то алгоритм, свой собственный или даже написанный другим человеком. Для этого нужно выполнить алгоритм вручную для каких-то исходных данных и сравнить результаты каждого шага с тем, что должно было получиться.

Нужно помнить, что мы работаем с формальными исполнителями, которые не могут обдумывать команды, а просто их выполняют.

- Вспомните, в какой последовательности выполнялись команды алгоритмов на прошлом уроке? (В порядке их следования)

- Как назвать алгоритм, в котором все действия выполняются последовательно друг за другом? (Линейный).

Алгоритм, в котором команды выполняются в порядке их записи, то есть последовательно друг за другом, называется линейным.

В дальнейшем будут рассмотрены программы с повторениями, с вложенными вызовами. Сегодня продолжается знакомство с привычными для детей линейными программами исполнителя Черепаха в режиме непосредственного управления.

Особое внимание следует обратить на построение алгоритма решения методом постепенной проработки деталей или, как говорят программисты, методом сверху вниз. Суть метода выражается фразой: сначала – общий план, затем – детали. Этот метод позволяет на ранней стадии разработки учитывать общую структуру будущей программы и, исходя из нее, программировать детали.

Метод «сверху вниз» широко используется не только в программировании, но и при проектировании сложных объектов в самых различных областях человеческой деятельности. однако в программировании он хорошо виден в «чистом» виде и, следовательно, удобен для анализа. При изучении этого метода полезна параллельная демонстрация его практического применения (всевозможные виды конструирования и планирования).

Задание 1. Считая, что сторона одной клетки равна 20 пикселям, с помощью пульта управления нарисуй портфель.









































































































































































































Задание 2. Считая, что сторона одной клетки равна 20 пикселям, с помощью пульта управления нарисуй улитку.













































































































































































































5


Название документа Тема 4.docx

Поделитесь материалом с коллегами:

Тема 4: Режим программного управления. Цикл k-раз. Правильный многоугольник. Окружность.

Планируемые образовательные результаты:

  • предметные – представления об алгоритмах с повторениями; умения разработки алгоритмов для управления исполнителем;

  • метапредметные – умения самостоятельно планировать пути достижения целей; соотносить свои действия с планируемыми результатами, осуществлять контроль своей деятельности, определять способы действий в рамках предложенных условий, корректировать свои действия в соответствии с изменяющейся ситуацией; оценивать правильность выполнения учебной задачи; опыт и принятия решений и управления исполнителями с помощью составленных для них алгоритмов;

  • личностные – способность увязать учебное содержание с собственным жизненным опытом, понять значение развитого алгоритмического мышления для современного человека.

Решаемые учебные задачи:

  • разить представления учащихся об исполнителях;

  • сформировать понятие циклического алгоритма;

  • познакомить с формой записи циклических алгоритмов для исполнителя Черепаха;

  • закрепить навыки управления исполнителем Черепаха.

Основные понятия, рассматриваемые на уроке:

  • алгоритм;

  • исполнитель;

  • управление;

  • циклический алгоритм;

  • режим программного управления.

Электронные приложения:

  • презентация «Управление исполнителем Черепаха»

  • плакат «Алгоритмы и исполнители». Издательство БИНОМ. Лаборатория знаний. Авторская мастерская Л.Л. Босовой

Свободное программное обеспечение

Исполнитель Черепаха в системе КуМир ( http://www.niisi.ru/kumir/ )

Особенности изложения содержания темы урока

Для объяснения нового, программного режима необходима мотивировка.

Учитель объясняет, что программу можно записывать в память компьютера. В качестве первого упражнения школьникам нужна простая задача. Например: поднять Черепаху на одну ступеньку лесенки. Высота и длина ступени – 45 пикселей.

Программа для решения задачи имеет вид:



использовать Черепаха

алг ступень

нач

вперед (45)

вправо (90)

вперед (45)

влево (90)

кон


hello_html_m136a2bc4.png

Для того, чтобы компьютер выполнил ее, достаточно задать команду верхнего меню: Выполнение Выполнить непрерывно (F9)

Что произойдет? Программа ступень записана в памяти компьютера. Сначала компьютер пытается найти эту команду в СКИ Черепахи. Там ее нет. Тогда поиск продолжается в памяти.

Что ищет компьютер? Он ищет запись вида

алг ступень ← заголовок программы

нач

... ← тело программы

кон ← окончание программы

Слова алг и кон отмечают начало и конец программы. Первое слово, расположенное за словом алг, компьютер воспринимает как имя программы (в нашем примере ступень). Его не разрешается опускать. За именем программы вплоть до слова кон располагается текст самой программы – ее тело.

Специальные слова, такие, как алг и кон, фиксируются в языке описаний команд исполнителя и предназначаются для конструирования фраз в этом языке. Сегодня будут введены и другие специальные слова. Мы их будем выделять полужирным шрифтом.

Обратите внимание на запись программы.

Для удобства восприятия человеком текста программы приняты следующие правила:

  1. программа записывается в столбик;

  2. слова алг и кон записываются друг под другом;

  3. команды, составляющие тело программы, записываются со смещением вправо;

  4. лишние пробелы и пустые строки служат для улучшения внешнего вида и читаемости программы.

Теперь можно сформулировать следующую задачу: как поднять Черепаху из исходного положения по лесенке к верхней границе пустыни, пользуясь написанной программой? (5 раз выполнить команду ступень).

использовать Черепаха

алг ступень

нач

нц 5 раз

вперед (45)

вправо (90)

вперед (45)

влево (90)

кц

кон

hello_html_25ce4d07.png

Задача 1. Напишите программу рисования квадрата со стороной 40.

Для начала попробуем рисовать квадрат шаг за шагом

Вскоре мы обнаруживаем, что повторяем одни и те же команды. Поэтому мы можем написать такую процедуру:

использовать Черепаха

алг квадрат

нач

вперед (40)

вправо (90)

вперед (40)

вправо (90)

вперед (40)

вправо (90)

вперед (40)

вправо (90)

кон

использовать Черепаха

алг квадрат

нач

нц 4 раз

вперед (40)

вправо (360/4)

кц

кон

hello_html_61534d7.png

Обратить внимание учащихся, что квадрат – это правильный четырехугольник. Правильный – значит имеет равные стороны и равные углы.

Каждое из четырех исполнений команды вперед – проходит по одной из сторон квадрата. Каждое из четырех исполнений команды вправо – поворот в одном из углов квадрата. Четыре поворота на 90hello_html_m28215024.gif в сумме дают поворот на360hello_html_m28215024.gif. Следовательно, после исполнения процедуры Черепаха стоит в том же самом месте и смотрит в ту же сторону, что и в начале.

Задача 2. Напишите программу рисования правильного (равностороннего) треугольника со стороной 40. Конечное положение Черепахи должно совпадать с начальным.

Наша главная трудность – понять, на сколько градусов следует поворачивать Черепаху в каждом углу. В помощь себе давайте придумаем новый персонаж – Ленивую Черепаху. Ленивая Черепаха понимает те же самые 6 команд, что и обычная. Но исполняет она только команды поворота влево и вправо. Все остальные команды она игнорирует, как будто их и не было. Она никуда не двигается, ничего не рисует и всегда находится в одном и том же месте. Но все повороты она исполняет точно так же, как обычная Черепаха. Поэтому она всегда повернута в ту же сторону, что и обычная Черепаха. (Можно воспользоваться не ленивой Черепахой, а магнитными фигурками)

Черепаха, рисующая треугольник, должна повернуться 3 раза – в трех вершинах треугольника. Значит, и Ленивая Черепаха повернется 3 раза на одном месте. Все повороты одинаковые. В сумме должен получиться поворот на 360hello_html_m28215024.gif. Следовательно, каждый из трех поворотов равен 360hello_html_m28215024.gif/3=120hello_html_m28215024.gif. Вот мы и получили нужную программу:

использовать Черепаха

алг треугольник

нач

нц 3 раз

вперед (40)

вправо (360/3)

кц

кон

hello_html_m4055e240.png

Домашнее задание: подумать, как изменить программу так, чтобы треугольник «стоял» на ребре, а не на вершине

Задача 3. Напишите программу рисования правильного 7-угольника со стороной 40. Слово «правильный» означает, что у него все стороны равны и все углы равны.

использовать Черепаха

алг семиугольник

нач

нц 7 раз

вперед (40)

вправо (360/7)

кц

кон


hello_html_m5330255d.png

Единственное, что нам пока неизвестно, - на какой угол поворачивать. Здесь снова приходит на помощь Ленивая Черепаха. Исполняя нашу программу, она повернется 7 раз на один и тот же угол, а в сумме это должно составить 360hello_html_m28215024.gif. Значит, каждый поворот равен 360hello_html_m78acb414.gif. Прямо в таком виде, не вычисляя, его можно вставить в программу (только значок «градус» надо убрать).

Задача 3.1. Напишите программу рисования:

  1. правильного 5-угольника;

  2. правильного 6-угольника;

  3. правильного 8-угольника;

  4. правильного 9-угольника;

  5. правильного 17-угольника;

Рисуем окружность.

Черепаха умеет рисовать только прямолинейные отрезки. Поэтому нарисовать точную окружность она не сможет. Но если начертить, например, правильный 120-угольник или, тем более, правильный 360-угольник, то его на глаз невозможно будет отличить от окружности. Только сторону многоугольника нужно брать очень маленькую. Например, так:

нц 120 раз

вперед (1)

вправо (360/120)

кц

использовать Черепаха

алг окружность

нач

нц 360 раз

вперед (1)

вправо (360/360)

кц

кон


hello_html_m460b7671.png

Рисуем звезды.

Задача 4. Напишите программу рисования 5-конечной звезды.

Понаблюдаем внимательно за поворотами Ленивой Черепахи в момент, когда Черепаха проходит вершины лучей звезды. Мы убеждаемся в том, что она делает не один, а два полных оборота, т.е. поворачивается в сумме на 2*360hello_html_m28215024.gif= 720hello_html_m28215024.gif. Поскольку вершин всего 5, на каждый поворот приходится 720hello_html_m28215024.gif/5=144hello_html_m28215024.gif.

использовать Черепаха

алг звезда

нач

нц 5 раз

вперед (70)

вправо (2*360/5)

кц

кон

hello_html_3d57b035.png

Мы в самом деле получили звезду, но слегка повернутую. Чтобы получить звезду в правильном положении, нужно в самом начале программы повернуть Черепаху вправо на 18hello_html_m28215024.gif - проверьте!

использовать Черепаха

алг звезда

нач

вправо (18)

нц 5 раз

вперед (70)

вправо (2*360/5)

кц

кон

hello_html_m29d59210.png

Задача 5. Напишите программу, рисующую 8-конечную звезду. (9-конечную)

использовать Черепаха

алг звезда

нач

нц 8 раз

вперед (70)

вправо (3*360/8)

кц

кон

hello_html_m42ed6d84.png

использовать Черепаха

алг звезда

нач

нц 9 раз

вперед (70)

вправо (4*360/9)

кц

кон

hello_html_20c0acb4.png


9


Название документа zvezda.docx

Поделитесь материалом с коллегами:

использовать Черепаха

алг звезда

нач

нц 5 раз

вперед (70)

вправо (2*360/5)

кц

кон

hello_html_3d57b035.png

использовать Черепаха

алг звезда

нач

вправо (18)

нц 5 раз

вперед (70)

вправо (2*360/5)

кц

кон

hello_html_m29d59210.png

использовать Черепаха

алг звезда

нач

нц 7 раз

вперед (70)

вправо (2*360/7)

кц

кон

hello_html_m72eb3e27.png

использовать Черепаха

алг звезда

нач

нц 7 раз

вперед (70)

вправо (3*360/7)

кц

кон

hello_html_1bce4199.png

использовать Черепаха

алг звезда

нач

нц 8 раз

вперед (70)

вправо (3*360/8)

кц

кон

hello_html_m42ed6d84.png

использовать Черепаха

алг звезда

нач

нц 9 раз

вперед (70)

вправо (4*360/9)

кц

кон

hello_html_20c0acb4.png



Название документа Тема 5.docx

Поделитесь материалом с коллегами:

Тема 5: Режим программного управления. Вложенные вызовы.

Планируемые образовательные результаты:

  • предметные – умения разработки алгоритмов для управления исполнителем;

  • метапредметные – умения самостоятельно планировать пути достижения целей; соотносить свои действия с планируемыми результатами, осуществлять контроль своей деятельности, определять способы действий в рамках предложенных условий, корректировать свои действия в соответствии с изменяющейся ситуацией; оценивать правильность выполнения учебной задачи; опыт и принятия решений и управления исполнителями с помощью составленных для них алгоритмов;

  • личностные – способность увязать учебное содержание с собственным жизненным опытом, понять значение развитого алгоритмического мышления для современного человека.

Решаемые учебные задачи:

  • разить представления учащихся об исполнителях;

  • познакомить со вспомогательными алгоритмами;

  • закрепить навыки управления исполнителем Черепаха.

Основные понятия, рассматриваемые на уроке:

  • алгоритм;

  • исполнитель;

  • управление;

  • основной алгоритм;

  • вспомогательный алгоритм;

  • система команд исполнителя;

  • система отказов исполнителя;

  • режим программного управления.

Электронные приложения:

  • презентация «Управление исполнителем Черепаха»

  • плакат «Алгоритмы и исполнители». Издательство БИНОМ. Лаборатория знаний. Авторская мастерская Л.Л. Босовой

Свободное программное обеспечение

Исполнитель Черепаха в системе КуМир ( http://www.niisi.ru/kumir/ )

Особенности изложения содержания темы урока

Работа с опорными вопросами темы «Алгоритмизация»



Задача 1. Напишите программу рисования «стоячего треугольника» и оформите ее в виде процедуры под названием треугольник.

использовать Черепаха

алг треугольник

нач

вправо (30)

нц 3 раз

вперед (40)

вправо (360/3)

кц

кон


hello_html_m43daed2d.png



Задача 2. Пользуясь процедурами квадрат и треугольник, напишите программу рисования домика.

использовать Черепаха

алг дом

нач

квадрат

повернуться

треугольник

кон




hello_html_m1307cba2.png

- Что будет, если описывая на поле памяти какую-нибудь новую команду дом, использовать команды квадрат, повернуться, треугольник?

Команды квадрат, повернуться, треугольник не входят в СКИ Черепахи. Нет описания этих команд и в поле памяти. Следовательно, при попытке выполнить дом последует сообщение «Нет такого алгоритма (2702)». (Аварийная ситуация «Не понимаю»)

А что, если их описать, например, так:

алг квадрат

нач

нц 4 раз

вперед (100)

вправо (360/4)

кц

кон



алг повернуться

нач

вперед (100)

вправо (30)

кон



алг треугольник

нач

нц 3 раз

вперед (100)

вправо (360/3)

кц

кон


Теперь все в порядке. По команде дом Черепахе будут переданы команды вперед(100), вправо(360/4), вперед(100), вправо(30), вперед(100), вправо(360/3).

Составляя программы, можно пользоваться как командами из СКИ Черепахи, так и программами, описанными в памяти компьютера. Программы как бы расширяют СКИ робота. Чтобы выполнить действия, описанные в программе, достаточно написать ее имя.

Обращение к программе из другой программы называется вложенным вызовом (процедурой).

Когда код нужно оформлять в отдельную процедуру?

Дробление программы на процедуры должно выполняться по правилам функционального разбиения алгоритма на части, методом нисходящей разработки (сверху вниз: от общего к частному).

Бывают отступления от нисходящего метода, например, при использовании процедур, написанных ранее, но принцип функциональности должен работать всегда.

Программа, разбитая на смысловые процедуры, гораздо легче читается, отлаживается и сопровождается, чем программа, состоящая из процедур с механическим делением на части по объему кода.

Дело в том, что команды квадрат, повернуться, треугольник лучше отражают суть действий, чем безликие наборы «назад (40), вправо (90), вперед (40), влево (90), вперед (40)».

Иногда имеет смысл выделить в процедуру даже одну команду.

Процедурное программирование

Программирование с помощью процедур (процедурное программирование) существенно облегчает труд.

Во-первых, написав процедуру, можно использовать ее, вызывая неоднократно из разных мест программы.

Во-вторых, разбивая программу на маленькие кирпичики, программист получает возможность описывать короткие простые действия.

В-третьих, разделение на процедуры позволяет работать над большим проектом коллективу программистов.

В связи с этим можно предложить организовать работу учащихся по группам, где в группе каждый ученик будет отвечать за написание своей процедуры. А затем, все эти процедуры объединить в одну общую программу с вложенными вызовами.



Задача 3.

использовать Черепаха

алг рисунок

нач

переместиться

квадрат

треугольник

сместиться

звезда

перейти

круг

кон


hello_html_1c18c00e.png

алг переместиться

нач

поднять хвост

влево (90)

вперед (249)

влево (90)

вперед (149)

опустить хвост

кон

алг квадрат

нач

нц 4 раз

вперед (100)

влево (90)

кц

кон

алг треугольник

нач

влево (90)

нц 3 раз

вперед (100)

влево (360/3)

кц

кон

алг сместиться

нач

поднять хвост

влево (90)

вперед (200)

вправо (90)

вперед (100)

влево (72)

опустить хвост

кон

алг звезда

нач

нц 5 раз

вперед(70)

вправо (2*360/5)

кц

кон

алг перейти

нач

поднять хвост

вправо (72)

вперед (150)

влево (90)

опустить хвост

кон

алг круг

нач

нц 60 раз

вперед (10)

вправо (360/60)

кц

кон




8


Название документа Тема 6.docx

Поделитесь материалом с коллегами:

Тема 6: Создание рисунков

Планируемые образовательные результаты:

  • предметные – умения разработки алгоритмов для управления исполнителем;

  • метапредметные – умения самостоятельно планировать пути достижения целей; соотносить свои действия с планируемыми результатами, осуществлять контроль своей деятельности, определять способы действий в рамках предложенных условий, корректировать свои действия в соответствии с изменяющейся ситуацией; оценивать правильность выполнения учебной задачи; опыт и принятия решений и управления исполнителями с помощью составленных для них алгоритмов;

  • личностные – способность увязать учебное содержание с собственным жизненным опытом, понять значение развитого алгоритмического мышления для современного человека.

Решаемые учебные задачи:

  • разить представления учащихся об исполнителях;

  • познакомить со вспомогательными алгоритмами;

  • закрепить навыки управления исполнителем Черепаха.

Основные понятия, рассматриваемые на уроке:

  • алгоритм;

  • исполнитель;

  • управление;

  • основной алгоритм;

  • вспомогательный алгоритм;

  • система команд исполнителя;

  • система отказов исполнителя;

  • режим программного управления.

Электронные приложения:

  • презентация «Управление исполнителем Черепаха»

  • плакат «Алгоритмы и исполнители». Издательство БИНОМ. Лаборатория знаний. Авторская мастерская Л.Л. Босовой

Свободное программное обеспечение

Исполнитель Черепаха в системе КуМир ( http://www.niisi.ru/kumir/ )

Особенности изложения содержания темы урока

Работа с опорными вопросами темы «Алгоритмизация»



использовать Черепаха

алг рисунок

нач

нц 6 раз

вправо(60)

вперед(50)

соты

кц

кон

алг соты

нач

нц 6 раз

влево(60)

вперед(20)

кц

кон


hello_html_m651a09e6.png

использовать Черепаха

алг рисунок

нач

нц 4 раз

квадрат

вправо (90)

кц

кон

алг квадрат

нач

нц 4 раз

вперед (70)

влево (90)

кц

кон

hello_html_55f334eb.png

использовать Черепаха

алг рисунок

нач

нц 3 раз

треугольник

вперед (70)

вправо (360/3)

кц

кон

алг треугольник

нач

нц 3 раз

вперед (30)

влево (360/3)

кц

кон

hello_html_m7e8acafd.png

использовать Черепаха

алг рисунок

нач

нц 8 раз

ход

вправо(45)

вперед (70)

вправо (360/8)

кц

кон

алг ход

нач

влево(45)

нц 8 раз

вперед (30)

влево (360/8)

кц

кон

hello_html_m700db887.png

использовать Черепаха

алг узор

нач

влево(90)

нц 12 раз

нц 2 раз

нц 50 раз

вперед(4)

вправо(1)

кц

вправо(130)

кц

вправо(30)

кц

кон


hello_html_m5d97c25a.png

использовать Черепаха

алг узор

нач

нц 4 раз

треугольник

переход

квадрат

переход

кц

кон

алг треугольник

нач

влево (90)

нц 3 раз

вперед (50)

вправо (360/3)

кц

кон

алг переход

нач

поднять хвост

влево (90)

вперед (1)

влево (90)

опустить хвост

кон

алг квадрат

нач

нц 4 раз

вперед (50)

вправо (90)

кц

кон


hello_html_m70a1c6e0.png



Название документа Документ Microsoft Word.docx

Поделитесь материалом с коллегами:

C:\Users\on\Desktop\1\cvetok.png

C:\Users\on\Desktop\1\dom.png

C:\Users\on\Desktop\1\krug.png

C:\Users\on\Desktop\1\pchela.png

C:\Users\on\Desktop\1\risunok.png

C:\Users\on\Desktop\1\risunok1.png

C:\Users\on\Desktop\1\rom.png

C:\Users\on\Desktop\1\uzor.png

C:\Users\on\Desktop\1\uzor2.png

C:\Users\on\Desktop\1\zvezda.png






Автор
Дата добавления 23.11.2015
Раздел Информатика
Подраздел Другие методич. материалы
Просмотров3383
Номер материала ДВ-180702
Получить свидетельство о публикации

Похожие материалы

Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.
Специальное предложение
Вверх