Инфоурок / Информатика / Конспекты / Открытый урок по информатику на тему "Моделирование случайных процессов в среде табличного процессора" (9 класс)
Обращаем Ваше внимание: Министерство образования и науки рекомендует в 2017/2018 учебном году включать в программы воспитания и социализации образовательные события, приуроченные к году экологии (2017 год объявлен годом экологии и особо охраняемых природных территорий в Российской Федерации).

Учителям 1-11 классов и воспитателям дошкольных ОУ вместе с ребятами рекомендуем принять участие в международном конкурсе «Законы экологии», приуроченном к году экологии. Участники конкурса проверят свои знания правил поведения на природе, узнают интересные факты о животных и растениях, занесённых в Красную книгу России. Все ученики будут награждены красочными наградными материалами, а учителя получат бесплатные свидетельства о подготовке участников и призёров международного конкурса.

ПРИЁМ ЗАЯВОК ТОЛЬКО ДО 21 ОКТЯБРЯ!

Конкурс "Законы экологии"

Открытый урок по информатику на тему "Моделирование случайных процессов в среде табличного процессора" (9 класс)

Такого ещё не было!
Скидка 70% на курсы повышения квалификации

Количество мест со скидкой ограничено!
Обучение проходит заочно прямо на сайте проекта "Инфоурок"

(Лицензия на осуществление образовательной деятельности № 5201 выдана ООО "Инфоурок" 20 мая 2016 г. бессрочно).


Список курсов, на которые распространяется скидка 70%:

Курсы повышения квалификации (144 часа, 1800 рублей):

Курсы повышения квалификации (108 часов, 1500 рублей):

Курсы повышения квалификации (72 часа, 1200 рублей):
библиотека
материалов


Учитель: Свинобоев И.С.


Предмет: Информатика


Класс: 9 класс


Профиль: естественно- математический

Тип урока: Комбинированный - урок формирования и закрепления умений и навыков практического использования MS Excel.


Тема урока: Моделирование случайных процессов в среде табличного процессора

Цель урока: научиться моделировать случайные процессы в электронных таблицах

Задачи урока

Образовательные:

  • повторить и закрепить знания и умения работы в MS Excel;

  • отработать основные приемы работы с электронными таблицами.

Воспитательные:

  • воспитывать общую и информационную культуру, трудолюбие, усидчивость, терпение, бережное отношение к школьной технике.

Развивающие:

  • Развивать логическое мышление, способность к анализу.



Оборудование урока:

    • приложение MS Windows – ЭТ MS Excel;

    • карточки – задания для практической работы.

Ход урока

I. Организационный момент: приветствие. (2 мин)

Проверка готовности учащихся к уроку, отметка отсутствующих, объявление темы и цели урока.

При выполнении работы должны соблюдаться правила ТБ при работе за ПК и правила поведения в компьютерном классе.

II. Постановка темы и целей урока. (2 мин) Слайд 1,2

III. Объяснение нового материала. (16 мин)

Предлагается учащимся решить следующую задачу «Бросание монеты» Слайд 3

I этап. Постановка задачи. Слайд 4

Бросание монеты

Решение задач на компьютере обычно разделяют на несколько этапов.

А. Описание задачи:

У вас есть 10 монет. Вы хотите увеличить свой капитал в два раза, испытав заодно и свою судьбу. Суть игра проста. Играя с маклером, вы делаете ставку и бросаете монету. Если выпадает «орел», маклер выдает вам сумму вашей ставки, в противном случае – вы ему отдаете эту сумму. Ставка может быть любой: от 1 до 10. Вы можете назначить самую большую ставку в 10 монет, и тогда за один бросок выясниться, «сорвали» ли вы банк или, наоборот, обанкротились. Опытные игроки действуют более осторожно, начиная с маленькой ставки.

B. Цель моделирования: Слайд 5

Выяснить, какая тактика чаще приводит к результату (положительному или отрицательному).

C. Формализация задачи: Слайд 6

Каков характер процесса? Случайный

Чем характеризуется игрок? Начальным капиталом Кнач, Ставкой СТ, Текущей наличностью Ктек

Чем характеризуется монета? Положение (орел/решка)

II этап. Разработка модели. Слайд 8

A. Информационная модель: (Составление модели по условию задачи). Слайд 9

 

Объект

Параметры

Действия

название

значение

Игрок

Начальным капиталом Кнач


Ставкой СТ


Текущей наличностью Ктек

Исходные данные

Исходные данные

Расчетные данные


Выбор ставки


Вычисление наличности



Продолжение игры

Маклер

Бросок


Выигрыш


Проигрыш

Расчетные данные

Расчетные данные

Расчетные данные

Выплата проигранного


Прекращение игры по банкротству

Монета

Вероятность угадывания результата

Положение «орел/решка»

Константа

Расчетные данные

Подбрасывание монет

Определение результата падения

Для обработки используются стандартные логические и статистические функции, имеющиеся во многих средах

V. Самостоятельная работа. (14 мин) Слайд 10

С помощью электронной таблицы учащимся предлагается построить компьютерную модель.

Заполняют учащиеся по образцу расчетную таблицу (карточки)

С. Компьютерная модель:

Ввести в таблицу исходные данные по образцу:

hello_html_1c99932c.png

Ввести в таблицу формулы для расчетов.

Формулы учащиеся заностят в электронные таблицы.

В ячейку А7 вводится формулу :=ЕСЛИ(СЛУЧ_ЧИСЛО()<0,5;1;0)

В ячейку В7 вводится формулу :=ЕСЛИ(A7=1;$B$4+$D$4;$B$4-$D$4)

В ячейку C7 вводится формулу :=ЕСЛИ(B7<2*$B$4;”-“;”банк”)

В ячейку D7 вводится формулу :=ЕСЛИ(B7>0;”-“;”банкрот”)

В ячейку B8 вводится формулу :=ЕСЛИ(A8=1;B7+$D$4;B7-$D$4)

D. Компьютерный эксперимент

Тестирование

Проверить правильность ввода формул.

Проведение исследования

Тестирование

Введите в таблицу контрольные исходные данные и расчетные формулы в первую строку. Результаты сравнить с приведенными в таблице.

Если в столбце Бросок выпал «0» («решка»), данные в остальных столбцах должны быть следующими:

6

Бросок

Наличность

Выигрыш

Проигрыш

7

0

9

-

-

Видим уменьшение наличности на величину ставки.

Если в столбце Бросок выпала «1» (2орел»), данные в остальных столбцах должны быть следующими:

6

Бросок

Наличность

Выигрыш

Проигрыш

7

1

11

-

-

Видим увеличение наличности на величину ставки.

Сравнение с контрольным образцом показывает правильность введения формул.

Ответить на вопросы:

  • Кто чаще выигрывает: казино или игрок?

  • Сколько в среднем бросков надо сделать до окончания игры?

VI. Подведение итогов. (3 мин) Слайд 11

Подведение итогов работы. Оценки за урок. Ответы на вопросы.

- Для чего нужна моделировать случайные процессы?
- Мои достижения на уроке:

  • я научился…

  • я понял, как…

  • оформил результаты, используя…

  • другой вариант




Самые низкие цены на курсы переподготовки

Специально для учителей, воспитателей и других работников системы образования действуют 50% скидки при обучении на курсах профессиональной переподготовки.

После окончания обучения выдаётся диплом о профессиональной переподготовке установленного образца с присвоением квалификации (признаётся при прохождении аттестации по всей России).

Обучение проходит заочно прямо на сайте проекта "Инфоурок", но в дипломе форма обучения не указывается.

Начало обучения ближайшей группы: 25 октября. Оплата возможна в беспроцентную рассрочку (10% в начале обучения и 90% в конце обучения)!

Подайте заявку на интересующий Вас курс сейчас: https://infourok.ru

Краткое описание документа:

Учитель: Свинобоев И.С.

 

Предмет: Информатика

 

Класс: 9 класс

 

Профиль: естественно- математический

Тип урока: Комбинированный - урок формирования и закрепления умений и навыков практического использования MS Excel.

 

Тема урока:Моделирование случайных процессов в среде табличного процессора

Цель урока: научиться моделировать случайные процессы в электронных таблицах

Задачи урока

Образовательные:

  • повторить и закрепить знания и умения работы в MS Excel;
  • отработать основные приемы работы с электронными таблицами.

Воспитательные:

  • воспитывать общую и информационную культуру, трудолюбие, усидчивость, терпение, бережное отношение к школьной технике.

Развивающие:

  • Развивать логическое мышление, способность к анализу.

 

Оборудование урока:

    • приложение MS Windows – ЭТ MS Excel;

карточки – задания для практической работы.

Ход урока

I. Организационный момент: приветствие. (2 мин)

Проверка готовности учащихся к уроку, отметка отсутствующих, объявление темы и цели урока.

При выполнении работы должны соблюдаться правила ТБ при работе за ПК и правила поведения в компьютерном классе.

II. Постановка темы и целей урока. (2 мин) Слайд 1,2

III. Объяснение нового материала.  (16 мин)

Предлагается учащимся решить  следующую задачу «Бросание монеты» Слайд 3

I этап. Постановка задачи. Слайд 4

Бросание монеты

Решение задач на компьютере обычно разделяют на несколько этапов.

А. Описание задачи:

У вас есть 10 монет. Вы хотите увеличить свой капитал в два раза, испытав заодно и свою судьбу. Суть игра проста. Играя с маклером, вы делаете ставку и бросаете монету. Если выпадает «орел», маклер выдает вам сумму вашей ставки, в противном случае – вы ему отдаете эту сумму. Ставка может быть любой: от 1 до 10. Вы можете назначить самую большую ставку в 10 монет, и тогда за один бросок выясниться, «сорвали» ли вы банк или, наоборот, обанкротились. Опытные игроки действуют более осторожно, начиная с маленькой ставки.

B. Цель моделирования: Слайд 5

Выяснить, какая тактика чаще приводит к результату (положительному или отрицательному).

C. Формализация задачи: Слайд 6

Каков характер процесса?    Случайный

Чем характеризуется игрок?   Начальным капиталом Кнач, Ставкой СТ, Текущей наличностью Ктек

Чем характеризуется монета? Положение (орел/решка)

II этап. Разработка модели. Слайд 8

A. Информационная модель: (Составление модели по условию задачи). Слайд 9

 

Объект

Параметры

Действия

название

значение

Игрок

Начальным капиталом Кнач

 

Ставкой СТ

 

Текущей наличностью Ктек

Исходные данные

Исходные данные

Расчетные данные

Выбор ставки

 

Вычисление наличности

 

 

Продолжение игры

Маклер

Бросок

 

Выигрыш

 

Проигрыш

Расчетные данные

Расчетные данные

Расчетные данные

Выплата проигранного

 

Прекращение игры по банкротству

Монета

Вероятность угадывания результата

Положение «орел/решка»

Константа

Расчетные данные

Подбрасывание монет

Определение результата падения

Для обработки используются стандартные логические и статистические функции, имеющиеся во многих средах

V. Самостоятельная работа. (14 мин) Слайд 10

С помощью электронной таблицы учащимся предлагается построить компьютерную модель.

Заполняют учащиеся по образцу расчетную таблицу (карточки)

С. Компьютерная модель:

Ввести в таблицу исходные данные по образцу:


Ввести в таблицу формулы для расчетов.

Формулы учащиеся заностят в электронные таблицы.

В ячейку А7 вводится формулу :=ЕСЛИ(СЛУЧ_ЧИСЛО()<0,5;1;0)

В ячейку В7 вводится формулу :=ЕСЛИ(A7=1;$B$4+$D$4;$B$4-$D$4)

В ячейку C7 вводится формулу :=ЕСЛИ(B7<2*$B$4;”-“;”банк”)

В ячейку D7 вводится формулу :=ЕСЛИ(B7>0;”-“;”банкрот”)

В ячейку

Общая информация

Номер материала: 479828

Похожие материалы