Добавить материал и получить бесплатное свидетельство о публикации в СМИ
Эл. №ФС77-60625 от 20.01.2015
Инфоурок / Информатика / Презентации / Презентация к уроку информатики в 9 классе по теме "Алгоритмическая структура "Выбор""

Презентация к уроку информатики в 9 классе по теме "Алгоритмическая структура "Выбор""

Международный конкурс по математике «Поверь в себя»

для учеников 1-11 классов и дошкольников с ЛЮБЫМ уровнем знаний

Задания конкурса по математике «Поверь в себя» разработаны таким образом, чтобы каждый ученик вне зависимости от уровня подготовки смог проявить себя.

К ОПЛАТЕ ЗА ОДНОГО УЧЕНИКА: ВСЕГО 28 РУБ.

Конкурс проходит полностью дистанционно. Это значит, что ребенок сам решает задания, сидя за своим домашним компьютером (по желанию учителя дети могут решать задания и организованно в компьютерном классе).

Подробнее о конкурсе - https://urokimatematiki.ru/


Идёт приём заявок на самые массовые международные олимпиады проекта "Инфоурок"

Для учителей мы подготовили самые привлекательные условия в русскоязычном интернете:

1. Бесплатные наградные документы с указанием данных образовательной Лицензии и Свидeтельства СМИ;
2. Призовой фонд 1.500.000 рублей для самых активных учителей;
3. До 100 рублей за одного ученика остаётся у учителя (при орг.взносе 150 рублей);
4. Бесплатные путёвки в Турцию (на двоих, всё включено) - розыгрыш среди активных учителей;
5. Бесплатная подписка на месяц на видеоуроки от "Инфоурок" - активным учителям;
6. Благодарность учителю будет выслана на адрес руководителя школы.

Подайте заявку на олимпиаду сейчас - https://infourok.ru/konkurs

  • Информатика
Каков результат выполнения алгоритма? Проверка домашнего задания S
Какой результат для переменной а выдаст программа?
Какой результат выдаст программа? если ввести b=1, b=6? s=4; cin>>b; if (b=1)...
Вложенное ветвление
Вложенное ветвление если Условие1 . . то операторы1 . . иначе если Условие2 ....
 Вычисление значений функции в зависимости от заданного с клавиатуры значения Х
Вычисление значений функции в зависимости от заданного с клавиатуры значения...
алг вычисление функции Вложенное Ветвление нач вещ x, y . вывод "введите знач...
Можно ли с помощью алгоритмической структуры «ветвление» реализовать алгоритм...
Алгоритмическая структура «выбор» 9 класс Информатика и ИКТ Учебник Н.Д. Угри...
выбор при условие1: операторы1 при условие2: операторы2 при условие3: операт...
алг вычисление функции Выбор нач вещ x, y . вывод "введите значения аргумента...
По введенному номеру дня недели, выведите его название алг день недели нач це...
По введенному номеру дня недели, выведите его название. Реализация на языке п...
Домашнее задание Составить блок-схему алгоритма и написать программу, позволя...
1 из 15

Описание презентации по отдельным слайдам:

№ слайда 1 Каков результат выполнения алгоритма? Проверка домашнего задания S
Описание слайда:

Каков результат выполнения алгоритма? Проверка домашнего задания S

№ слайда 2 Какой результат для переменной а выдаст программа?
Описание слайда:

Какой результат для переменной а выдаст программа?

№ слайда 3 Какой результат выдаст программа? если ввести b=1, b=6? s=4; cin>>b; if (b=1)
Описание слайда:

Какой результат выдаст программа? если ввести b=1, b=6? s=4; cin>>b; if (b<=6) {s=s+b; z=s/5; if (z>=1) {cout<<“мальчишки”<<endl;} else {cout<<“девчонки”<<endl;} }

№ слайда 4 Вложенное ветвление
Описание слайда:

Вложенное ветвление

№ слайда 5 Вложенное ветвление если Условие1 . . то операторы1 . . иначе если Условие2 .
Описание слайда:

Вложенное ветвление если Условие1 . . то операторы1 . . иначе если Условие2 . . . . то операторы2 . . . . иначе операторы3 . . . все . все

№ слайда 6  Вычисление значений функции в зависимости от заданного с клавиатуры значения Х
Описание слайда:

Вычисление значений функции в зависимости от заданного с клавиатуры значения Х

№ слайда 7 Вычисление значений функции в зависимости от заданного с клавиатуры значения
Описание слайда:

Вычисление значений функции в зависимости от заданного с клавиатуры значения Х (заполните пустые блоки)

№ слайда 8 алг вычисление функции Вложенное Ветвление нач вещ x, y . вывод &quot;введите знач
Описание слайда:

алг вычисление функции Вложенное Ветвление нач вещ x, y . вывод "введите значения аргумента х " . ввод x . если x<=0 . . то y:=x*x . . иначе если x<=4 . . . . то y:=3*sin(x) . . . . иначе y:=3*cos(x) . . . все . все . вывод нс, "значение функции =",y кон

№ слайда 9 Можно ли с помощью алгоритмической структуры «ветвление» реализовать алгоритм
Описание слайда:

Можно ли с помощью алгоритмической структуры «ветвление» реализовать алгоритмы к следующим задачам?

№ слайда 10 Алгоритмическая структура «выбор» 9 класс Информатика и ИКТ Учебник Н.Д. Угри
Описание слайда:

Алгоритмическая структура «выбор» 9 класс Информатика и ИКТ Учебник Н.Д. Угринович Учитель Орешкова Т.Г

№ слайда 11 выбор при условие1: операторы1 при условие2: операторы2 при условие3: операт
Описание слайда:

выбор при условие1: операторы1 при условие2: операторы2 при условие3: операторы3 иначе операторы4 все

№ слайда 12 алг вычисление функции Выбор нач вещ x, y . вывод &quot;введите значения аргумента
Описание слайда:

алг вычисление функции Выбор нач вещ x, y . вывод "введите значения аргумента х " . ввод x . выбор . . при x<=0: y:=x*x . . при x > 0 и x<=4: y:=3*sin(x) . . при x>4: y:=3*cos(x) . все . вывод нс, "значение функции =",y кон Вычисление значений функции в зависимости от заданного с клавиатуры значения Х (заполните пустые блоки)

№ слайда 13 По введенному номеру дня недели, выведите его название алг день недели нач це
Описание слайда:

По введенному номеру дня недели, выведите его название алг день недели нач цел d вывод "введите номер дня недели " ввод d выбор при d=1: вывод нс, "понедельник" при d =2: вывод нс, "вторник" при d =3: вывод нс, "среда" при d =4: вывод нс, "четверг" при d =5: вывод нс, "пятница" при d =6: вывод нс, "суббота" при d =7: вывод нс, "воскресенье" все кон

№ слайда 14 По введенному номеру дня недели, выведите его название. Реализация на языке п
Описание слайда:

По введенному номеру дня недели, выведите его название. Реализация на языке программирования С++. switch (d) { case 1: cout<< "понедельник "<<endl; case 2: cout<< "вторник"<<endl; case 3: cout<< "среда"<<endl; case 4: cout<< "четверг"<<endl; case 5: cout<< "пятница"<<endl; case 6: cout<< "суббота"<<endl; case 7: cout<< "воскресенье"<<endl; default: cout<<"некорректный ввод"<<endl; }

№ слайда 15 Домашнее задание Составить блок-схему алгоритма и написать программу, позволя
Описание слайда:

Домашнее задание Составить блок-схему алгоритма и написать программу, позволяющую по последней цифре числа, введенного с клавиатуры, определить последнюю цифру его квадрата. Составить блок-схему алгоритма и написать программу «Отметка за урок», выдающая оценку по заданному с клавиатуры количеству ошибок.

Самые низкие цены на курсы профессиональной переподготовки и повышения квалификации!

Предлагаем учителям воспользоваться 50% скидкой при обучении по программам профессиональной переподготовки.

После окончания обучения выдаётся диплом о профессиональной переподготовке установленного образца (признаётся при прохождении аттестации по всей России).

Обучение проходит заочно прямо на сайте проекта "Инфоурок".

Начало обучения ближайших групп: 18 января и 25 января. Оплата возможна в беспроцентную рассрочку (20% в начале обучения и 80% в конце обучения)!

Подайте заявку на интересующий Вас курс сейчас: https://infourok.ru/kursy



Автор
Дата добавления 15.02.2016
Раздел Информатика
Подраздел Презентации
Просмотров549
Номер материала ДВ-456967
Получить свидетельство о публикации

УЖЕ ЧЕРЕЗ 10 МИНУТ ВЫ МОЖЕТЕ ПОЛУЧИТЬ ДИПЛОМ

от проекта "Инфоурок" с указанием данных образовательной лицензии, что важно при прохождении аттестации.

Если Вы учитель или воспитатель, то можете прямо сейчас получить документ, подтверждающий Ваши профессиональные компетенции. Выдаваемые дипломы и сертификаты помогут Вам наполнить собственное портфолио и успешно пройти аттестацию.

Список всех тестов можно посмотреть тут - https://infourok.ru/tests


Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.
Специальное предложение
Вверх