Добавить материал и получить бесплатное свидетельство о публикации в СМИ
Эл. №ФС77-60625 от 20.01.2015
Свидетельство о публикации

Автоматическая выдача свидетельства о публикации в официальном СМИ сразу после добавления материала на сайт - Бесплатно

Добавить свой материал

За каждый опубликованный материал Вы получите бесплатное свидетельство о публикации от проекта «Инфоурок»

(Свидетельство о регистрации СМИ: Эл №ФС77-60625 от 20.01.2015)

Инфоурок / Информатика / Презентации / Презентация к уроку информатики в 9 классе по теме "Алгоритмическая структура "Выбор""
ВНИМАНИЮ ВСЕХ УЧИТЕЛЕЙ: согласно Федеральному закону № 313-ФЗ все педагоги должны пройти обучение навыкам оказания первой помощи.

Дистанционный курс "Оказание первой помощи детям и взрослым" от проекта "Инфоурок" даёт Вам возможность привести свои знания в соответствие с требованиями закона и получить удостоверение о повышении квалификации установленного образца (180 часов). Начало обучения новой группы: 28 июня.

Подать заявку на курс
  • Информатика

Презентация к уроку информатики в 9 классе по теме "Алгоритмическая структура "Выбор""

библиотека
материалов
Каков результат выполнения алгоритма? Проверка домашнего задания S
Какой результат для переменной а выдаст программа?
Какой результат выдаст программа? если ввести b=1, b=6? s=4; cin>>b; if (b=1)...
Вложенное ветвление
Вложенное ветвление если Условие1 . . то операторы1 . . иначе если Условие2 ....
 Вычисление значений функции в зависимости от заданного с клавиатуры значения Х
Вычисление значений функции в зависимости от заданного с клавиатуры значения...
алг вычисление функции Вложенное Ветвление нач вещ x, y . вывод "введите знач...
Можно ли с помощью алгоритмической структуры «ветвление» реализовать алгоритм...
Алгоритмическая структура «выбор» 9 класс Информатика и ИКТ Учебник Н.Д. Угри...
выбор при условие1: операторы1 при условие2: операторы2 при условие3: операт...
алг вычисление функции Выбор нач вещ x, y . вывод "введите значения аргумента...
По введенному номеру дня недели, выведите его название алг день недели нач це...
По введенному номеру дня недели, выведите его название. Реализация на языке п...
Домашнее задание Составить блок-схему алгоритма и написать программу, позволя...
15 1

Подайте заявку сейчас на любой интересующий Вас курс переподготовки, чтобы получить диплом со скидкой 50% уже осенью 2017 года.


Выберите специальность, которую Вы хотите получить:

Обучение проходит дистанционно на сайте проекта "Инфоурок".
По итогам обучения слушателям выдаются печатные дипломы установленного образца.

ПЕРЕЙТИ В КАТАЛОГ КУРСОВ

Описание презентации по отдельным слайдам:

№ слайда 1 Каков результат выполнения алгоритма? Проверка домашнего задания S
Описание слайда:

Каков результат выполнения алгоритма? Проверка домашнего задания S

№ слайда 2 Какой результат для переменной а выдаст программа?
Описание слайда:

Какой результат для переменной а выдаст программа?

№ слайда 3 Какой результат выдаст программа? если ввести b=1, b=6? s=4; cin>>b; if (b=1)
Описание слайда:

Какой результат выдаст программа? если ввести b=1, b=6? s=4; cin>>b; if (b<=6) {s=s+b; z=s/5; if (z>=1) {cout<<“мальчишки”<<endl;} else {cout<<“девчонки”<<endl;} }

№ слайда 4 Вложенное ветвление
Описание слайда:

Вложенное ветвление

№ слайда 5 Вложенное ветвление если Условие1 . . то операторы1 . . иначе если Условие2 .
Описание слайда:

Вложенное ветвление если Условие1 . . то операторы1 . . иначе если Условие2 . . . . то операторы2 . . . . иначе операторы3 . . . все . все

№ слайда 6  Вычисление значений функции в зависимости от заданного с клавиатуры значения Х
Описание слайда:

Вычисление значений функции в зависимости от заданного с клавиатуры значения Х

№ слайда 7 Вычисление значений функции в зависимости от заданного с клавиатуры значения
Описание слайда:

Вычисление значений функции в зависимости от заданного с клавиатуры значения Х (заполните пустые блоки)

№ слайда 8 алг вычисление функции Вложенное Ветвление нач вещ x, y . вывод &quot;введите знач
Описание слайда:

алг вычисление функции Вложенное Ветвление нач вещ x, y . вывод "введите значения аргумента х " . ввод x . если x<=0 . . то y:=x*x . . иначе если x<=4 . . . . то y:=3*sin(x) . . . . иначе y:=3*cos(x) . . . все . все . вывод нс, "значение функции =",y кон

№ слайда 9 Можно ли с помощью алгоритмической структуры «ветвление» реализовать алгоритм
Описание слайда:

Можно ли с помощью алгоритмической структуры «ветвление» реализовать алгоритмы к следующим задачам?

№ слайда 10 Алгоритмическая структура «выбор» 9 класс Информатика и ИКТ Учебник Н.Д. Угри
Описание слайда:

Алгоритмическая структура «выбор» 9 класс Информатика и ИКТ Учебник Н.Д. Угринович Учитель Орешкова Т.Г

№ слайда 11 выбор при условие1: операторы1 при условие2: операторы2 при условие3: операт
Описание слайда:

выбор при условие1: операторы1 при условие2: операторы2 при условие3: операторы3 иначе операторы4 все

№ слайда 12 алг вычисление функции Выбор нач вещ x, y . вывод &quot;введите значения аргумента
Описание слайда:

алг вычисление функции Выбор нач вещ x, y . вывод "введите значения аргумента х " . ввод x . выбор . . при x<=0: y:=x*x . . при x > 0 и x<=4: y:=3*sin(x) . . при x>4: y:=3*cos(x) . все . вывод нс, "значение функции =",y кон Вычисление значений функции в зависимости от заданного с клавиатуры значения Х (заполните пустые блоки)

№ слайда 13 По введенному номеру дня недели, выведите его название алг день недели нач це
Описание слайда:

По введенному номеру дня недели, выведите его название алг день недели нач цел d вывод "введите номер дня недели " ввод d выбор при d=1: вывод нс, "понедельник" при d =2: вывод нс, "вторник" при d =3: вывод нс, "среда" при d =4: вывод нс, "четверг" при d =5: вывод нс, "пятница" при d =6: вывод нс, "суббота" при d =7: вывод нс, "воскресенье" все кон

№ слайда 14 По введенному номеру дня недели, выведите его название. Реализация на языке п
Описание слайда:

По введенному номеру дня недели, выведите его название. Реализация на языке программирования С++. switch (d) { case 1: cout<< "понедельник "<<endl; case 2: cout<< "вторник"<<endl; case 3: cout<< "среда"<<endl; case 4: cout<< "четверг"<<endl; case 5: cout<< "пятница"<<endl; case 6: cout<< "суббота"<<endl; case 7: cout<< "воскресенье"<<endl; default: cout<<"некорректный ввод"<<endl; }

№ слайда 15 Домашнее задание Составить блок-схему алгоритма и написать программу, позволя
Описание слайда:

Домашнее задание Составить блок-схему алгоритма и написать программу, позволяющую по последней цифре числа, введенного с клавиатуры, определить последнюю цифру его квадрата. Составить блок-схему алгоритма и написать программу «Отметка за урок», выдающая оценку по заданному с клавиатуры количеству ошибок.


Подайте заявку сейчас на любой интересующий Вас курс переподготовки, чтобы получить диплом со скидкой 50% уже осенью 2017 года.


Выберите специальность, которую Вы хотите получить:

Обучение проходит дистанционно на сайте проекта "Инфоурок".
По итогам обучения слушателям выдаются печатные дипломы установленного образца.

ПЕРЕЙТИ В КАТАЛОГ КУРСОВ

Автор
Дата добавления 15.02.2016
Раздел Информатика
Подраздел Презентации
Просмотров990
Номер материала ДВ-456967
Получить свидетельство о публикации
Похожие материалы

Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.
Специальное предложение
Вверх