Добавить материал и получить бесплатное свидетельство о публикации в СМИ
Эл. №ФС77-60625 от 20.01.2015
Инфоурок / Другое / Презентации / Презентация по теме "Задачи о назначениях"

Презентация по теме "Задачи о назначениях"


До 7 декабря продлён приём заявок на
Международный конкурс "Мириады открытий"
(конкурс сразу по 24 предметам за один оргвзнос)

  • Другое
Задачи о назначениях Технология решения задач о назначениях в ЭТ Excel дисцип...
Условие задачи Пусть имеется n работников и n рабочих мест (работ). Известно...
Время выполнения заданий
Время выполнения заданий
Математическая модель Количество переменных в задаче о назначениях, как и в т...
Смысл переменных С1 – признак того, что М1 выполняет задание Т1; С2 – признак...
Целевая функция (минимальное общее время) f = 1 0*C1 + 5*C2 + 9*С3 + 18*С4 +...
Ограничения Количество ограничений = сумме числа строк и числа столбцов в таб...
Ограничения Ограничения, которые отражают то, что каждая работа выполняется т...
Двоичные числа Условия того, что каждая переменная является двоичным признако...
Подготовка листа Excel Занесем в ячейки С1:С16 нулевые значения Занесем в яче...
Вид рабочего листа
Окно «Поиск Решения»
Результаты поиска решения
Ответ (решение задачи) В результате решения получилось, что признаки С1, С7,...
Оформление отчета Единицы в ячейках А3:А10 гарантируют, что каждый сотрудник...
Способ решения с помощью функций
Используемые функции Для выражения цели задачи при этом способе была использо...
Используемые функции В ячейки А3:А6 вводятся формулы: =СУММ(D11:G11); =СУММ(D...
Решение найдено
Проверка модели
Результаты (выводы) Мы видим, что сумма желтых цифр равна 29 Это действительн...
Области применения распределение изделий между предприятиями распределение са...
Вариант № 1. Необходимо распределить нагрузку преподавателям, закрепив каждог...
Вариант № 2. Секретарю учебной части необходимо распределить преподавателей п...
Литература Куликов Ю.Г. Экономико-математические методы и модели (раздел «Лин...
1 из 27

Описание презентации по отдельным слайдам:

№ слайда 1 Задачи о назначениях Технология решения задач о назначениях в ЭТ Excel дисцип
Описание слайда:

Задачи о назначениях Технология решения задач о назначениях в ЭТ Excel дисциплина «Моделирование экономических процессов» преподаватель Камышова Галина Алексеевна

№ слайда 2 Условие задачи Пусть имеется n работников и n рабочих мест (работ). Известно
Описание слайда:

Условие задачи Пусть имеется n работников и n рабочих мест (работ). Известно время, которое затрачивает каждый работник на выполнение каждого вида работ. Требуется так распределить работников по рабочим местам, чтобы каждый работник был назначен на одну работу, каждая работа выполнялась одним работником при минимальном времени выполнения всеми работниками всех работ.

№ слайда 3 Время выполнения заданий
Описание слайда:

Время выполнения заданий

№ слайда 4 Время выполнения заданий
Описание слайда:

Время выполнения заданий

№ слайда 5 Математическая модель Количество переменных в задаче о назначениях, как и в т
Описание слайда:

Математическая модель Количество переменных в задаче о назначениях, как и в транспортной задаче, определяется произведением числа строк в таблице на число столбцов. Введем переменные С1 : С16. Каждая переменная соответствует определенной клетке в таблице и принимает значение = 1, если данный работник выполняет данную работу, или = 0 если данный работник не выполняет данную работу.

№ слайда 6 Смысл переменных С1 – признак того, что М1 выполняет задание Т1; С2 – признак
Описание слайда:

Смысл переменных С1 – признак того, что М1 выполняет задание Т1; С2 – признак того, что М1 выполняет задание Т2; С3 – признак того, что М1 выполняет задание Т3; С4 – признак того, что М1 выполняет задание Т4; С5 – признак того, что М2 выполняет задание Т1; С6 – признак того, что М2 выполняет задание Т2; С7 – признак того, что М2 выполняет задание Т3; С8 – признак того, что М2 выполняет задание Т4; С9 – признак того, что М3 выполняет задание Т1; С10 – признак того, что М3 выполняет задание Т2; С11– признак того, что М3 выполняет задание Т3; С12 – признак того, что М3 выполняет задание Т4; С13 – признак того, что М4 выполняет задание Т1; С14– признак того, что М4 выполняет задание Т2; С15 – признак того, что М4 выполняет задание Т3; С16 - признак того, что М4 выполняет задание Т4;

№ слайда 7 Целевая функция (минимальное общее время) f = 1 0*C1 + 5*C2 + 9*С3 + 18*С4 +
Описание слайда:

Целевая функция (минимальное общее время) f = 1 0*C1 + 5*C2 + 9*С3 + 18*С4 + 13*С5 + 19*С6 + 6*С7 + 12*С8 + 3*С9 + 2*С10 + 4*С11 + 4*С12 + 18*С13 + 9*С14 + 12*С15 +17*С16

№ слайда 8 Ограничения Количество ограничений = сумме числа строк и числа столбцов в таб
Описание слайда:

Ограничения Количество ограничений = сумме числа строк и числа столбцов в таблице. Ограничения, которые отражают то, что каждый сотрудник выполняет только одну работу: С1+С2+С3+С4=1 С5+С6+С7+С8=1 С9+С10+С11+С12=1 С13+С14+С15+С16=1

№ слайда 9 Ограничения Ограничения, которые отражают то, что каждая работа выполняется т
Описание слайда:

Ограничения Ограничения, которые отражают то, что каждая работа выполняется только одним сотрудником: С1+С5+С9+С13=1 С2+С6+С10+С14=1 С3+С7+С11+С15=1 С4+С8+С12+С16=1

№ слайда 10 Двоичные числа Условия того, что каждая переменная является двоичным признако
Описание слайда:

Двоичные числа Условия того, что каждая переменная является двоичным признаком выполнения данной работы данным исполнителем (1 – выполняется, 0 – не выполняется) выразим в виде: С1 : С16 – двоичные числа.

№ слайда 11 Подготовка листа Excel Занесем в ячейки С1:С16 нулевые значения Занесем в яче
Описание слайда:

Подготовка листа Excel Занесем в ячейки С1:С16 нулевые значения Занесем в ячейку А1 формулу целевой функции В ячейки, начиная с А3 по А10 занесем формулы левых частей ограничений После этого вызовем Поиск Решения, который находится в меню Сервис

№ слайда 12 Вид рабочего листа
Описание слайда:

Вид рабочего листа

№ слайда 13 Окно «Поиск Решения»
Описание слайда:

Окно «Поиск Решения»

№ слайда 14 Результаты поиска решения
Описание слайда:

Результаты поиска решения

№ слайда 15 Ответ (решение задачи) В результате решения получилось, что признаки С1, С7,
Описание слайда:

Ответ (решение задачи) В результате решения получилось, что признаки С1, С7, С12 и С14 = 1  Сотрудник М1 выполняет работу Т1 Сотрудник М2 выполняет работу Т3 Сотрудник М3 выполняет работу Т4 Сотрудник М4 выполняет работу Т2 Общее время при этом = 29

№ слайда 16 Оформление отчета Единицы в ячейках А3:А10 гарантируют, что каждый сотрудник
Описание слайда:

Оформление отчета Единицы в ячейках А3:А10 гарантируют, что каждый сотрудник выполняет один вид работы, а каждый вид работы выполняется одним человеком

№ слайда 17 Способ решения с помощью функций
Описание слайда:

Способ решения с помощью функций

№ слайда 18 Используемые функции Для выражения цели задачи при этом способе была использо
Описание слайда:

Используемые функции Для выражения цели задачи при этом способе была использована функция =СУММПРОИЗВ(D3:G6;D11:G14); Эта функция вычисляет сумму попарных произведений Данные она берёт из двух таблиц

№ слайда 19 Используемые функции В ячейки А3:А6 вводятся формулы: =СУММ(D11:G11); =СУММ(D
Описание слайда:

Используемые функции В ячейки А3:А6 вводятся формулы: =СУММ(D11:G11); =СУММ(D12:G12); =СУММ(D13:G13); =СУММ(D14:G14); В ячейки А7:А10 вводятся формулы: =СУММ(D11:D14); =СУММ(E11:E14); =СУММ(F11:F14); =СУММ(G11:G14);

№ слайда 20
Описание слайда:

№ слайда 21 Решение найдено
Описание слайда:

Решение найдено

№ слайда 22 Проверка модели
Описание слайда:

Проверка модели

№ слайда 23 Результаты (выводы) Мы видим, что сумма желтых цифр равна 29 Это действительн
Описание слайда:

Результаты (выводы) Мы видим, что сумма желтых цифр равна 29 Это действительно минимальный результат Вспомните, что результаты, которые мы могли предложить, не решая задачу были 35 (черные цифры) и 32 (красные цифры)

№ слайда 24 Области применения распределение изделий между предприятиями распределение са
Описание слайда:

Области применения распределение изделий между предприятиями распределение самолетов между воздушными линиями рациональное использование машинно-транспортного парка распределение башенных кранов между строительными площадками планирование работы речного флота распределения посевной площади между сельскохозяйственными структурами распределение работников на курсы повышения квалификации

№ слайда 25 Вариант № 1. Необходимо распределить нагрузку преподавателям, закрепив каждог
Описание слайда:

Вариант № 1. Необходимо распределить нагрузку преподавателям, закрепив каждого преподавателя за определенным предметом. Имеются данные о том, сколько лет тот или другой преподаватель ведет данный предмет. Несомненно, это свидетельствует о накопленном опыте. Предпочтение будет отдано тому преподавателю, который посвятил данному предмету больше времени. Данные из отдела кадров приведены в таблице:

№ слайда 26 Вариант № 2. Секретарю учебной части необходимо распределить преподавателей п
Описание слайда:

Вариант № 2. Секретарю учебной части необходимо распределить преподавателей по кабинетам. Для этого каждый преподаватель указывает, какой кабинет для него предпочтительнее по следующей системе приоритетов: 1 приоритет означает, что для преподавателя было бы наилучшим вариантом провести занятие в этом кабинете (самый лучший для преподавателя вариант); 2 приоритет означает, что если нужный кабинет занят, то он может провести и в этом (не самый лучший, но и не самый плохой для преподавателя вариант); 3 приоритет означает, что если нет других вариантов, то преподаватель согласен и на этот кабинет (самый худший вариант для преподавателя).

№ слайда 27 Литература Куликов Ю.Г. Экономико-математические методы и модели (раздел «Лин
Описание слайда:

Литература Куликов Ю.Г. Экономико-математические методы и модели (раздел «Линейное программирование») Учебное пособие для практических занятий. М.: Московский психолого-социальный институт; Воронеж: Издательство НПО «МОДЭК», 2000 г. (Серия «Библиотека экономиста») Малик Г.С. «Основы экономики и математические методы в планировании»: Учебник для техникумов - М.: Высшая школа, 1988. Цисарь И.Ф. Лабораторные работы на персональном компьютере. Учебное пособие для студентов экономических специальностей. – М.: Издательство «Экзамен», 2002. Шапкин А.С., Мазаева Н.П. Математические методы и модели исследования операций: Учебник – 3-е изд. – М.: Издательско-торговая корпорация «Дашков и К», 2006.


57 вебинаров для учителей на разные темы
ПЕРЕЙТИ к бесплатному просмотру
(заказ свидетельства о просмотре - только до 11 декабря)

Автор
Дата добавления 20.10.2016
Раздел Другое
Подраздел Презентации
Просмотров10
Номер материала ДБ-277703
Получить свидетельство о публикации
Похожие материалы

Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.
Специальное предложение
Вверх