Добавить материал и получить бесплатное свидетельство о публикации в СМИ
Эл. №ФС77-60625 от 20.01.2015

Опубликуйте свой материал в официальном Печатном сборнике методических разработок проекта «Инфоурок»

(с присвоением ISBN)

Выберите любой материал на Вашем учительском сайте или загрузите новый

Оформите заявку на публикацию в сборник(займет не более 3 минут)

+

Получите свой экземпляр сборника и свидетельство о публикации в нем

Инфоурок / Информатика / Презентации / Презентация "Алгоритмы с ленейной структурой". Решение задач с помощью блок-схем и на школьном алгоритмическом языке.
ВНИМАНИЮ ВСЕХ УЧИТЕЛЕЙ: согласно Федеральному закону № 313-ФЗ все педагоги должны пройти обучение навыкам оказания первой помощи.

Дистанционный курс "Оказание первой помощи детям и взрослым" от проекта "Инфоурок" даёт Вам возможность привести свои знания в соответствие с требованиями закона и получить удостоверение о повышении квалификации установленного образца (180 часов). Начало обучения новой группы: 24 мая.

Подать заявку на курс
  • Информатика

Презентация "Алгоритмы с ленейной структурой". Решение задач с помощью блок-схем и на школьном алгоритмическом языке.

библиотека
материалов
Задача 2 Напишите алгоритм вычисления общего члена Вn и суммы Sn первых n чле...
Задача 1. Напишите алгоритм вычисления суммы Sn первых n членов арифметическ...
Начало Ввод n, d, a1 Вывод Sn Конец Выход из презентации
алг сумма (арг вещ d, a1 цел n, рез вещ Sn ) 	нач 		ввод d, a1 , n 			 Sn:=(2...
Задача №2 Задача №3 Задача №1 Выход из презентации Задача №4
Начало Ввод n,q, b1 Вывод Вn , Sn Конец Выход из презентации
алг прогрессия (арг вещ q, b1 цел n, рез вещ Вn , Sn ) 	нач 		ввод q, b1 , n...
Задача 3. Напишите алгоритм вычисления площади параллелограмма S по заданным...
Начало Ввод a, b, f Вывод S Конец Выход из презентации
алг площадь (арг вещ a,b,f рез вещ , S) 	нач 		ввод a, b, f 			 :=f*3.14/18...
Начало Ввод х1, х2, х3, у1, у2, у3 Вывод S Конец Выход из презентации
алг задача (арг вещ х1, х2, х3, у1, у2, у3 рез вещ a1, a2,S) нач 	 ввод х1, х...
Задача 5 Составить алгоритм, который с тремя произвольными числами x, y и z...
алг функция (арг вещ x, y, z рез вещ a, b, c, d) 	нач 	 ввод x, y, z 		a:=x/(...
Составить алгоритм, который с четырмя произвольными числами a, x, z и w произ...
алг функция (арг вещ a, x, z, w рез вещ b, c, e,f) 	нач 	 ввод a, x, z, w 	 b...
По представленной блок-схеме составьте алгоритм на школьном алгоритмическом я...
алг Задача (арг вещ a, b, c рез вещ s, k, y) нач 	 ввод a,b,c 	 s:= (a+c^4)/(...
По представленной блок-схеме составьте алгоритм на школьном алгоритмическом я...
алг Задача (арг вещ a, b, c рез вещ s, k, y) нач 	 ввод a,b,c 	 s:= (sqrt(3*c...
22 1

Описание презентации по отдельным слайдам:

№ слайда 1 Задача 2 Напишите алгоритм вычисления общего члена Вn и суммы Sn первых n чле
Описание слайда:

Задача 2 Напишите алгоритм вычисления общего члена Вn и суммы Sn первых n членов геометрической прогрессии. Первый член прогрессии b1, знаменатель прогрессии q и число членов задаются. Выход из презентации

№ слайда 2 Задача 1. Напишите алгоритм вычисления суммы Sn первых n членов арифметическ
Описание слайда:

Задача 1. Напишите алгоритм вычисления суммы Sn первых n членов арифметической прогрессии. Первый член прогрессии а1, разность d и число членов задаются. Выход из презентации

№ слайда 3 Начало Ввод n, d, a1 Вывод Sn Конец Выход из презентации
Описание слайда:

Начало Ввод n, d, a1 Вывод Sn Конец Выход из презентации

№ слайда 4 алг сумма (арг вещ d, a1 цел n, рез вещ Sn ) 	нач 		ввод d, a1 , n 			 Sn:=(2
Описание слайда:

алг сумма (арг вещ d, a1 цел n, рез вещ Sn ) нач ввод d, a1 , n Sn:=(2*a1+d*(n-1))*n/2 вывод «Sn=», Sn кон Выход из презентации

№ слайда 5 Задача №2 Задача №3 Задача №1 Выход из презентации Задача №4
Описание слайда:

Задача №2 Задача №3 Задача №1 Выход из презентации Задача №4

№ слайда 6 Начало Ввод n,q, b1 Вывод Вn , Sn Конец Выход из презентации
Описание слайда:

Начало Ввод n,q, b1 Вывод Вn , Sn Конец Выход из презентации

№ слайда 7 алг прогрессия (арг вещ q, b1 цел n, рез вещ Вn , Sn ) 	нач 		ввод q, b1 , n
Описание слайда:

алг прогрессия (арг вещ q, b1 цел n, рез вещ Вn , Sn ) нач ввод q, b1 , n Вn:=b1*q^(n-1) Sn:=(b1*(q^n-1))/(q-1) вывод «Bn=», Bn, «Sn=», Sn кон Выход из презентации

№ слайда 8 Задача 3. Напишите алгоритм вычисления площади параллелограмма S по заданным
Описание слайда:

Задача 3. Напишите алгоритм вычисления площади параллелограмма S по заданным двум сторонам a и b и углу между ними, заданному в градусах f (предварительно перевести градусы f в радианы  по формуле ) Выход из презентации

№ слайда 9 Начало Ввод a, b, f Вывод S Конец Выход из презентации
Описание слайда:

Начало Ввод a, b, f Вывод S Конец Выход из презентации

№ слайда 10 алг площадь (арг вещ a,b,f рез вещ , S) 	нач 		ввод a, b, f 			 :=f*3.14/18
Описание слайда:

алг площадь (арг вещ a,b,f рез вещ , S) нач ввод a, b, f :=f*3.14/180 S:=a*b*sin() вывод «S=», S кон Выход из презентации

№ слайда 11 Начало Ввод х1, х2, х3, у1, у2, у3 Вывод S Конец Выход из презентации
Описание слайда:

Начало Ввод х1, х2, х3, у1, у2, у3 Вывод S Конец Выход из презентации

№ слайда 12 алг задача (арг вещ х1, х2, х3, у1, у2, у3 рез вещ a1, a2,S) нач 	 ввод х1, х
Описание слайда:

алг задача (арг вещ х1, х2, х3, у1, у2, у3 рез вещ a1, a2,S) нач ввод х1, х2, х3, у1, у2, у3 a1:=sqrt(sqr(x2-x1)+sqr(y2-y1)) a2:=sqrt(sqr(x3-x2)+sqr(y3-y2)) S:=a1*a2 вывод «S=», S кон Выход из презентации

№ слайда 13 Задача 5 Составить алгоритм, который с тремя произвольными числами x, y и z
Описание слайда:

Задача 5 Составить алгоритм, который с тремя произвольными числами x, y и z производит вычисления по следующим формулам

№ слайда 14 алг функция (арг вещ x, y, z рез вещ a, b, c, d) 	нач 	 ввод x, y, z 		a:=x/(
Описание слайда:

алг функция (арг вещ x, y, z рез вещ a, b, c, d) нач ввод x, y, z a:=x/(y*y+z^3)+y*y/(z*z-y*y)-(z*z-y)/(x*y + z) b:=(x*x+y-z^3+5*a)/(y*y+z^3-75.5-3*z*y*x)+12.75*y c:=(28*b*x-27*a*y*y)/(z*z)+25*a*b/7 d:=(21*x/b-5)/(a*y)*17.7 вывод a, b, c, d кон

№ слайда 15 Составить алгоритм, который с четырмя произвольными числами a, x, z и w произ
Описание слайда:

Составить алгоритм, который с четырмя произвольными числами a, x, z и w производит вычисления по следующим формулам

№ слайда 16 алг функция (арг вещ a, x, z, w рез вещ b, c, e,f) 	нач 	 ввод a, x, z, w 	 b
Описание слайда:

алг функция (арг вещ a, x, z, w рез вещ b, c, e,f) нач ввод a, x, z, w b:=((z*z-a*a)*7.5-3*(z^3+w)^2+3*x)*z/(25*x*a*w+33.7*z*z) c:=b+a/(5-x/3)^3+120.5*b*x e:=(a*b*c-175*a*(b-3))/(a*b*b*c+17*a*z) f:=2*b+3*e-c*b вывод b, c, e, f кон

№ слайда 17 По представленной блок-схеме составьте алгоритм на школьном алгоритмическом я
Описание слайда:

По представленной блок-схеме составьте алгоритм на школьном алгоритмическом языке Начало Ввод a, b, c Вывод y Конец

№ слайда 18 алг Задача (арг вещ a, b, c рез вещ s, k, y) нач 	 ввод a,b,c 	 s:= (a+c^4)/(
Описание слайда:

алг Задача (арг вещ a, b, c рез вещ s, k, y) нач ввод a,b,c s:= (a+c^4)/(3*b) k:= s – sqrt(abs(a+2*b*c^4)) y:=a+2*b-(3*s)/(b*c) вывод y кон

№ слайда 19 По представленной блок-схеме составьте алгоритм на школьном алгоритмическом я
Описание слайда:

По представленной блок-схеме составьте алгоритм на школьном алгоритмическом языке Начало Ввод a, b, c Вывод y Конец

№ слайда 20 алг Задача (арг вещ a, b, c рез вещ s, k, y) нач 	 ввод a,b,c 	 s:= (sqrt(3*c
Описание слайда:

алг Задача (арг вещ a, b, c рез вещ s, k, y) нач ввод a,b,c s:= (sqrt(3*c^3+b^5))/(b – c) k:= sqrt(s)+abs(-a*b*c) y:= s+3*k – (s^4)/(b+c) вывод y кон

№ слайда 21
Описание слайда:

№ слайда 22
Описание слайда:

Краткое описание документа:

В презентации представлены примеры решения надач на алгоритм с линейтой структурой.

Решение каждой задачи представлено с помошью блок-схем и на школьном алгоритмическом языке.

Основная цель: освоение учащимися принципа перевода математических выражений на школьный алгоритмический язык, а также научить с блок-схем записывать задачу на школьном алгоритмическом языке.

Для решения задач учащиеся должны вспомнить формулы нахождения суммы членов арифметической и геометрической прогрессии. Формулу Герона(нахождение площади треугоольника по трём сторонам). Формулу для нахождения площади параллелограмма.

Автор
Дата добавления 02.02.2015
Раздел Информатика
Подраздел Презентации
Просмотров517
Номер материала 358344
Получить свидетельство о публикации

Выберите специальность, которую Вы хотите получить:

Обучение проходит дистанционно на сайте проекта "Инфоурок".
По итогам обучения слушателям выдаются печатные дипломы установленного образца.

ПЕРЕЙТИ В КАТАЛОГ КУРСОВ

Похожие материалы

Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.
Специальное предложение
Вверх