Добавить материал и получить бесплатное свидетельство о публикации в СМИ
Эл. №ФС77-60625 от 20.01.2015
Инфоурок / Информатика / Презентации / Презентация на тему "Структура ветвления в алгоритмах"
ВНИМАНИЮ ВСЕХ УЧИТЕЛЕЙ: согласно Федеральному закону № 313-ФЗ все педагоги должны пройти обучение навыкам оказания первой помощи.

Дистанционный курс "Оказание первой помощи детям и взрослым" от проекта "Инфоурок" даёт Вам возможность привести свои знания в соответствие с требованиями закона и получить удостоверение о повышении квалификации установленного образца (180 часов). Начало обучения новой группы: 24 мая.

Подать заявку на курс
  • Информатика

Презентация на тему "Структура ветвления в алгоритмах"

библиотека
материалов
Структура ВЕТВЛЕНИЕ если – то Если условие то действие Все
Структура ВЕТВЛЕНИЕ если – то - иначе Если условие то действие 1 иначе действ...
Составить блок-схему и алгоритм для определения, что больше – площадь круга...
начало Ввод а да Вывод S1 Вывод S2 нет конец
алг функция (арг вещ a, рез вещ S1,S2) 	нач 	 ввод a S1:=3.14*a*a S2:=a*a 		е...
Составить блок-схему и алгоритм на школьном алгоритмическом языке для вычисле...
Блок-схема алгоритма начало Ввод х х≤5 да нет Вывод у конец
алг функция (арг вещ х, рез вещ у) 	нач 	 ввод х 		если х
Составить блок-схему и алгоритм на школьном алгоритмическом языке для вычисле...
Блок-схема алгоритма начало Ввод х х≤-1 да нет y=-x Вывод у конец -1
алг функция (арг вещ х, рез вещ у) 	нач 	 ввод х 		если х-1) и (х
Даны три числа a, b, и c. Если все они равны, то первое увеличьте в 10 раз,...
начало Ввод a, b, c a=b и b=c да a=a*10 c=c+10 Вывод a, b, c нет а=с да a=a+1...
алг функция (арг вещ a,b,c рез вещ S) 	нач 	 ввод a,b,c 		если (a=b) и (b=c)...
алг задача (арг вещ х рез вещ у лит t) нач ввод х у:= abs(x) + sin(x) если (х...
Задачи для самостоятельного решения
Даны три числа x, y и z. Если числа равны, то увеличьте их в три раза и выве...
20 1

Описание презентации по отдельным слайдам:

№ слайда 1
Описание слайда:

№ слайда 2 Структура ВЕТВЛЕНИЕ если – то Если условие то действие Все
Описание слайда:

Структура ВЕТВЛЕНИЕ если – то Если условие то действие Все

№ слайда 3 Структура ВЕТВЛЕНИЕ если – то - иначе Если условие то действие 1 иначе действ
Описание слайда:

Структура ВЕТВЛЕНИЕ если – то - иначе Если условие то действие 1 иначе действие 2 Все

№ слайда 4 Составить блок-схему и алгоритм для определения, что больше – площадь круга
Описание слайда:

Составить блок-схему и алгоритм для определения, что больше – площадь круга с радиусом а или площадь квадрата со стороной а. Вывести значение большей площади. Значение числа а вводится. Площадь круга вычисляется по формуле

№ слайда 5 начало Ввод а да Вывод S1 Вывод S2 нет конец
Описание слайда:

начало Ввод а да Вывод S1 Вывод S2 нет конец

№ слайда 6 алг функция (арг вещ a, рез вещ S1,S2) 	нач 	 ввод a S1:=3.14*a*a S2:=a*a 		е
Описание слайда:

алг функция (арг вещ a, рез вещ S1,S2) нач ввод a S1:=3.14*a*a S2:=a*a если S1>S2 то вывод S1 иначе вывод S2 все кон

№ слайда 7 Составить блок-схему и алгоритм на школьном алгоритмическом языке для вычисле
Описание слайда:

Составить блок-схему и алгоритм на школьном алгоритмическом языке для вычисления значений функции у в зависимости от заданного значения аргумента х

№ слайда 8 Блок-схема алгоритма начало Ввод х х≤5 да нет Вывод у конец
Описание слайда:

Блок-схема алгоритма начало Ввод х х≤5 да нет Вывод у конец

№ слайда 9 алг функция (арг вещ х, рез вещ у) 	нач 	 ввод х 		если х
Описание слайда:

алг функция (арг вещ х, рез вещ у) нач ввод х если х<=5 то у:=х^4-3*х/15 иначе у:=4*х+2/(3*x) все вывод у кон

№ слайда 10 Составить блок-схему и алгоритм на школьном алгоритмическом языке для вычисле
Описание слайда:

Составить блок-схему и алгоритм на школьном алгоритмическом языке для вычисления значений функции у в зависимости от заданного значения аргумента х

№ слайда 11 Блок-схема алгоритма начало Ввод х х≤-1 да нет y=-x Вывод у конец -1
Описание слайда:

Блок-схема алгоритма начало Ввод х х≤-1 да нет y=-x Вывод у конец -1<x≤0 да нет

№ слайда 12 алг функция (арг вещ х, рез вещ у) 	нач 	 ввод х 		если х-1) и (х
Описание слайда:

алг функция (арг вещ х, рез вещ у) нач ввод х если х<=-1 то у:=-1/(x*x) иначе если (х>-1) и (х<=0) то у:=-х иначе у:=-х*х все все вывод «у=», у кон

№ слайда 13 Даны три числа a, b, и c. Если все они равны, то первое увеличьте в 10 раз,
Описание слайда:

Даны три числа a, b, и c. Если все они равны, то первое увеличьте в 10 раз, второе уменьшите в 10 раз, а третье увеличьте на 10 и выведите результат. Если равны только первое и последнее число, то увеличьте все числа на 100 и выведите результат. Иначе, найдите и выведите удвоенную сумму этих чисел.

№ слайда 14 начало Ввод a, b, c a=b и b=c да a=a*10 c=c+10 Вывод a, b, c нет а=с да a=a+1
Описание слайда:

начало Ввод a, b, c a=b и b=c да a=a*10 c=c+10 Вывод a, b, c нет а=с да a=a+100 b=b+100 c=c+100 Вывод a, b, c S=2·(a+b+c) Вывод S конец

№ слайда 15 алг функция (арг вещ a,b,c рез вещ S) 	нач 	 ввод a,b,c 		если (a=b) и (b=c)
Описание слайда:

алг функция (арг вещ a,b,c рез вещ S) нач ввод a,b,c если (a=b) и (b=c) то a:=a*10, b:=b/10, c:=c+10 вывод a, b, c иначе если a=c то a:=a+100, b:=b+100, c:=c+100 вывод a, b, c иначе S:=2*(a+b+c) вывод S все все кон

№ слайда 16
Описание слайда:

№ слайда 17 алг задача (арг вещ х рез вещ у лит t) нач ввод х у:= abs(x) + sin(x) если (х
Описание слайда:

алг задача (арг вещ х рез вещ у лит t) нач ввод х у:= abs(x) + sin(x) если (х>=-1) и (х<=0) и (y>=-1) и (y<=2) то t:= «Принадлежит» иначе t:= «Не принадлежит» всё вывод t кон

№ слайда 18 Задачи для самостоятельного решения
Описание слайда:

Задачи для самостоятельного решения

№ слайда 19
Описание слайда:

№ слайда 20 Даны три числа x, y и z. Если числа равны, то увеличьте их в три раза и выве
Описание слайда:

Даны три числа x, y и z. Если числа равны, то увеличьте их в три раза и выведите результаты. Если равны только два последних числа, то замените все числа на противо-положные и выведите результаты. Иначе, все числа сделайте равными 222 и выведите результаты.

Краткое описание документа:

В презентации представлены примеры решения надач на алгоритмы с структурой ветвления.

Решение каждой задачи представлено с помошью блок-схем и на школьном алгоритмическом языке.

Основная цель: Закрепление пройденного материала: “Линейные алгоритмы” , изучение базовой алгоритмической структуры “Ветвление”, видов ветвящихся структур в полной и неполной форме, развитие умений интеллектуальной деятельности: выделять главное, анализировать, обобщать, логически и абстрактно мыслить.

Для решения задач учащиеся должны вспомнить формулы нахождения площади квадрата, площади круга.

Автор
Дата добавления 04.02.2015
Раздел Информатика
Подраздел Презентации
Просмотров323
Номер материала 363410
Получить свидетельство о публикации

Выберите специальность, которую Вы хотите получить:

Обучение проходит дистанционно на сайте проекта "Инфоурок".
По итогам обучения слушателям выдаются печатные дипломы установленного образца.

ПЕРЕЙТИ В КАТАЛОГ КУРСОВ

Похожие материалы

Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.
Специальное предложение
Вверх