Скачивание материала началось

Предлагаем Вам установить расширение «Инфоурок» для удобного поиска материалов:

ПЕРЕЙТИ К УСТАНОВКЕ
Каждую неделю мы делим 100 000 ₽ среди активных педагогов. Добавьте свои разработки в библиотеку “Инфоурок”
Добавить авторскую разработку
и получить бесплатное свидетельство о публикации в СМИ №ФС77-60625 от 20.01.2015 Свидетельство о публикации
Инфоурок Информатика ПрезентацииПрезентация с задачами А6 для подготовки к ГИА

Презентация с задачами А6 для подготовки к ГИА

библиотека
материалов
Исполнители алгоритмов

Описание презентации по отдельным слайдам:

1 слайд Исполнители алгоритмов
Описание слайда:

Исполнители алгоритмов

2 слайд №1
Описание слайда:

№1

3 слайд № 9
Описание слайда:

№ 9

4 слайд №4 Исполнитель Черепашка перемещается на экране компьютера, оставляя след в в
Описание слайда:

№4 Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды: Вперед n (где n – целое число), вызывающая передвижение Черепашки на n шагов в направлении движения. Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке. Запись Повтори k [Команда1 Команда2 Команда3] означает, что последовательность команд в скобках повторится k раз. Черепашке был дан для исполнения следующий алгоритм: Повтори 12 [Направо 45 Вперед 20 Направо 45] Какая фигура появится на экране? 1) квадрат 2) правильный двенадцатиугольник 3) правильный восьмиугольник 4) незамкнутая ломаная линия

5 слайд №5 Исполнитель Черепашка перемещается на экране компьютера, оставляя след в в
Описание слайда:

№5 Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды: Вперед n (где n – целое число), вызывающая передвижение Черепашки на n шагов в направлении движения. Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке. Запись Повтори k [Команда1 Команда2 Команда3] означает, что последовательность команд в скобках повторится k раз. Черепашке был дан для исполнения следующий алгоритм: Повтори 4 [Направо 60 Вперед 20 Направо 60] Какая фигура появится на экране? 1) правильный треугольник 2) квадрат 3) правильный шестиугольник 4) незамкнутая ломаная линия

6 слайд
Описание слайда:

7 слайд № 10
Описание слайда:

№ 10

8 слайд №3 Исполнитель Черепашка перемещается на экране компьютера, оставляя след в в
Описание слайда:

№3 Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды: Вперед n (где n - целое число), вызывающая передвижение Черепашки на n шагов в направлении движения. Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке. Запись Повтори 5 [Команда1 Команда2] означает, что последовательность команд в скобках повторится 5 раз. Черепашке был дан для исполнения следующий алгоритм: Повтори 6 [Вперед 10 Направо 72] Какая фигура появится на экране? 1) незамкнутая ломаная линия 2) квадрат 3) правильный пятиугольник 4) правильный шестиугольник

9 слайд Дополнительно
Описание слайда:

Дополнительно

10 слайд Дополнительно «Робот»
Описание слайда:

Дополнительно «Робот»

Курс профессиональной переподготовки
Учитель информатики
Курс профессиональной переподготовки
Учитель математики и информатики
Найдите материал к любому уроку,
указав свой предмет (категорию), класс, учебник и тему:
также Вы можете выбрать тип материала:
Краткое описание документа:

В данной презентации рассматриваются три вида задач: на исполнитель Чертежник, Черепашка и Муравей

Общая информация

Оставьте свой комментарий

Авторизуйтесь, чтобы задавать вопросы.