Добавить материал и получить бесплатное свидетельство о публикации в СМИ
Эл. №ФС77-60625 от 20.01.2015
Инфоурок / Информатика / Другие методич. материалы / Применение вложенных условных функций в электронных таблицах (9-11 классы)
ВНИМАНИЮ ВСЕХ УЧИТЕЛЕЙ: согласно Федеральному закону № 313-ФЗ все педагоги должны пройти обучение навыкам оказания первой помощи.

Дистанционный курс "Оказание первой помощи детям и взрослым" от проекта "Инфоурок" даёт Вам возможность привести свои знания в соответствие с требованиями закона и получить удостоверение о повышении квалификации установленного образца (180 часов). Начало обучения новой группы: 24 мая.

Подать заявку на курс
  • Информатика

Применение вложенных условных функций в электронных таблицах (9-11 классы)

библиотека
материалов

Практическая работа в электронных таблицах предназначена для учащихся 9, 10 и 11 классов углубленного изучения информатики и ИКТ.

Учащиеся должны уметь:

- работать с математическими формулами в плане их преобразования,

- применять абсолютные ссылки;

- логически размышлять и строить алгоритм решения поставленной задачи;

- знать правила написания логической функции и читать готовые алгоритмы решения;

- вводить формулы в электронных таблицах разными способами.

Задание подойдет как для повторения материала, так и для самостоятельной работы.

Данная практическая работа больше подходит в качестве раздаточного материала.

Также предоставляется лист для учителя для проверки результатов решения задания.








Практическая работа с применением вложенных условных функций


Задача «Автостоянка» Владелец автостоянки хочет автоматизировать расчеты с клиентами за услуги и знать количество занятых мест за определенные промежутки времени.


Для времени приезда и отъезда выбран формат, в котором до запятой указываются часы, а после запятой – минуты. Это позволяет работать с этими данными как с числами.

1.Перевод времени приезда в минуты выглядит так: 60*Целое(В2)+(В2-Целое(В2))*100

Где Целое(В2) – это целая часть числа, записанного в ячейку В2.

2. Определите формулу для определения продолжительности стоянки в минутах.

3.Определите стоимость каждого места, учитывая цену стоянки автомобиля за 1 час (абсолютная ссылка).


hello_html_m333142c3.png


4. В ячейке F20 подсчитайте дневной доход автостоянки.

5.Определите в ячейке G6 количество мест, которые были заняты между 11 и 12 часами по следующей формуле: (Подумайте, как можно облегчить ввод таких длинных формул)


=ЕСЛИ(И(B2>11;C2<12);1;0)+ЕСЛИ(И(B3>11;C3<12);1;0)+ЕСЛИ(И(B4>11;C4<12);1;0)+

CЛИ(И(B5>11;C5<12);1;0)+ЕСЛИ(И(B6>11;C6<12);1;0)+ЕСЛИ(И(B7>11;C7<12);1;0)+

CЛИ(И(B8>11;C8<12);1;0)+ЕСЛИ(И(B9>11;C9<12);1;0)+ЕСЛИ(И(B10>11;C10<12);1;0)+

+ЕСЛИ(И(B11>11;C11<12);1;0)+ЕСЛИ(И(B12>11;C12<12);1;0)+ЕСЛИ(И(B13>11;C13<12);1;0)+

+ЕСЛИ(И(B14>11;C14<12);1;0)+ЕСЛИ(И(B15>11;C15<12);1;0)+ЕСЛИ(И(B16>11;C16<12);1;0)+

+ЕСЛИ(И(B17>11;C17<12);1;0)+ЕСЛИ(И(B18>11;C18<12);1;0)+ЕСЛИ(И(B19>11;C19<12);1;0)+

+ЕСЛИ(И(B20>11;C20<12);1;0)+ЕСЛИ(И(B21>11;C21<12);1;0)


6.Аналогично определите кол-во мест между 12 и 24 часами.


ЛИСТ для учителя с результатом практической работы


Задача «Автостоянка» Владелец автостоянки хочет автоматизировать расчеты с клиентами за услуги и знать количество занятых мест за определенные промежутки времени.


Для времени приезда и отъезда выбран формат, в котором до запятой указываются часы, а после запятой – минуты. Это позволяет работать с этими данными как с числами.

1.Перевод времени приезда в минуты выглядит так: 60*Целое(В2)+(В2-Целое(В2))*100 (1 формула)

Где Целое(В2) – это целая часть числа, записанного в ячейку В2.

2. Определите формулу для определения продолжительности стоянки в минутах.

(из преобразований 1 формулы): =40*(ЦЕЛОЕ(B2)-ЦЕЛОЕ(C2))+(C2-B2)*100 ( в ячейку D2)


3.Определите стоимость каждого места, учитывая цену стоянки автомобиля за 1 час (абсолютная ссылка).


hello_html_6d57356e.png


4. В ячейке F20 подсчитайте дневной доход автостоянки.

5.Определите в ячейке G6 количество мест, которые были заняты между 11 и 12 часами по следующей формуле: (Подумайте, как можно облегчить ввод таких длинных формул)


=ЕСЛИ(И(B2>11;C2<12);1;0)+ЕСЛИ(И(B3>11;C3<12);1;0)+ЕСЛИ(И(B4>11;C4<12);1;0)+

CЛИ(И(B5>11;C5<12);1;0)+ЕСЛИ(И(B6>11;C6<12);1;0)+ЕСЛИ(И(B7>11;C7<12);1;0)+

CЛИ(И(B8>11;C8<12);1;0)+ЕСЛИ(И(B9>11;C9<12);1;0)+ЕСЛИ(И(B10>11;C10<12);1;0)+

+ЕСЛИ(И(B11>11;C11<12);1;0)+ЕСЛИ(И(B12>11;C12<12);1;0)+ЕСЛИ(И(B13>11;C13<12);1;0)+

+ЕСЛИ(И(B14>11;C14<12);1;0)+ЕСЛИ(И(B15>11;C15<12);1;0)+ЕСЛИ(И(B16>11;C16<12);1;0)+

+ЕСЛИ(И(B17>11;C17<12);1;0)+ЕСЛИ(И(B18>11;C18<12);1;0)+ЕСЛИ(И(B19>11;C19<12);1;0)+

+ЕСЛИ(И(B20>11;C20<12);1;0)+ЕСЛИ(И(B21>11;C21<12);1;0)


6.Аналогично определите кол-во мест между 12 и 24 часами.

ОТВЕТ : 8 мест




Краткое описание документа:

Практическая работа в электронных таблицах  предназначена для учащихся 9, 10 и 11 классов углубленного изучения информатики и ИКТ.

Учащиеся должны уметь:

- работать с математическими формулами в плане их преобразования,

- применять абсолютные ссылки;

- логически размышлять и строить алгоритм решения поставленной задачи;

- знать правила написания логической функции и читать готовые алгоритмы решения;

- вводить формулы в электронных таблицах разными способами.

Задание  подойдет как для повторения материала, так и для самостоятельной работы.

Данная практическая работа больше подходит в качестве раздаточного материала.

Также предоставляется лист для учителя для проверки результатов решения задания.

 

 

 

Автор
Дата добавления 13.01.2015
Раздел Информатика
Подраздел Другие методич. материалы
Просмотров651
Номер материала 296465
Получить свидетельство о публикации

Выберите специальность, которую Вы хотите получить:

Обучение проходит дистанционно на сайте проекта "Инфоурок".
По итогам обучения слушателям выдаются печатные дипломы установленного образца.

ПЕРЕЙТИ В КАТАЛОГ КУРСОВ

Похожие материалы

Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.
Специальное предложение
Вверх