Добавить материал и получить бесплатное свидетельство о публикации в СМИ
Эл. №ФС77-60625 от 20.01.2015
Инфоурок / Информатика / Тесты / Проверочная работа по теме "Алгоритмизация" (9 класс)

Проверочная работа по теме "Алгоритмизация" (9 класс)

  • Информатика

Поделитесь материалом с коллегами:

Проверочная работа по теме «Алгоритмизация»

Вариант 1

  1. Дать определения понятиям: алгоритм, циклический алгоритм

  2. Определите значения переменных x и y после выполнения фрагмента алгоритма.

Полотно 55



3. Чему будет равна переменная c после выполнения этого алгоритма:

a:= 20

b:= 3

b:= a div b

c:= a mod (b+1)



  1. Определите значение целочисленных переменных x и y после выполнения фрагмента программы.


i:=0; S:=0

нц пока i<3

i:=i+1;

S:=S+i*i

кц


5. Составьте алгоритм нахождения суммы всех двухзначных чисел, кратных трем, используя цикл с параметром.

















Проверочная работа по теме «Алгоритмизация»

Вариант 2

1. Дать определения понятиям: алгоритм, разветвляющийся алгоритм

2. Определите значения переменных x и y после выполнения фрагмента алгоритма

Полотно 56


  1. Чему будет равна переменная c после выполнения этого алгоритма:

a:= 28

b:= 7

b:= a mod b

c:= a div (b+1)


4. Определите значения переменно s после выполнения фрагмента алгоритма.

s:=0

нц для i от 1 до 5

s:=s+i*i

кц


5. Составьте алгоритм нахождения произведения всех двухзначных чисел, кратных пяти, используя цикл с параметром.





Выберите курс повышения квалификации со скидкой 50%:

Автор
Дата добавления 27.10.2016
Раздел Информатика
Подраздел Тесты
Просмотров128
Номер материала ДБ-294698
Получить свидетельство о публикации

Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.
Специальное предложение
Вверх