Инфоурок / Информатика / Конспекты / Работа с массивами данных в Microsoft Excel

Работа с массивами данных в Microsoft Excel


библиотека
материалов

Работа с массивами данных в Microsoft Excel Массив данных представляет собой набор значений, сгруппированных по строкам и столбцам. Примерами массивов являются векторы и матрицы. Для выполнения вычислений с массивами ввод формул осуществляется следующим образом: выделить ячейки, в которых необходимо создать формулу, ввести формулу, затем перейти в строку формул и нажать Ctrl + Shift + Enter, при этом формула автоматически будет заключена в фигурные скобки. Эти действия используются всегда, если нужно одновременно воздействовать на набор значений. Основные функции Excel для работы с матрицами: определитель матрицы – МОПРЕД, обратная матрица – МОБР, транспонированная матрица – ТРАНСП. ПРИМЕР. Транспонировать матрицу, расположенную в ячейках В3:Е5 (рис. 1), и возвести все ее элементы в квадрат. Рис. 1. Работа с массивом данных Последовательность действий: 1) Выделить группу ячеек, куда нужно поместить результирующую матрицу (например, А8:C11). При этом количество выделенных ячеек и их положение должны строго соответствовать количеству результирующих данных. 2) Нажать  = , затем любым способом запустить мастер функций . 3) В категории «Полный алфавитный перечень» выбрать функцию ТРАНСП. 4) В диалоговом окне функции ТРАНСП щелчком на кнопке в поле «Массив» перейти на рабочий лист, выделить ячейки с исходными данными (В3:Е5). 5) Установить курсор в строку формул и набрать  ^2 (возведение в квадрат). При этом в строке формул будет сформирована формула   =ТРАНСП(B3:E5)^2 . 6) Нажать Ctrl + Shift + Enter. В результате формула будет заключена в фигурные скобки и примет окончательный вид  {=ТРАНСП(B3:E5)^2}, а в результирующих ячейках А8:C11 появятся вычисленные значения. Для исключения ошибочных ситуаций при работе с массивами перед нажатием клавиш Ctrl + Shift + Enter курсор всегда следует устанавливать в строку формул. В некоторых случаях при вычислениях в ячейке результата Excel выдает ошибку #ЗНАЧ. При работе с массивами наиболее частой причиной такой ошибки является то, что с элементами массива была введена простая формула (после ввода формулы нажата клавиша Enter или кнопка OK вместо комбинации Ctrl + Shift + Enter). Исправить это можно следующим образом: выделить ячейки результата, перейти в строку формул и нажать Ctrl + Shift + Enter. Если расчет не получился, то зачастую причина ошибки заключается в том, что в начале формулы отсутствует знак “=”. Вычисления с проверкой условия Для подсчета количества значений с каким-либо условием в Excel используется функция СЧЕТЕСЛИ. Для выборки записей, удовлетворяющих заданному условию, используется функция ЕСЛИ. Обе эти функции имеются в списке мастера функций. Рассмотрим их использование на примере таблицы успеваемости студентов (рис.2). Рис. 2. Таблица успеваемости студентов Функция СЧЕТЕСЛИ Общая форма записи: СЧЕТЕСЛИ (диапазон анализируемых ячеек; проверяемое условие) ПРИМЕР. По каждому учебному предмету подсчитать количество студентов, имеющих оценку 5, и вывести полученные результаты в 15-й строке Excel. Последовательность действий: Установить курсор в первую ячейку результата B15, нажать  = . Запустить мастер функций и выбрать функцию СЧЕТЕСЛИ. В результате откроется диалоговое окно этой функции для ввода ее параметров, где в поле «Диапазон» указать диапазон проверяемых ячеек, а в поле «Критерий» – проверяемое условие (рис. 3). Рис. 3. Диалоговое окно функции СЧЕТЕСЛИ Окончательно формула в ячейке B15 будет иметь вид:  =СЧЁТЕСЛИ(В10:В13;"=5"). Для подсчета количества пятерок по другим предметам введенную в ячейку B15 формулу нужно скопировать в ячейки C15:D15, протащив за маркер автозаполнения. Функция ЕСЛИ Общая форма записи: ЕСЛИ (условие; результат при выполнении условия; результат при невыполнении условия) ПРИМЕР. В столбце F (см. рис. 2) вывести фамилии студентов, имеющих средний балл больше 4. Последовательность действий: Установить курсор в первую ячейку результата F10, нажать  = . Запустить мастер функций, выбрать функцию ЕСЛИ и в диалоговом окне этой функции задать необходимые параметры (рис. 4). Рис. 4. Диалоговое окно функции ЕСЛИ В отличие от функции СЧЕТЕСЛИ в функции ЕСЛИ проверяемые ячейки и условие вводятся в одно поле «Лог_выражение» (в функции СЧЕТЕСЛИ – в разные поля). Если поле «Значение_если_ложь» оставить пустым, то в ячейке результата при невыполнении условия будет выводиться слово «ЛОЖЬ». Чтобы этого избежать, надо ввести в этом поле пробел (или текст, которым нужно сопроводить вывод соответствующего результата). Окончательно формула в ячейке F10 будет иметь вид:   =ЕСЛИ(E10>4; A10; " "), затем нужно ее скопировать в ячейки F11:F13 с помощью автозаполнения.

Только до конца зимы! Скидка 60% для педагогов на ДИПЛОМЫ от Столичного учебного центра!

Курсы профессиональной переподготовки и повышения квалификации от 1 400 руб.
Для выбора курса воспользуйтесь удобным поиском на сайте KURSY.ORG


Вы получите официальный Диплом или Удостоверение установленного образца в соответствии с требованиями государства (образовательная Лицензия № 038767 выдана ООО "Столичный учебный центр" Департаментом образования города МОСКВЫ).

Московские документы для аттестации: KURSY.ORG


Общая информация

Номер материала: ДВ-188554

Похожие материалы



Очень низкие цены на курсы переподготовки от Московского учебного центра для педагогов

Специально для учителей, воспитателей и других работников системы образования действуют 60% скидки (только до конца зимы) при обучении на курсах профессиональной переподготовки (124 курса на выбор).

После окончания обучения выдаётся диплом о профессиональной переподготовке установленного образца с присвоением квалификации (признаётся при прохождении аттестации по всей России).

Подайте заявку на интересующий Вас курс сейчас: KURSY.ORG