Добавить материал и получить бесплатное свидетельство о публикации в СМИ
Эл. №ФС77-60625 от 20.01.2015
Инфоурок / Информатика / Конспекты / Работа с массивами данных в Microsoft Excel
ВНИМАНИЮ ВСЕХ УЧИТЕЛЕЙ: согласно Федеральному закону № 313-ФЗ все педагоги должны пройти обучение навыкам оказания первой помощи.

Дистанционный курс "Оказание первой помощи детям и взрослым" от проекта "Инфоурок" даёт Вам возможность привести свои знания в соответствие с требованиями закона и получить удостоверение о повышении квалификации установленного образца (180 часов). Начало обучения новой группы: 24 мая.

Подать заявку на курс
  • Информатика

Работа с массивами данных в Microsoft Excel

библиотека
материалов

Работа с массивами данных в Microsoft Excel Массив данных представляет собой набор значений, сгруппированных по строкам и столбцам. Примерами массивов являются векторы и матрицы. Для выполнения вычислений с массивами ввод формул осуществляется следующим образом: выделить ячейки, в которых необходимо создать формулу, ввести формулу, затем перейти в строку формул и нажать Ctrl + Shift + Enter, при этом формула автоматически будет заключена в фигурные скобки. Эти действия используются всегда, если нужно одновременно воздействовать на набор значений. Основные функции Excel для работы с матрицами: определитель матрицы – МОПРЕД, обратная матрица – МОБР, транспонированная матрица – ТРАНСП. ПРИМЕР. Транспонировать матрицу, расположенную в ячейках В3:Е5 (рис. 1), и возвести все ее элементы в квадрат. Рис. 1. Работа с массивом данных Последовательность действий: 1) Выделить группу ячеек, куда нужно поместить результирующую матрицу (например, А8:C11). При этом количество выделенных ячеек и их положение должны строго соответствовать количеству результирующих данных. 2) Нажать  = , затем любым способом запустить мастер функций . 3) В категории «Полный алфавитный перечень» выбрать функцию ТРАНСП. 4) В диалоговом окне функции ТРАНСП щелчком на кнопке в поле «Массив» перейти на рабочий лист, выделить ячейки с исходными данными (В3:Е5). 5) Установить курсор в строку формул и набрать  ^2 (возведение в квадрат). При этом в строке формул будет сформирована формула   =ТРАНСП(B3:E5)^2 . 6) Нажать Ctrl + Shift + Enter. В результате формула будет заключена в фигурные скобки и примет окончательный вид  {=ТРАНСП(B3:E5)^2}, а в результирующих ячейках А8:C11 появятся вычисленные значения. Для исключения ошибочных ситуаций при работе с массивами перед нажатием клавиш Ctrl + Shift + Enter курсор всегда следует устанавливать в строку формул. В некоторых случаях при вычислениях в ячейке результата Excel выдает ошибку #ЗНАЧ. При работе с массивами наиболее частой причиной такой ошибки является то, что с элементами массива была введена простая формула (после ввода формулы нажата клавиша Enter или кнопка OK вместо комбинации Ctrl + Shift + Enter). Исправить это можно следующим образом: выделить ячейки результата, перейти в строку формул и нажать Ctrl + Shift + Enter. Если расчет не получился, то зачастую причина ошибки заключается в том, что в начале формулы отсутствует знак “=”. Вычисления с проверкой условия Для подсчета количества значений с каким-либо условием в Excel используется функция СЧЕТЕСЛИ. Для выборки записей, удовлетворяющих заданному условию, используется функция ЕСЛИ. Обе эти функции имеются в списке мастера функций. Рассмотрим их использование на примере таблицы успеваемости студентов (рис.2). Рис. 2. Таблица успеваемости студентов Функция СЧЕТЕСЛИ Общая форма записи: СЧЕТЕСЛИ (диапазон анализируемых ячеек; проверяемое условие) ПРИМЕР. По каждому учебному предмету подсчитать количество студентов, имеющих оценку 5, и вывести полученные результаты в 15-й строке Excel. Последовательность действий: Установить курсор в первую ячейку результата B15, нажать  = . Запустить мастер функций и выбрать функцию СЧЕТЕСЛИ. В результате откроется диалоговое окно этой функции для ввода ее параметров, где в поле «Диапазон» указать диапазон проверяемых ячеек, а в поле «Критерий» – проверяемое условие (рис. 3). Рис. 3. Диалоговое окно функции СЧЕТЕСЛИ Окончательно формула в ячейке B15 будет иметь вид:  =СЧЁТЕСЛИ(В10:В13;"=5"). Для подсчета количества пятерок по другим предметам введенную в ячейку B15 формулу нужно скопировать в ячейки C15:D15, протащив за маркер автозаполнения. Функция ЕСЛИ Общая форма записи: ЕСЛИ (условие; результат при выполнении условия; результат при невыполнении условия) ПРИМЕР. В столбце F (см. рис. 2) вывести фамилии студентов, имеющих средний балл больше 4. Последовательность действий: Установить курсор в первую ячейку результата F10, нажать  = . Запустить мастер функций, выбрать функцию ЕСЛИ и в диалоговом окне этой функции задать необходимые параметры (рис. 4). Рис. 4. Диалоговое окно функции ЕСЛИ В отличие от функции СЧЕТЕСЛИ в функции ЕСЛИ проверяемые ячейки и условие вводятся в одно поле «Лог_выражение» (в функции СЧЕТЕСЛИ – в разные поля). Если поле «Значение_если_ложь» оставить пустым, то в ячейке результата при невыполнении условия будет выводиться слово «ЛОЖЬ». Чтобы этого избежать, надо ввести в этом поле пробел (или текст, которым нужно сопроводить вывод соответствующего результата). Окончательно формула в ячейке F10 будет иметь вид:   =ЕСЛИ(E10>4; A10; " "), затем нужно ее скопировать в ячейки F11:F13 с помощью автозаполнения.

Автор
Дата добавления 25.11.2015
Раздел Информатика
Подраздел Конспекты
Просмотров437
Номер материала ДВ-188554
Получить свидетельство о публикации

Выберите специальность, которую Вы хотите получить:

Обучение проходит дистанционно на сайте проекта "Инфоурок".
По итогам обучения слушателям выдаются печатные дипломы установленного образца.

ПЕРЕЙТИ В КАТАЛОГ КУРСОВ

Похожие материалы

Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.
Специальное предложение
Вверх