Добавить материал и получить бесплатное свидетельство о публикации в СМИ
Эл. №ФС77-60625 от 20.01.2015
Инфоурок / Информатика / Другие методич. материалы / Разноуровневые дидактические материалы по теме: "Основы алгоритмизации и программирования в среде КУМИР" (8 класс)
ВНИМАНИЮ ВСЕХ УЧИТЕЛЕЙ: согласно Федеральному закону № 313-ФЗ все педагоги должны пройти обучение навыкам оказания первой помощи.

Дистанционный курс "Оказание первой помощи детям и взрослым" от проекта "Инфоурок" даёт Вам возможность привести свои знания в соответствие с требованиями закона и получить удостоверение о повышении квалификации установленного образца (180 часов). Начало обучения новой группы: 26 апреля.

Подать заявку на курс
  • Информатика

Разноуровневые дидактические материалы по теме: "Основы алгоритмизации и программирования в среде КУМИР" (8 класс)

библиотека
материалов

hello_html_m4ac5d449.gifhello_html_m4ac5d449.gifhello_html_m4ac5d449.gifhello_html_m4ac5d449.gifhello_html_m4ac5d449.gifhello_html_m4ac5d449.gifhello_html_77c46134.gifhello_html_m62237ab3.gifhello_html_m4ac5d449.gifhello_html_3dd0be10.gifhello_html_m4ac5d449.gifhello_html_mb419d65.gifhello_html_m710c44e8.gifhello_html_m695a8987.gifhello_html_m4ac5d449.gifhello_html_m4ac5d449.gifhello_html_m4ac5d449.gifhello_html_m5b785d60.gifhello_html_m62237ab3.gifhello_html_42881771.gifhello_html_5ef63394.gifhello_html_6713afe1.gifhello_html_4800f332.gifhello_html_mc1d5302.gifhello_html_763618ee.gifhello_html_m10606387.gifhello_html_4c447aec.gifhello_html_7c1e5f63.gifhello_html_m1b9bec12.gifРазноуровневые дидактические задания по теме «Основы алгоритмизации и программирования» в среде КУМИР
(8 класс)

Учитель информатики ГБОУ РШИ №32 г. Москва

Овсянникова Татьяна Юрьевна

Цель:

- закрепление навыков построения блок-схем алгоритмов

- усвоение правил написания программы на алгоритмическом языке в среде КУМИР и назначения операторов


Тема 1: Линейный алгоритм

Уровень 1.

Решение каждой задачи оценивается в 0,5 балла



  1. Даны текст программы на алгоритмическом языке и блок-схема этого алгоритма. Попарно поставить в соответствие операторы алгоритмического языка и элементы блок-схемы.



hello_html_51b5e6d3.png













  1. Дан фрагмент программы на алгоритмическом языке. Используя знания об операторе присваивания найти значение указанной переменной



Чему равно значение переменной а после выполнения следующего фрагмента программы, записанной на алгоритмическом языке?

Задача 1

Задача 2

Задача 3

Задача 4

a:=1

b:=2

a:=a+b

a:=a*b

a:=0

b:=10

b:=a+10

a:=a+b

a:=10

b:=a*2

a:=a+b

a:=a-b

a:=2

b:=6

a:=b+2*a

a:=a-1

Чему равно значение переменной s после выполнения следующего фрагмента программы, записанной на алгоритмическом языке?

Задача 5

Задача 6

Задача 7

Задача 8

a:=1

b:=2

a:=b*3+5

s:=a+b

a:=10

b:=a+7

s:=b*2

s:=s-10

s:=0

b:=0

a:=s*b+100

s:=a+b

s:=0

a:=0

b:=0

s:=a*b+s

Чему равно значение переменной k после выполнения следующего фрагмента программы, записанной на алгоритмическом языке?

Задача 9

Задача 10

Задача 11

Задача 12

a:=1

b:=1

c:=2

k:=(2*a+b)*c

k:=k-1

a:=10

b:=a-5

c:=a+2

k:=100

k:=a+b+c

a:=0

b:=40

c:=b-a

k:=c

k:=k+b

a:=2

b:=a

c:=b

k:=c

k:=a*b*c*k































Уровень 2.

Решение каждой задачи оценивается в 1 балл



  1. Дан текст программы на алгоритмическом языке. Построить блок-схему соответствующего алгоритма.



Задача 1.



цел а, b, c

алг

нач

вывод «введите два числа»

ввод а

ввод b

c:=a+b

вывод «сумма равна =»

вывод с

кон


Задача 2.



цел а, b, c, d

алг

нач

вывод «введите два числа»

ввод а

ввод b

c:=a+b

d:=a*b

вывод «сумма равна =»

вывод с

вывод «произведение равно =»

вывод d

кон










































  1. Дан текст программы на алгоритмическом языке. Найти ошибки.



Задача 1.



алг

нач

вывод «введите два числа»

ввод а

ввод b

c:=a+b

вывод «сумма равна =»

вывод с

кон

Задача 2.



цел а, b, c

вывод «введите два числа»

ввод а

ввод b

c:=a+b

вывод «сумма равна =»

вывод с


Задача 3.

цел а, b, c

алг

нач

вывод «введите два числа»

ввод d

ввод s

c:=a+b

вывод «сумма равна =»

вывод с

кон

Задача 4.



цел а, b, c

алг

нач

вывод «введите два числа»

ввод а

ввод b

c=a+b

вывод «сумма равна =»

вывод с

кон

Задача 5.



цел а, b, c

алг

нач

вывод введите два числа

ввод а

ввод b

c:=a+b

вывод сумма равна =

вывод с

кон


Задача 6.



цел а, b, c

алг

нач

вывод «введите два числа»

вывод а

вывод b

c:=a+b

вывод «сумма равна =»

вывод с

кон








Уровень 3.

Решение каждой задачи оценивается в 2 балла



  1. Дана блок-схема алгоритма. Написать соответствующую программу на алгоритмическом языке

начало

Введите числа: a1, b1, a2, b2, b3

c1:=a1+b2

c2:=a2*b2

c3:=c2*b3

Вывод c1, c2, c3

конец



Задача 1

Задача 2




































конец

Площадь поверхности куба равна s

S:=6*a^2

Введите длину стороны куба a

начало
































Тема 2: Условный алгоритм

Уровень 1.

Решение каждой задачи оценивается в 0,5 балла



    1. Даны текст программы на алгоритмическом языке и блок-схема этого алгоритма. Попарно поставить в соответствие операторы алгоритмического языка и элементы блок-схемы.

hello_html_71b2787.png





















    1. Дан фрагмент программы на алгоритмическом языке. Используя знания об операторе присваивания найти значение указанной переменной

Чему равно значение переменной а после выполнения следующих операторов?

Задача 1.

Задача 2.

Задача 3.

Задача 4.

а:=20

если а>100 то

а:=а+1 иначе

а:=а-1 все

а:=а*8

a:=10

если a<100 то

a:=7 иначе

a:=a*10 всё

a:=a*10

a:=0

если a=2 то

a:=a+2 иначе

a:=35*a всё

вывод a

a:=5

если a>0 то

a:=a^2 иначе

a:=a^3 всё

a:=a+50

Чему равно значение переменной s после выполнения следующих операторов?

Задача 5.

Задача 6.

Задача 7.

Задача 8.

a:=1

s:=2

если (a>0) и (s>0) то

s:=2*s+a иначе

a:=2*a+s всё

s:=s+a

a:=10

s:=-1

если (a>0) и (s>0) то

s:=2*s+a иначе

s:=0

a:=2*a+s всё

s:=s+a

a:=1

s:=-7

если (a>0) и (s<0) то

s:=2*s+a иначе

a:=2*a+s всё

s:=s+a

a:=1

s:=2

если (a>0) и (s>0) то

a:=5

s:=2*s+a иначе

a:=2*a+s всё

s:=s+a









































Уровень 2.

Решение каждой задачи оценивается в 1 балл.



    1. Дан текст программы на алгоритмическом языке. Найти ошибки.



Задача 1

Задача 2

алг

нач

вывод «введите два числа»

ввод а

ввод b

если a>b то

c:=a+b иначе

c:=a-b всё

вывод «результат равен =»

вывод с

кон

цел а, b, c

вывод «введите два числа»

ввод а

ввод b

если a>b то

c:=a+b иначе

c:=a-b всё

вывод «результат равен =»

вывод с


Задача 3

Задача 4

цел а, b, c

алг

нач

вывод «введите два числа»

ввод y

ввод r

если a>b то

c:=a+b иначе

c:=a-b всё

вывод «результат равен =»

вывод с

кон

цел а, b, c

алг

нач

вывод «введите два числа»

ввод а

ввод b

если a>b то

c=a+b иначе

c=a-b всё

вывод «результат равен =»

вывод с

кон

Задача 5

Задача 6

цел а, b, c

алг

нач

вывод введите два числа

ввод а

ввод b

если a>b то

c:=a+b иначе

c:=a-b всё

вывод результат равен =

вывод с

кон

цел а, b, c

алг

нач

вывод «введите два числа»

вывод а

вывод b

если a>b то

c:=a+b иначе

c:=a-b всё

ввод «результат равен =»

ввод с

кон

Задача 7

Задача 8

цел а, b, c

алг

нач

вывод «введите два числа»

ввод а

ввод b

если a>b то

c:=a+b

c:=a-b

вывод «результат равен =»

вывод с

кон

цел а, b, c

алг

нач

вывод «введите два числа»

ввод а

ввод b

если a>b иначе

c:=a+b то

c:=a-b всё

вывод «результат равен =»

вывод с

кон



















































    1. Дан текст программы на алгоритмическом языке. Построить блок-схему соответствующего алгоритма.



Задача 1.

Задача 2.

цел а, b, c

алг

нач

вывод «введите два числа»

ввод а

ввод b

если a>b то

c:=a+b иначе

c:=a-b всё

вывод «результат равен =»

вывод с

кон

цел а

алг

нач

вывод «введите целое число»

ввод а

если a>0 то

a:=a*100 иначе

a:=a*1000 всё

вывод «результат равен =»

вывод a

кон


Задача 3

цел x, y

алг

нач

вывод «введите число х»

ввод x

если х<5 то

y:=2*x иначе

если x=5 то

y:=x+10 иначе

y:=x-5

всё

всё

вывод «результат равен =»

вывод y

кон



















Уровень 3.

Решение каждой задачи оценивается в 2 балла.



    1. Дана блок-схема алгоритма. Написать соответствующую программу на алгоритмическом языке

Задача 1

начало





Ввести х и у





Х22<25



да





Х22<=100

нет

нет



да

«не принадлежит»

«принадлежит»









конец




































Задача 2

начало







Ввести А В и С





М=А





B



да



М=В

нет





С



да

М=С



нет



hello_html_m5bc53fc1.gif







Р







конец






























































Автор
Дата добавления 11.03.2016
Раздел Информатика
Подраздел Другие методич. материалы
Просмотров272
Номер материала ДВ-518531
Получить свидетельство о публикации

"Инфоурок" приглашает всех педагогов и детей к участию в самой массовой интернет-олимпиаде «Весна 2017» с рекордно низкой оплатой за одного ученика - всего 45 рублей

В олимпиадах "Инфоурок" лучшие условия для учителей и учеников:

1. невероятно низкий размер орг.взноса — всего 58 рублей, из которых 13 рублей остаётся учителю на компенсацию расходов;
2. подходящие по сложности для большинства учеников задания;
3. призовой фонд 1.000.000 рублей для самых активных учителей;
4. официальные наградные документы для учителей бесплатно(от организатора - ООО "Инфоурок" - имеющего образовательную лицензию и свидетельство СМИ) - при участии от 10 учеников
5. бесплатный доступ ко всем видеоурокам проекта "Инфоурок";
6. легко подать заявку, не нужно отправлять ответы в бумажном виде;
7. родителям всех учеников - благодарственные письма от «Инфоурок».
и многое другое...

Подайте заявку сейчас - https://infourok.ru/konkurs


Выберите специальность, которую Вы хотите получить:

Обучение проходит дистанционно на сайте проекта "Инфоурок".
По итогам обучения слушателям выдаются печатные дипломы установленного образца.

ПЕРЕЙТИ В КАТАЛОГ КУРСОВ


Идёт приём заявок на международный конкурс по математике "Весенний марафон" для учеников 1-11 классов и дошкольников

Уникальность конкурса в преимуществах для учителей и учеников:

1. Задания подходят для учеников с любым уровнем знаний;
2. Бесплатные наградные документы для учителей;
3. Невероятно низкий орг.взнос - всего 38 рублей;
4. Публикация рейтинга классов по итогам конкурса;
и многое другое...

Подайте заявку сейчас - https://urokimatematiki.ru

Похожие материалы

Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.
Специальное предложение
Вверх