Инфоурок Информатика КонспектыРазработка урока по информатике "Цикл с условием" 8 класс

Разработка урока по информатике "Цикл с условием" 8 класс

Скачать материал

Выберите документ из архива для просмотра:

Выбранный для просмотра документ 8 класс.docx

 

 

Тема урока:

«Исполнитель Робот. Цикл с условием»

Класс: 8

Место проведения: МБОУ «Лицей №21»

Учитель: Лян Ксения Романовна


План-конспект урока

Тема:

 

Тип урока – комбинированный

 

Продолжительность: 45 мин.

 

Место проведения: компьютерный класс.

 

Оборудование: компьютер, мультимедийный проектор.

 

Цель урока:

-       Образовательная: познакомить учащихся с циклом «пока», научиться пользоваться циклом «пока», исходя из условий поставленной задачи,  составлять задачи в системе исполнителя Кумир;

-        Развивающая: продолжить развитие исследовательской и познавательной деятельности, интереса к предмету, алгоритмического и  логического мышления, умения обобщать, сопоставлять и применять полученные знания на практике, развитие навыков практической работы на ПК; лаконично, полно и содержательно отвечать и делать обобщающие выводы;

-       Воспитательная: воспитание у учащихся информационной культуры на примере освоения нового материала, необходимости связывать изучение нового материала с уже известными фактами, умения работать индивидуально и в парах, прислушиваться к мнению других.

 

Этапы урока:

                                                    I.              Организационный момент.

                                                  II.             Повторение ранее изученного материала.

                                               III.            Проверка домашнего задания.

                                              IV.            Изучение нового материала.

                                                 V.            Физминутка.

                                              VI.            Закрепление нового материала (практическая часть).

                                           VII.            Проверка усвоения нового материала.

                                        VIII.            Домашнее задание.

                                              IX.            Подведение итогов.

 


Ход урока

1.             Организационный момент

 

10.45-10.47

 

Здравствуйте ребята, садитесь!

Сегодня на уроке у нас будут присутствовать гости Ольга Анатольевна и Светлана     поздоровайтесь с гостями. Садитесь!

 

 

2.             Повторение ранее изученного материала

 

10.47-10.50

 

(один ученик выходит к доске, пока остальные отвечают на вопросы, он  пишет д/з).

 

На доске стихотворение про циклический алгоритм:

 

Повторяюсь, повторяюсь,

Раз скажу и два скажу.

Раз дощечка, два дощечка

Тут по кругу я хожу,

Мне бы выйти из загона,

Но условий не видать.

Мне зацикливаться не охота,

Мне бы выйти к вам опять.

Но повтор похожих действий

В каждом цикле не похожий.

Он в Пока в начале действий

А у До в конце стоит.

Цикл с параметром окончит

Счетчик, что внутри стоит.

 

О каком типе алгоритма идет речь в данном стихотворении?

А какие циклические конструкции вы увидели в данном стихотворении?

В какой программе и с каким исполнителем мы работаем?

Какие команды существуют у этого исполнителя?

Как проверить наличие стены?

Назовите общий вид арифметического цикла.

Какие условия вы знаете?

Слайд 1

3.             Проверка домашнего задания.

 

10.50-10.52

Дома вам необходимо было составить алгоритм для Робота в след. обстановке (слайд 2).

 

Какой цикл мы использовали при описании данного алгоритма? Т.е.мы заранее знали, что Роботу нужно закрасить 7 клеток.

а как Роботу узнать, где и когда ему следует остановиться или закрасить нужную клетку, если изначально не известны расстояния и длины стен?

 

Ответ на этот вопрос мы сегодня узнаем на нашем уроке.

 

Слайд 2

4.             Изучение нового материала.

 

Постановка цели урока

10.52-11.10

 

Запишем тему урока: «Исполнитель Робот. Цикл с условием».

 

Целью нашего урока будет научиться пользоваться циклом, исходя из условий поставленной задачи,  составлять задачи в системе исполнителя Кумир.

 

Давайте рассмотрим пример обстановок на экране. Если длина стены неизвестна, как Робот узнает, сколько клеток ему нужно закрасить? Обратите внимание на такую особенность: над закрашенными клетками стоит стена, как только заканчивается стена, заканчиваются и закрашенные клетки.

На второй обстановке робот опять же закрашивает клетки возле стены.

т.о.для того, чтобы остановиться, робот должен проверить наличие стены, причем стена может располагаться как над ним, так и справа, слева и снизу. Но мы можем прописывать условие только в том случае, если известно расстояние или длина стен, т.к. оно проверяется однократно.

Поэтому мы условие должны поместить в цикл.

 

Цикл с условием имеет следующий общий вид:

нц пока условие

             серия команд

кц

 

Давайте попробуем этот цикл применить к первой обстановке, с тем условием, что нам не известна длина стены и расстояние.

 

нц пока не сверху свободно

закрасить

вправо

кц

 

следующее задание: проехать на автобусе от лицея до Драмтеатра.

Перед вами изображена схематичная карта местности.

 

Теперь мы эту карту местности наложим сверху на обстановку для Робота.

Ваша задача написать алгоритм переезда робота из пункта А в пункт В.

 

Ответ на экране:

нц пока не сверху свободно

            влево

кц

нц пока не слева свободно

            вверх

кц

нц пока не снизу свободно

            влево

кц

 

Слайд 3

 

 

 

 

 

 

Слайд 4

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Слайд 5

 

 

 

 

 

Слайд 6

 

 

 

 

 

 

 

Слайд 7

 

 

 

Слайд 8

 

 

 

 

Слайд 8

5.     Физкультминутка

11.10-11.12

 

Давайте немного отдохнем

 

6.    Закрепление нового материала (практическая часть).

 

11.12-11.20

Теперь поменяемся тетрадями и придумаем стартовую обстановку друг для друга в виде небольшого лабиринта.

 

Выполняют работу на компьютере.

 

7.      Проверка усвоения нового материала.

 

11.20-11.25

Перед вами на столах в конвертах лежит стартовая обстановка для Робота и отдельно команды. Вам необходимо составить в правильном порядке алгоритм закрашивания Роботом клеток и выложить его из данных команд на парте.

 

 

8.      Домашнее задание

 

11.25-11.27

Придумать стартовую обстановку для робота, проходящего расстояние от вашего дома до остановки. И написать алгоритм его прохождения.

 

Слайд 9

9.                Подведение итогов

 

11.27-11.30

Наш урок подходит к концу. Давайте с вами повторим, что мы сегодня узнали нового?

 

Сдайте, пожалуйста, дневники для выставления оценок.

 

Вопросы домашнему заданию есть?

 

Урок окончен, до свидания.

 

Слайд 10

 

Просмотрено: 0%
Просмотрено: 0%
Скачать материал
Скачать материал "Разработка урока по информатике "Цикл с условием" 8 класс"

Методические разработки к Вашему уроку:

Получите новую специальность за 3 месяца

Специалист по охране труда

Получите профессию

Фитнес-тренер

за 6 месяцев

Пройти курс

Рабочие листы
к вашим урокам

Скачать

Выбранный для просмотра документ Руки на пояс поставьте вначале.docx

Руки на пояс поставьте вначале
Влево и вправо качайте плечами.
Выполнить по 5 наклонов в каждую сторону.

Упражнение 2:
Вы дотянитесь мизинцем до пятки,
Если достали – все в полном порядке.
Выполнить по три раза.

А напоследок должны вы мяукнуть,
Крякнуть, проквакать, залаять и хрюкнуть!

Просмотрено: 0%
Просмотрено: 0%
Скачать материал
Скачать материал "Разработка урока по информатике "Цикл с условием" 8 класс"

Получите профессию

Технолог-калькулятор общественного питания

за 6 месяцев

Пройти курс

Рабочие листы
к вашим урокам

Скачать

Выбранный для просмотра документ цикл с условием.pptx

Скачать материал "Разработка урока по информатике "Цикл с условием" 8 класс"

Получите профессию

Технолог-калькулятор общественного питания

за 6 месяцев

Пройти курс

Рабочие листы
к вашим урокам

Скачать

Описание презентации по отдельным слайдам:

  • Повторяюсь, повторяюсь,
Раз скажу и два скажу.
Раз дощечка, два дощечка
Тут п...

    1 слайд

    Повторяюсь, повторяюсь,
    Раз скажу и два скажу.
    Раз дощечка, два дощечка
    Тут по кругу я хожу,
    Мне бы выйти из загона,
    Но условий не видать.
    Мне зацикливаться не охота,
    Мне бы выйти к вам опять.
    Но повтор похожих действий
    В каждом цикле не похожий.
    Он в Пока в начале действий
    А у До в конце стоит.
    Цикл с параметром окончит
    Счетчик, что внутри стоит.

  • Домашнее задание

    2 слайд

    Домашнее задание

  • Исполнитель Робот. Цикл с условием.Тема урока:

    3 слайд

    Исполнитель Робот.
    Цикл с условием.
    Тема урока:

  • 4 слайд

  • Общий вид цикла с условиемнц пока условие
             серия команд
кц

    5 слайд

    Общий вид цикла с условием
    нц пока условие
    серия команд
    кц

  • нц пока не сверху свободно
закрасить 
вправо
кц

    6 слайд

    нц пока не сверху свободно
    закрасить
    вправо
    кц

  • Задача Как проехать на автобусе от лицея до Драмтеатра?

    7 слайд

    Задача
    Как проехать на автобусе от лицея до Драмтеатра?

  • нц пока не сверху свободно
	влево
кц
нц пока не слева свободно
	вверх
кц
нц п...

    8 слайд

    нц пока не сверху свободно
    влево
    кц
    нц пока не слева свободно
    вверх
    кц
    нц пока не снизу свободно
    влево
    кц

  • Домашнее задание	Придумать стартовую обстановку для Робота, проходящего расст...

    9 слайд

    Домашнее задание
    Придумать стартовую обстановку для Робота, проходящего расстояние от вашего дома до ближайшей остановки. И написать алгоритм его прохождения.

  • Что узнали?

    10 слайд

    Что узнали?

Получите профессию

Копирайтер

за 6 месяцев

Пройти курс

Рабочие листы
к вашим урокам

Скачать

Получите профессию

Бухгалтер

за 6 месяцев

Пройти курс

Рабочие листы
к вашим урокам

Скачать

Краткое описание документа:

Тип урока – комбинированный

Продолжительность: 45 мин.

Место проведения: компьютерный класс.

Оборудование: компьютер, мультимедийный проектор.

Цель урока:

  • Образовательная: познакомить учащихся с циклом «пока», научиться пользоваться циклом «пока», исходя из условий поставленной задачи, составлять задачи в системе исполнителя Кумир;
  • Развивающая: продолжить развитие исследовательской и познавательной деятельности, интереса к предмету, алгоритмического илогического мышления, умения обобщать, сопоставлять и применять полученные знания на практике, развитие навыков практической работы на ПК; лаконично, полно и содержательно отвечать и делать обобщающие выводы;
  • Воспитательная: воспитание у учащихся информационной культуры на примере освоения нового материала, необходимости связывать изучение нового материала с уже известными фактами, умения работать индивидуально и в парах, прислушиваться к мнению других.

Этапы урока:

  • Организационный момент.
  • Повторение ранее изученного материала.
  • Проверка домашнего задания.
  • Изучение нового материала.
  • Физминутка.
  • Закрепление нового материала (практическая часть).
  • Проверка усвоения нового материала.
  • Домашнее задание.
  • Подведение итогов.

Скачать материал

Найдите материал к любому уроку, указав свой предмет (категорию), класс, учебник и тему:

6 712 726 материалов в базе

Материал подходит для УМК

Скачать материал

Другие материалы

Вам будут интересны эти курсы:

Оставьте свой комментарий

Авторизуйтесь, чтобы задавать вопросы.

  • Скачать материал
    • 30.10.2020 2926
    • RAR 517.5 кбайт
    • 229 скачиваний
    • Рейтинг: 5 из 5
    • Оцените материал:
  • Настоящий материал опубликован пользователем Лян Ксения Романовна. Инфоурок является информационным посредником и предоставляет пользователям возможность размещать на сайте методические материалы. Всю ответственность за опубликованные материалы, содержащиеся в них сведения, а также за соблюдение авторских прав несут пользователи, загрузившие материал на сайт

    Если Вы считаете, что материал нарушает авторские права либо по каким-то другим причинам должен быть удален с сайта, Вы можете оставить жалобу на материал.

    Удалить материал
  • Автор материала

    Лян Ксения Романовна
    Лян Ксения Романовна
    • На сайте: 4 года и 3 месяца
    • Подписчики: 0
    • Всего просмотров: 4374
    • Всего материалов: 3

Ваша скидка на курсы

40%
Скидка для нового слушателя. Войдите на сайт, чтобы применить скидку к любому курсу
Курсы со скидкой

Мини-курс

Стимулирование интереса к обучению у детей дошкольного возраста

6 ч.

780 руб. 390 руб.
Подать заявку О курсе
  • Сейчас обучается 20 человек из 12 регионов
  • Этот курс уже прошли 13 человек

Мини-курс

Искусство понимания: техники успешной жизни, отношений и бизнеса

4 ч.

780 руб. 390 руб.
Подать заявку О курсе

Мини-курс

Регуляция состояний спортсмена

2 ч.

780 руб. 390 руб.
Подать заявку О курсе