1201685
столько раз учителя, ученики и родители
посетили сайт «Инфоурок»
за прошедшие 24 часа
Добавить материал и получить бесплатное
свидетельство о публикации
в СМИ №ФС77-60625 от 20.01.2015
ИнфоурокИнформатикаДругие методич. материалыСамостоятельная работа ОГЭ задание № 9, 27 вариантов

Самостоятельная работа ОГЭ задание № 9, 27 вариантов

библиотека
материалов

Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -1.

1. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 3 до 7

s := s + 6

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 3 TO 7

s = s + 6

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 3 to 7 do

s := s + 6;

writeln(s);

End.



2. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 4 до 8

s := s + 7

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 4 TO 8

s = s + 7

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 4 to 8 do

s := s + 7;

writeln(s);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -2.

1. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 4 до 7

s := s + 8

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 4 TO 7

s = s + 8

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 4 to 7 do

s := s + 8;

writeln(s);

End.



2. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 3 до 8

s := s + 9

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 3 TO 8

s = s + 9

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 3 to 8 do

s := s + 9;

writeln(s);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -3.

1. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 3 до 8

s := s + 7

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 3 TO 8

s = s + 7

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 3 to 8 do

s := s + 7;

writeln(s);

End.



2. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 3 до 8

s := s + 6

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 3 TO 8

s = s + 6

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 3 to 8 do

s := s + 6;

writeln(s);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -4.

1. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 5 до 9

s := s + 8

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 5 TO 9

s = s + 8

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 5 to 9 do

s := s + 8;

writeln(s);

End.



2. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 6 до 10

s := s + 10

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 6 TO 10

s = s + 10

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 6 to 10 do

s := s + 10;

writeln(s);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -5.

1. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 7 до 11

s := s + 11

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 7 TO 11

s = s + 11

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 7 to 11 do

s := s + 11;

writeln(s);

End.



2. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 8 до 12

s := s + 12

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 8 TO 12

s = s + 12

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 8 to 12 do

s := s + 12;

writeln(s);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -6.

1. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 9 до 13

s := s + 9

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 9 TO 13

s = s + 9

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 9 to 13 do

s := s + 9;

writeln(s);

End.



2. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 6 до 9

s := s + 12

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 6 TO 9

s = s + 12

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 6 to 9 do

s := s + 12;

writeln(s);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -7.

1. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 7 до 12

s := s + 11

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 7 TO 12

s = s + 11

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 7 to 12 do

s := s + 11;

writeln(s);

End.



2. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 6 до 12

s := s + 10

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 6 TO 12

s = s + 10

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 6 to 12 do

s := s + 10;

writeln(s);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -1.

1. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 12 до 15

s := s + 13

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 12 TO 15

s = s + 13

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 12 to 15 do

s := s + 13;

writeln(s);

End.



2. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 13 до 16

s := s + 14

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 13 TO 16

s = s + 14

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 13 to 16 do

s := s + 14;

writeln(s);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -9.

1. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 8

нц для k от 3 до 8

s := s + 8

кц

вывод s

кон

DIM k, s AS INTEGER

s = 8

FOR к = 3 TO 8

s = s + 8

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 8;

for k := 3 to 8 do

s := s + 8;

writeln(s);

End.



2. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 50

нц для k от 0 до 8

s := s - 4

кц

вывод s

кон

DIM k, s AS INTEGER

s = 50

FOR к = 0 TO 8

s = s - 4

NEXT k

PRINT s

END

Var s,k: integer;

Begin

s := 50;

for k := 0 to 8 do

s := s - 4;

writeln(s);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -10.

1. Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 50

нц для k от 1 до 9

s := s - 3

кц

вывод s

кон

s = 50

FOR к = 1 TO 9

s = s - 3

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s := 50;

for k := 1 to 9 do

s := s - 3;

write (s);

End.



2. Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 100

нц для k от 1 до 9

s := s - 5

кц

вывод s

кон

DIM k, s AS INTEGER

s = 100

FOR k = 1 TO 9

s = s - 5

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s := 100;

for k := 1 to 9 do

s := s - 5;

write (s);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -11.

1. Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 3

нц для k от 0 до 9

s := s + 3

кц

вывод s

кон

s = 3

FOR к = 0 TO 9

s = s + 3

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s := 3;

for k := 0 to 9 do

s := s + 3;

write (s);

End.



2. Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 1

нц для k от 0 до 9

s := s + 5

кц

вывод s

кон

s = 1

FOR к = 0 TO 9

s = s + 5

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s := 1;

for k := 0 to 9 do

s := s + 5;

write (s);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -12.

1. Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 2

нц для k от 1 до 3

s := s*s

кц

вывод s

кон

s = 2

FOR к = 1 TO 3

s = s*s

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s := 2;

for k := 1 to 3 do

s := s*s;

write (s);

End.



2. Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 1

нц для k от 3 до 0

шаг −1

s := s*3

кц

вывод s

кон

s = 1

FOR k = 3 TO 0

STEP −1

s = s*3

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s := 1;

for k := 3 downto 0 do

s := s*3;

write (s);

End.





Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -13.

1. Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 2

нц для k от 1 до 5

s := s*2

кц

вывод s

кон

s = 2

FOR k = 1 TO 5

s = s*2

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s := 2;

for k := 1 to 5 do

s := s*2;

write (s);

End.



2. Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 1

нц для k от 0 до 4

s := s*3

кц

вывод s

кон

s = 1

FOR k = 0 TO 4

s = s*3

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s := 1;

for k := 0 to 4 do

s := s*3;

write (s);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -14.

1. Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 1

нц для k от 1 до 7

s := s*2

кц

вывод s

кон

s = 1

FOR k = 1 TO 7

s = s*2

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s := 1;

for k := 1 to 7 do

s := s*2;

write (s);

End.



2. Запишите значение переменной y, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел y, i

y := 0

нц для i от 1 до 3

y := y + 4*i

кц

вывод y

кон

DIM i, y AS INTEGER

y = 0

FOR i = 1 TO 3

y = y + 4*i

NEXT i

PRINT y

Var y,i: integer;

Begin

y := 0;

For i := 1 to 3 do

y := y + 4*i;

Writeln(y);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -15.

1. Запишите значение переменной y, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел y, i

y := 5

нц для i от 1 до 3

y := y + 5*i

кц

вывод y

кон

DIM i, y AS INTEGER

y = 5

FOR i = 1 TO 3

y = y + 5*i

NEXT i

PRINT y

Var y,i: integer;

Begin

y := 5;

For i := 1 to 3 do

y := y + 5*i;

Writeln(y);

End.



2. Запишите значение переменной k, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел k, i

k := 4

нц для i от 1 до 3

k := i + 2*k

кц

вывод k

кон

DIM i, k AS INTEGER

k = 4

FOR i = 1 TO 3

k = i + 2*k

NEXT i

PRINT k

Var k, i: integer;

Begin

k := 4;

For i := 1 to 3 do

k := i + 2*k;

Writeln(k);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -16.

1. Запишите значение переменной k, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел k, i

k := 2

нц для i от 0 до 2

k := i + 3*k

кц

вывод k

кон

DIM i, k AS INTEGER

k = 2

FOR i = 0 TO 2

k = i + 3*k

NEXT i

PRINT k

Var k, i: integer;

Begin

k := 2;

For i := 0 to 2 do

k := i + 3*k;

Writeln(k);

End.



2. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, i

s := 3

нц для i от 2 до 5

s := s + 2*i

кц

вывод s

кон

DIM i, s AS INTEGER

s = 3

FOR i = 2 TO 5

s = s + 2*i

NEXT i

PRINT s

Var s, i: integer;

Begin

s := 3;

For i := 2 to 5 do

s := s + 2*i;

Writeln(s);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -17.

1. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, n

s := 5

нц для n от 2 до 4

s := s + (n-1)

кц

вывод s

кон

DNM n, s AS INTEGER

s = 5

FOR n = 2 TO 4

s = s + (n-1)

NEXT n

PRINT s

Var s, n: integer;

Begin

s := 5;

For n := 2 to 4 do

s := s + (n-1);

Writeln(s);

End.



2. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, n

s := 2

нц для n от 2 до 5

s := s*2 + n

кц

вывод s

кон

DNM n, s AS INTEGER

s = 2

FOR n = 2 TO 5

s = s*2 + n

NEXT n

PRINT s

Var s, n: integer;

Begin

s := 2;

For n := 2 to 5 do

s := s*2 + n;

Writeln(s);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -18.

1. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, n

s := 2

нц для n от 2 до 5

s := s + n*2

кц

вывод s

кон

DNM n, s AS INTEGER

s = 2

FOR n = 2 TO 5

s = s + n*2

NEXT n

PRNNT s

Var s, n: integer;

Begin

s := 2;

For n := 2 to 5 do

s := s + n*2;

Writeln(s);

End.



2. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 6 до 12

s := s + 10

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 6 TO 12

s = s + 10

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 6 to 12 do

s := s + 10;

writeln(s);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -19.

1. Запишите значение переменной d, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел d,n

d := 6

d := d-2

нц для п от 1 до 4

d : = d + n

кц

вывод d

кон

DIM n,d AS INTEGER

d = 6

d = d-2

FOR n = 1 TO 4

d = d + n

NEXT n

PRINT d

Var d,n: integer;

Begin

d := 6;

d := d-2;

For n := 1 to 4 do

d : = d + n ;

Writeln(d);

End .



2. Запишите значение переменной d, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел d,n

d := 5

d := d-3

нц для n от 1 до 4

d := d + n

кц

вывод d

кон

DIM n,d AS INTEGER

d = 5

d = d-3

FOR n = 1 TO 4

d = d + n

NEXT n

PRINT d

Var d,n: integer;

Begin

d := 5;

d := d-3;

For n := 1 to 4 do

d := d + n;

Writeln(d);

End.




Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -20.

1. Запишите значение переменной f, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел f,n

f := 4

f := f*3

нц для n от 1 до 4

f := f + n

кц

вывод f

кон

DIM n,f AS INTEGER

f = 4

f = f*3

FOR n = 1 TO 4

f = f + n

NEXT n

PRINT f

Var f,n: integer;

Begin

f := 4;

f := f*3;

For n := 1 to 4 do

f := f + n;

Writeln(f);

End.



2. Запишите значение переменной f, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел f,n

f := 22

f := f–20

нц для n от 1 до 5

f := f + n

кц

вывод f

кон

DIM n,f AS INTEGER

f = 22

f = f–20

FOR n = 1 TO 5

f = f + n

NEXT n

PRINT f

Var f,n: integer;

Begin

f := 22;

f := f–20;

For n := 1 to 5 do

f := f + n;

Writeln(f);

End.




Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -21.

1. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел n, s

s := 1

нц для n от 2 до 5

s := s * 3

кц

вывод s

кон

DIM n, s AS INTEGER

s = 1

FOR n = 2 TO 5

s = s * 3

NEXT n

PRINT s

END

var n, s: integer;

begin

s := 1;

for n := 2 to 5 do

s := s * 3;

write(s);

end.



2. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел n, s

s := 0

нц для n от 3 до 7

s := s + 2 * n

кц

вывод s

кон

DIM n, s AS INTEGER

s = 0

FOR n = 3 TO 7

s = s + 2 * n

NEXT n

PRINT s

END

var n, s: integer;

begin

s := 0;

for n := 3 to 7 do

s := s + 2 * n;

write(s);

end.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -22.

1. Запишите значение переменной d, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел d,n,i

n :=4

d := n*2

нц для i от 1 до 3

d := d + 2*i

кц

вывод d

кон

DIM d,n,i AS INTEGER

n = 4

d = n*2

FOR i = 1 TO 3

d = d + 2*i

NEXT i

PRINT d

Var d,n,i:integer;

Begin

n := 4;

d := n*2;

For i := 1 to 3 do

d := d + 2*i;

Writeln(d);

End.



2. Запишите значение переменной d, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел d,n,i

n :=3

d := n*3

нц для i от 1 до 3

d := d + i

кц

вывод d

кон

DIM d,n,i AS INTEGER

n = 3

d = n*3

FOR i = 1 TO 3

d = d + i

NEXT i

PRINT d

Var d,n,i: integer;

Begin

n := 3;

d := n*3;

For i := 1 to 3 do

d := d + i;

Writeln(d);

End.




Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -23.

1. Запишите значение переменной t, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел t,i

t := 1

нц для i от 1 до 4

t := t * i

кц

вывод t

кон

DIM i,t AS INTEGER

t = 1

FOR i = 1 TO 4

t = t * i

NEXT i

PRINT t

Var t,i: integer;

Begin

t := 1;

For i := 1 to 4 do

t := t * i;

Writeln(t);

End.



2. Запишите значение переменной t, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел t,i

t := 2

нц для i от 1 до 3

t := t * i

кц

вывод t

кон

DIM i,t AS INTEGER

t = 2

FOR i = 1 TO 3

t = t * i

NEXT i

PRINT t

Var t,i: integer;

Begin

t := 2;

For i := 1 to 3 do

t := t * i;

Writeln(t);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -24.

1. Запишите значение переменной u, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел u,i

u := 30

нц для i от 1 до 6

u := u – i

кц

вывод u

кон

DIM i,u AS INTEGER

u = 30

FOR i = 1 TO 6

u = u – i

NEXT i

PRINT u

Var u,i: integer;

Begin

u := 30;

For i := 1 to 6 do

u := u – i;

Writeln(u);

End.



2. Запишите значение переменной u, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел u,i

u := 26

нц для i от 1 до 5

u := u – i

кц

вывод u

кон

DIM i,u AS INTEGER

u = 26

FOR i = 1 TO 5

u = u – i

NEXT i

PRINT u

Var u,i: integer;

Begin

u := 26;

For i := 1 to 5 do

u := u – i;

Writeln(u);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -25.

1. Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s:=0

нц для k от 3 до 10

s:=s+13

кц

вывод s

кон

DIM s,k AS INTEGER

s = 0

FOR k = 3 TO 10

s= s+13

NEXT k

PRINT s

END

Var u,i: integer;

Var s, k: integer;

Begin

s:=0;

for k:=3 to 10 do

s:=s+13;

write(s);

End.



2. Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 8,

нц для k от 14 до 18

s := s+6

кц

вывод s

кон

DIM k, s AS INTEGER

s = 8

FOR k = 14 TO 18

s = s+6

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 8;

for k := 14 to 18 do

s := s+6;

writeln(s);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -26.

1. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 4 до 9

s := s + 12

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 4 TO 9

s = s + 12

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 4 to 9 do

s := s + 12;

writeln(s);

End.



2. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 2 до 12

s := s + 11

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 2 TO 12

s = s + 11

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 2 to 12 do

s := s + 11;

writeln(s);

End.






Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке.

Вариант -27.

1. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s,k

s:=100

нц для k от 0 до 10

s:=s-5

кц

вывод s

кон

DIM s AS INTEGER

DIM k AS INTEGER

s = 100

FOR k = 0 TO 10

s = s – 5

NEXT k

PRINT s

END

var s, k:integer;

begin

s:= 100;

for k:= 0 to 10 do

s:= s - 5;

writeln (s);

end.



2. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел s, k

s := 0

нц для k от 14 до 18

s := s+7

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 14 TO 18

s = s+7

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 14 to 18 do

s := s+7;

writeln(s);

End.






Ключ

Курс профессиональной переподготовки
Учитель информатики
Найдите материал к любому уроку,
указав свой предмет (категорию), класс, учебник и тему:
также Вы можете выбрать тип материала:
Общая информация
К учебнику: Информатика. 9 класс. Босова Л.Л., Босова А.Ю. М.: 2013. — 184 с.

Номер материала: ДБ-595721

ВНИМАНИЮ ВСЕХ УЧИТЕЛЕЙ: согласно Федеральному закону N273-ФЗ «Об образовании в Российской Федерации» педагогическая деятельность требует от педагога наличия системы специальных знаний в области обучения и воспитания детей с ОВЗ. Поэтому для всех педагогов является актуальным повышение квалификации по этому направлению!

Дистанционный курс «Обучающиеся с ОВЗ: Особенности организации учебной деятельности в соответствии с ФГОС» от проекта "Инфоурок" даёт Вам возможность привести свои знания в соответствие с требованиями закона и получить удостоверение о повышении квалификации установленного образца (72 часа).

Подать заявку на курс

Вам будут интересны эти курсы:

Курс повышения квалификации «Табличный процессор MS Excel в профессиональной деятельности учителя математики»
Курс повышения квалификации «Организация работы по формированию медиаграмотности и повышению уровня информационных компетенций всех участников образовательного процесса»
Курс повышения квалификации «Сетевые и дистанционные (электронные) формы обучения в условиях реализации ФГОС по ТОП-50»
Курс повышения квалификации «Использование компьютерных технологий в процессе обучения в условиях реализации ФГОС»
Курс повышения квалификации «Специфика преподавания информатики в начальных классах с учетом ФГОС НОО»
Курс повышения квалификации «Применение MS Word, Excel в финансовых расчетах»
Курс повышения квалификации «Введение в программирование на языке С (СИ)»
Курс профессиональной переподготовки «Математика и информатика: теория и методика преподавания в образовательной организации»
Курс повышения квалификации «Современные тенденции цифровизации образования»
Курс повышения квалификации «Специфика преподавания дисциплины «Информационные технологии» в условиях реализации ФГОС СПО по ТОП-50»
Курс повышения квалификации «Современные языки программирования интегрированной оболочки Microsoft Visual Studio C# NET., C++. NET, VB.NET. с использованием структурного и объектно-ориентированного методов разработки корпоративных систем»
Курс повышения квалификации «Применение интерактивных образовательных платформ на примере платформы Moodle»
Оставьте свой комментарий
Авторизуйтесь, чтобы задавать вопросы.
Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.