877029
столько раз учителя, ученики и родители
посетили сайт «Инфоурок»
за прошедшие 24 часа
+Добавить материал
и получить бесплатное
свидетельство о публикации
в СМИ №ФС77-60625 от 20.01.2015
Дистанционные курсы профессиональной переподготовки и повышения квалификации для педагогов

Дистанционные курсы для педагогов - курсы профессиональной переподготовки от 5.520 руб.;
- курсы повышения квалификации от 1.200 руб.
Престижные документы для аттестации

ВЫБРАТЬ КУРС СО СКИДКОЙ ДО 70%

ВНИМАНИЕ: Скидка действует ТОЛЬКО сейчас!

(Лицензия на осуществление образовательной деятельности № 5201 выдана ООО "Инфоурок")

ИнфоурокИнформатикаТестыТест по программированию по теме "Двумерные массивы"

Тест по программированию по теме "Двумерные массивы"

библиотека
материалов
Скачать материал целиком можно бесплатно по ссылке внизу страницы.

Тестирование по теме «Двумерные массивы»

Вариант 1.

1. Дан фрагмент программы, обрабатывающей двухмерный массив А
размера nxn.

Бейсик

Паскаль

Алгоритмический

k=1

FOR i=1 TO n
b=A(i,i)
A(i,i)=A(i,n-k)
A(i,n-k)=b
NEXT i

k:=1;

for i:=1 to n do
begin
b:=A[i,i];
A[i,i]:=A[i,n-k];
A[i,n-k]:=b
end

k:=1

нц для i от 1 до n
b:=A[i,i]
A[i,i]:=A[i,n-k]
A[i,n-k]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) два столбца в таблице;

2) элементы диагонали и n-k -го столбца таблицы;

3) элементы диагонали и n-ой строки таблицы;

4) две строки в таблице.


2. Дан фрагмент программы, обрабатывающей двухмерный массив А
размера nxn.

Бейсик

Паскаль

Алгоритмический

k=2

FOR i=1 TO n
b=A(k,i)
A(k,i)=A(i,k)
A(i,k)=b
NEXT i

k:=2;

for i:=1 to n do
begin
b:=A[k,i];
A[k,i]:=A[i,k];
A[i,k]:=b
end

k:=2

нц для i от 1 до n
b:=A[k,i]
A[k,i]:=A[i,k]
A[i,k]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) элементы k-го столбца и k-ой строки таблицы;

2) элементы k-ой строки и k-го столбца таблицы;

3) элементы диагонали и k-ой строки таблицы;

4) элементы диагонали и k-го столбца таблицы.


3. Дан фрагмент программы, обрабатывающей двухмерный массив А размера nxn.

Бейсик

Паскаль

Алгоритмический

k=2

FOR i=1 TO n
b=A(i,k)
A(i,k)=A(i,k+1)
A(i,k+1)=b
NEXT i

k:=2;

for i:=1 to n do
begin
b:=A[i,k];
A[i,k]:=A[i,k+1];
A[i,k+1]:=b
end

k:=2

нц для i от 1 до n
b:=A[i,k]
A[i,k]:=A[i,k+1]
A[i,k+1]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) элементы k-ой строки и k+1-го столбца таблицы;

2) элементы k-го столбца и k+1-го столбца таблицы;

3) элементы диагонали и k+1-ой строки таблицы;

4) элементы диагонали и k-го столбца таблицы.


4. Дан фрагмент программы, обрабатывающей двухмерный массив А размера nxn.

Бейсик

Паскаль

Алгоритмический

k=1

FOR i=1 TO n
b=A(i,n)
A(i,n)=A(i,k)
A(i,k)=b
NEXT i

k:=1;

for i:=1 to n do
begin
b:=A[i,n];
A[i,n]:=A[i,k];
A[i,k]:=b
end

k:=1

нц для i от 1 до n
b:=A[i,n]
A[i,n]:=A[i,k]
A[i,k]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) элементы k-ой строки и k+1-го столбца таблицы;

2) элементы n-го столбца и k-го столбца таблицы;

3) элементы диагонали и k+1-ой строки таблицы;

4) элементы k-ой строки и k+1-ой строки таблицы.



5. Дан фрагмент программы, обрабатывающей двухмерный массив А
размера nxn.

Бейсик

Паскаль

Алгоритмический

k=1

FOR i=1 TO n
b=A(k,i)
A(k,i)=A(i,i)
A(i,i)=b
NEXT i

k:=1;

for i:=1 to n do
begin
b:=A[k,i];
A[k,i]:=A[i,i];
A[i,i]:=b
end

k:=1

нц для i от 1 до n
b:=A[k,i]
A[k,i]:=A[i,i]
A[i,i]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) два столбца в таблице;

2) элементы диагонали и k -го столбца таблицы;

3) элементы k -ой строки и диагонали таблицы;

4) две строки в таблице.

Тестирование по теме «Двумерные массивы»

Вариант 2.

1. Дан фрагмент программы, обрабатывающей двухмерный массив А размера nxn.

Бейсик

Паскаль

Алгоритмический

k=1

FOR i=1 TO n
b=A(i,i)
A(i,i)=A(i,k)
A(i,k)=b
NEXT i

k:=1;

for i:=1 to n do
begin
b:=A[i,i];
A[i,i]:=A[i,k];
A[i,k]:=b
end

k:=1

нц для i от 1 до n
b:=A[i,i]
A[i,i]:=A[i,k]
A[i,k]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) два столбца в таблице;

2) две строки в таблице;

3) элементы диагонали и k-ой строки таблицы;

4) элементы диагонали и k-го столбца таблицы


2. Дан фрагмент программы, обрабатывающей двухмерный массив А размера nxn.

Бейсик

Паскаль

Алгоритмический

k=2

FOR i=1 TO n
b=A(i,k)
A(i,k)=A(k,i)
A(k,i)=b
NEXT i

k:=2;

for i:=1 to n do
begin
b:=A[i,k];
A[i,k]:=A[k,i];
A[k,i]:=b
end

k:=2

нц для i от 1 до n
b:=A[i,k]
A[i,k]:=A[k,i]
A[k,i]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) элементы k-го столбца и k-ой строки таблицы;

2) элементы k-ой строки и k-го столбца таблицы;

3) элементы диагонали и k-ой строки таблицы;

4) элементы диагонали и k-го столбца таблицы.


3. Дан фрагмент программы, обрабатывающей двухмерный массив А размера nxn.

Бейсик

Паскаль

Алгоритмический

k=1

FOR i=1 TO n
b=A(k,i)
A(k,i)=A(k+1,i)
A(k+1,i)=b
NEXT i

k:=1;

for i:=1 to n do
begin
b:=A[k,i];
A[k,i]:=A[k+1,i];
A[k+1,i]:=b
end

k:=1

нц для i от 1 до n
b:=A[k,i]
A[k,i]:=A[k+1,i]
A[k+1,i]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) элементы k-ой строки и k+1-го столбца таблицы;

2) элементы k-го столбца и k+1-го столбца таблицы;

3) элементы диагонали и k+1-ой строки таблицы;

4) элементы k-ой строки и k+1-ой строки таблицы


4. Дан фрагмент программы, обрабатывающей двухмерный массив А размера nxn.

Бейсик

Паскаль

Алгоритмический

k=1

FOR i=1 TO n
b=A(n,i)
A(n,i)=A(k,i)
A(k,i)=b
NEXT i

k:=1;

for i:=1 to n do
begin
b:=A[n,i];
A[n,i]:=A[k,i];
A[k,i]:=b
end

k:=1

нц для i от 1 до n
b:=A[n,i]
A[n,i]:=A[k,i]
A[k,i]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) элементы k-ой строки и k+1-го столбца таблицы;

2) элементы n-го столбца и k-го столбца таблицы;

3) элементы n-ой строки и k-ой строки таблицы;

4) элементы диагонали и k+1-ой строки таблицы.


5. Дан фрагмент программы, обрабатывающей двухмерный массив А
размера nxn.

Бейсик

Паскаль

Алгоритмический

k=1

FOR i=1 TO n
b=A(k,i)
A(k,i)=A(n,i)
A(n,i)=b
NEXT i

k:=1;

for i:=1 to n do
begin
b:=A[k,i];
A[k,i]:=A[n,i];
A[n,i]:=b
end

k:=1

нц для i от 1 до n
b:=A[k,i]
A[k,i]:=A[n,i]
A[n,i]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) элементы k-ой строки и n-ой строки таблицы;

2) элементы k-го столбца и n-го столбца таблицы;

3) элементы n-ой строки и k+1-ой строки таблицы;

4) элементы диагонали и k+1-ой строки таблицы.


Общая информация

Номер материала: ДВ-563679

Вам будут интересны эти курсы:

Курс повышения квалификации «Современные информационные технологии и их использование в работе преподавателей. Системы автоматизированного проектирования одежды и организация технологического процесса»
Курс повышения квалификации «Основы создания интерактивного урока: от презентации до видеоурока»
Курс повышения квалификации «Внедрение системы компьютерной математики в процесс обучения математике в старших классах в рамках реализации ФГОС»
Курс повышения квалификации «Организация работы по формированию медиаграмотности и повышению уровня информационных компетенций всех участников образовательного процесса»
Курс повышения квалификации «Облачные технологии в образовании»
Курс «WEB-ВЕРСТКА (HTML, CSS)»
Курс повышения квалификации «Сетевые и дистанционные (электронные) формы обучения в условиях реализации ФГОС по ТОП-50»
Курс повышения квалификации «Развитие информационно-коммуникационных компетенций учителя в процессе внедрения ФГОС: работа в Московской электронной школе»
Курс профессиональной переподготовки «Информационные технологии в профессиональной деятельности: теория и методика преподавания в образовательной организации»
Курс повышения квалификации «Специфика преподавания информатики в начальных классах с учетом ФГОС НОО»
Курс повышения квалификации «Введение в программирование на языке С (СИ)»
Курс профессиональной переподготовки «Управление в сфере информационных технологий в образовательной организации»
Курс повышения квалификации «Современные тенденции цифровизации образования»
Курс повышения квалификации «Специфика преподавания дисциплины «Информационные технологии» в условиях реализации ФГОС СПО по ТОП-50»
Курс повышения квалификации «Современные языки программирования интегрированной оболочки Microsoft Visual Studio C# NET., C++. NET, VB.NET. с использованием структурного и объектно-ориентированного методов разработки корпоративных систем»

Благодарность за вклад в развитие крупнейшей онлайн-библиотеки методических разработок для учителей

Опубликуйте минимум 3 материала, чтобы БЕСПЛАТНО получить и скачать данную благодарность

Сертификат о создании сайта

Добавьте минимум пять материалов, чтобы получить сертификат о создании сайта

Грамота за использование ИКТ в работе педагога

Опубликуйте минимум 10 материалов, чтобы БЕСПЛАТНО получить и скачать данную грамоту

Свидетельство о представлении обобщённого педагогического опыта на Всероссийском уровне

Опубликуйте минимум 15 материалов, чтобы БЕСПЛАТНО получить и скачать данное cвидетельство

Грамота за высокий профессионализм, проявленный в процессе создания и развития собственного учительского сайта в рамках проекта "Инфоурок"

Опубликуйте минимум 20 материалов, чтобы БЕСПЛАТНО получить и скачать данную грамоту

Грамота за активное участие в работе над повышением качества образования совместно с проектом "Инфоурок"

Опубликуйте минимум 25 материалов, чтобы БЕСПЛАТНО получить и скачать данную грамоту

Почётная грамота за научно-просветительскую и образовательную деятельность в рамках проекта "Инфоурок"

Опубликуйте минимум 40 материалов, чтобы БЕСПЛАТНО получить и скачать данную почётную грамоту

Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.