Добавить материал и получить бесплатное свидетельство о публикации в СМИ
Эл. №ФС77-60625 от 20.01.2015
Инфоурок / Информатика / Тесты / Тест по программированию по теме "Двумерные массивы"

Тест по программированию по теме "Двумерные массивы"

  • Информатика

Поделитесь материалом с коллегами:

Тестирование по теме «Двумерные массивы»

Вариант 1.

1. Дан фрагмент программы, обрабатывающей двухмерный массив А
размера nxn.

Бейсик

Паскаль

Алгоритмический

k=1

FOR i=1 TO n
b=A(i,i)
A(i,i)=A(i,n-k)
A(i,n-k)=b
NEXT i

k:=1;

for i:=1 to n do
begin
b:=A[i,i];
A[i,i]:=A[i,n-k];
A[i,n-k]:=b
end

k:=1

нц для i от 1 до n
b:=A[i,i]
A[i,i]:=A[i,n-k]
A[i,n-k]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) два столбца в таблице;

2) элементы диагонали и n-k -го столбца таблицы;

3) элементы диагонали и n-ой строки таблицы;

4) две строки в таблице.


2. Дан фрагмент программы, обрабатывающей двухмерный массив А
размера nxn.

Бейсик

Паскаль

Алгоритмический

k=2

FOR i=1 TO n
b=A(k,i)
A(k,i)=A(i,k)
A(i,k)=b
NEXT i

k:=2;

for i:=1 to n do
begin
b:=A[k,i];
A[k,i]:=A[i,k];
A[i,k]:=b
end

k:=2

нц для i от 1 до n
b:=A[k,i]
A[k,i]:=A[i,k]
A[i,k]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) элементы k-го столбца и k-ой строки таблицы;

2) элементы k-ой строки и k-го столбца таблицы;

3) элементы диагонали и k-ой строки таблицы;

4) элементы диагонали и k-го столбца таблицы.


3. Дан фрагмент программы, обрабатывающей двухмерный массив А размера nxn.

Бейсик

Паскаль

Алгоритмический

k=2

FOR i=1 TO n
b=A(i,k)
A(i,k)=A(i,k+1)
A(i,k+1)=b
NEXT i

k:=2;

for i:=1 to n do
begin
b:=A[i,k];
A[i,k]:=A[i,k+1];
A[i,k+1]:=b
end

k:=2

нц для i от 1 до n
b:=A[i,k]
A[i,k]:=A[i,k+1]
A[i,k+1]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) элементы k-ой строки и k+1-го столбца таблицы;

2) элементы k-го столбца и k+1-го столбца таблицы;

3) элементы диагонали и k+1-ой строки таблицы;

4) элементы диагонали и k-го столбца таблицы.


4. Дан фрагмент программы, обрабатывающей двухмерный массив А размера nxn.

Бейсик

Паскаль

Алгоритмический

k=1

FOR i=1 TO n
b=A(i,n)
A(i,n)=A(i,k)
A(i,k)=b
NEXT i

k:=1;

for i:=1 to n do
begin
b:=A[i,n];
A[i,n]:=A[i,k];
A[i,k]:=b
end

k:=1

нц для i от 1 до n
b:=A[i,n]
A[i,n]:=A[i,k]
A[i,k]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) элементы k-ой строки и k+1-го столбца таблицы;

2) элементы n-го столбца и k-го столбца таблицы;

3) элементы диагонали и k+1-ой строки таблицы;

4) элементы k-ой строки и k+1-ой строки таблицы.



5. Дан фрагмент программы, обрабатывающей двухмерный массив А
размера nxn.

Бейсик

Паскаль

Алгоритмический

k=1

FOR i=1 TO n
b=A(k,i)
A(k,i)=A(i,i)
A(i,i)=b
NEXT i

k:=1;

for i:=1 to n do
begin
b:=A[k,i];
A[k,i]:=A[i,i];
A[i,i]:=b
end

k:=1

нц для i от 1 до n
b:=A[k,i]
A[k,i]:=A[i,i]
A[i,i]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) два столбца в таблице;

2) элементы диагонали и k -го столбца таблицы;

3) элементы k -ой строки и диагонали таблицы;

4) две строки в таблице.

Тестирование по теме «Двумерные массивы»

Вариант 2.

1. Дан фрагмент программы, обрабатывающей двухмерный массив А размера nxn.

Бейсик

Паскаль

Алгоритмический

k=1

FOR i=1 TO n
b=A(i,i)
A(i,i)=A(i,k)
A(i,k)=b
NEXT i

k:=1;

for i:=1 to n do
begin
b:=A[i,i];
A[i,i]:=A[i,k];
A[i,k]:=b
end

k:=1

нц для i от 1 до n
b:=A[i,i]
A[i,i]:=A[i,k]
A[i,k]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) два столбца в таблице;

2) две строки в таблице;

3) элементы диагонали и k-ой строки таблицы;

4) элементы диагонали и k-го столбца таблицы


2. Дан фрагмент программы, обрабатывающей двухмерный массив А размера nxn.

Бейсик

Паскаль

Алгоритмический

k=2

FOR i=1 TO n
b=A(i,k)
A(i,k)=A(k,i)
A(k,i)=b
NEXT i

k:=2;

for i:=1 to n do
begin
b:=A[i,k];
A[i,k]:=A[k,i];
A[k,i]:=b
end

k:=2

нц для i от 1 до n
b:=A[i,k]
A[i,k]:=A[k,i]
A[k,i]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) элементы k-го столбца и k-ой строки таблицы;

2) элементы k-ой строки и k-го столбца таблицы;

3) элементы диагонали и k-ой строки таблицы;

4) элементы диагонали и k-го столбца таблицы.


3. Дан фрагмент программы, обрабатывающей двухмерный массив А размера nxn.

Бейсик

Паскаль

Алгоритмический

k=1

FOR i=1 TO n
b=A(k,i)
A(k,i)=A(k+1,i)
A(k+1,i)=b
NEXT i

k:=1;

for i:=1 to n do
begin
b:=A[k,i];
A[k,i]:=A[k+1,i];
A[k+1,i]:=b
end

k:=1

нц для i от 1 до n
b:=A[k,i]
A[k,i]:=A[k+1,i]
A[k+1,i]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) элементы k-ой строки и k+1-го столбца таблицы;

2) элементы k-го столбца и k+1-го столбца таблицы;

3) элементы диагонали и k+1-ой строки таблицы;

4) элементы k-ой строки и k+1-ой строки таблицы


4. Дан фрагмент программы, обрабатывающей двухмерный массив А размера nxn.

Бейсик

Паскаль

Алгоритмический

k=1

FOR i=1 TO n
b=A(n,i)
A(n,i)=A(k,i)
A(k,i)=b
NEXT i

k:=1;

for i:=1 to n do
begin
b:=A[n,i];
A[n,i]:=A[k,i];
A[k,i]:=b
end

k:=1

нц для i от 1 до n
b:=A[n,i]
A[n,i]:=A[k,i]
A[k,i]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) элементы k-ой строки и k+1-го столбца таблицы;

2) элементы n-го столбца и k-го столбца таблицы;

3) элементы n-ой строки и k-ой строки таблицы;

4) элементы диагонали и k+1-ой строки таблицы.


5. Дан фрагмент программы, обрабатывающей двухмерный массив А
размера nxn.

Бейсик

Паскаль

Алгоритмический

k=1

FOR i=1 TO n
b=A(k,i)
A(k,i)=A(n,i)
A(n,i)=b
NEXT i

k:=1;

for i:=1 to n do
begin
b:=A[k,i];
A[k,i]:=A[n,i];
A[n,i]:=b
end

k:=1

нц для i от 1 до n
b:=A[k,i]
A[k,i]:=A[n,i]
A[n,i]:=b
кц

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) элементы k-ой строки и n-ой строки таблицы;

2) элементы k-го столбца и n-го столбца таблицы;

3) элементы n-ой строки и k+1-ой строки таблицы;

4) элементы диагонали и k+1-ой строки таблицы.


Автор
Дата добавления 28.03.2016
Раздел Информатика
Подраздел Тесты
Просмотров203
Номер материала ДВ-563679
Получить свидетельство о публикации
Похожие материалы

Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.
Специальное предложение
Вверх