Добавить материал и получить бесплатное свидетельство о публикации в СМИ
Эл. №ФС77-60625 от 20.01.2015
Инфоурок / Информатика / Конспекты / Урок на тему "Цикл с постусловием для исполнителя Робот"

Урок на тему "Цикл с постусловием для исполнителя Робот"



57 вебинаров для учителей на разные темы
ПЕРЕЙТИ к бесплатному просмотру
(заказ свидетельства о просмотре - только до 11 декабря)


  • Информатика

Название документа Технологическая карта урока_Цикл при_8 класс.doc

Поделитесь материалом с коллегами:

Технологическая карта урока информатики (ФГОС) в 8 классе по теме «Основные алгоритмические конструкции. Цикл с постусловием (при)»

(Информатика: Учебник для 8 класса по ФГОС. Л.Л. Босова)


Работу выполнила:

учитель информатики

МБОУ «Лицей» г. Арзамас

Мурзина О.И.

Учебные цели урока



Развивающие цели





Воспитательные цели



Здоровьесберегающая цель




Основные образовательные принципы урока


Методы мотивации


Тип урока


Оформление и оборудование


Аппаратное и программное обеспечение

Познакомить учащихся с конструкциями различных видов циклов на основе работы с исполнителем Робот из ПО «Кумир»


Создать условия для развития умений работать коллективно, в парах, индивидуально;

создать условия для развития мышления при нахождении условий циклов;

развивать понимание алгоритмических конструкций на практическом материале при работе с исполнителем Робот.


Воспитывать коммуникабельность при коллективной работе и в парах; самостоятельность, уверенность, эстетичность при выполнении практической работы на ПК.


Эффективно использовать здоровьесберегающие режимные моменты (оздоровительные паузы); использовать коррекционные упражнения (для укрепления зрения, внимания); следить за выполнением санитарно-гигиенических норм (освещённость, воздушный режим, осанка детей).


Доступность, практичность, природосообразность, научность.



Эмоциональные, познавательные, волевые и социальные


Получение новых знаний


Проекционная картинка с обстановкой на поле Робота, офтальмотренажеры.


Компьютеры с операционной системой Windows, ПО «Кумир», мультимедийный проектор.


Технологическая карта урока


Этап урока

Задачи этапа

Методы

обучения

Форма

организации

учащихся

Деятельность учителя

Деятельность ученика

Время

1. Организационный момент.


Включение в деловой ритм. Подготовка класса к работе.

Объяснительно-иллюстративный (разъяснение)

фронтальная

Приветствие. Проверка готовности к уроку. Демонстрируется слайд 1.

Слушают

1 мин.


2. Проверка выполнения д/з

Выявить уровень знаний по д/з. Определение типичных ошибок.

Активизировать знания учащихся, необходимых для изучения нового материала.


Контроль усвоения.

Коллективная

Демонстрирует слайд 2 с обстановкой на поле Робота.


Вопросы:

1. Как решали эту задачу?



2. Посмотрите, как решил ее один ученик не из нашей школы (слайд 3, 4). Есть ли замечания?



3. А как нужно сделать эти переходы?

Смотрят и отвечают на вопросы




1. Несколько подряд идущих циклов «пока».


2. Да, ошибка при переходе от стены к стене. Эти расстояния нам тоже неизвестны по условию задачи.


3.

нц пока снизу свободно

вправо

кц

и

нц пока справа свободно

вверх

кц

5 мин.

3. Подготовка к активной учебно-познавательной деятельности. Ввод нового материала.



Подготовка для ввода нового материала. Формировать познавательные мотивы.

Новая ситуация.


Коллективная

Учитель демонстрирует слайд 5 с картинкой «Вахтер на входе» и связывает цикл «пока» с этим образом:

Цикл работает, пока выполняется условие. Дети заходит в школу, пока есть пропуск. Поток прерывается, как только подойдет ребенок без пропуска. Как только условие цикла нарушается, цикл прекращает свою работу.

Проверка условия осуществляется в начале цикла. Такой цикл называется цикл с предусловием. (слайд 6).


Далее слайд 7.


Проблемные ситуация:

«Нарушитель обнаружен на 3 этаже!»

1. Получается, что команды из тела цикла сработали хотя бы один раз! Можете привести пример такой ситуации в жизни?


2. Когда такая ситуация нужна? (слайд 8)





3. Как вы думаете, можно ли реализовать такую конструкцию для Робота?


Посмотрите на доску (слайд 9). Это начало решения домашней задачи с циклами, где условия проверяются в конце (слайд 10).

Записываем в тетрадь вид нового цикла (слайд 11).


4. Как вы думаете, в этом цикле новые условия (слайд 12)?


5. А каким должно быть условие, чтобы цикл перестал работать?


6. Условие цикла «при» как-то связано с условием цикла «пока»? Как? (слайд 13)


Вывод:

Т.е. в цикле «пока» мы используем условие продолжения действия, а в цикле «при» - условие окончания действия.

Чтобы сформулировать условие цикла «пока», мы задаем вопрос – до каких пор мы будем делать что-то?

А для формулировки условия цикла «при» мы должны спросить себя – когда мы должны закончить выполнение действия?

Рассматривают, слушают.





















Ответы:

  1. Легко. Ученик прошел по чужому пропуску, но потом его отдал. Когда вахтер поймал этого ученика, у него уже не было пропуска.




2. Например, в спорте. Дошел до финиша – молодец. Спортивное ориентирование: проходишь по трассе, отмечаешься на каждом контрольном пункте.


3. Наверное, можно. Идет сначала, а потом проверяет условие…






Записывают в тетрадь тему урока и вид нового цикла.


4. Они не новые, они такие же. Просто идут в конце.



5. Оно должно описывать ситуацию окончания работы цикла.


6. Да. Оно противоположно условиям циклов «пока».

15 мин.

4. Усвоение новых знаний

Организация учащихся по принятию познавательной задачи.

Устное сообщение учителя

В парах


Сегодня мы с вами узнали, как можно решить ту же задачу другим видом цикла.

Нам нужно разбиться на пары и построить ментальную карту по циклам с пред- и пост- условиям. (слайд 14)

Выполняют задание в тетради в парах.





5 мин.

5. Подготовка к проверке понимания изученного материала

Улучшить обменные процессы, способствующие повы­шению внимания и активности детей на последующих этапах урока

Динамическая пауза на опорно-двигательный аппарат

Коллективная

Демонстрирует упражнения

(пальчиковая гимнастика,

упражнения на шейный и плечевой пояс)

Выполняют упражнения

1 мин.

6. Закрепление знаний

Организовать деятельность по применению новых знаний.

Обучать работе с циклом «пока».


Практическая работа за ПК


Индивидуальная

Сегодня на уроке мы будем решать задачи из ОГЭ.

Дает инструктаж по работе, оценке за выполненную работу и выдает задачи с примерами обстановок и требованиями к ним, которые необходимо решить.


Координирует, направляет, корректирует.

Практическая работа за ПК с ПО «Кумир». Работают за ПК








Физкультминутка на укрепление зрения в середине работы на ПК

13 мин.










1 мин.

7. Подведение итогов урока.


Анализ успешности усвоенного материала и деятельности учащихся.


Объяснительно-иллюстративный

(беседа)

Коллективная

Вопросы:

1. Какой цикл можно использовать для стен неизвестной длины?

2. Как эти циклы оформляется в системе «Кумир»?







3. Какие условия могут быть использованы?


4. Как долго Робот будет повторять команды из тела цикла?

5. Можно ли решить домашнюю задачу только с помощью цикла «пока»?

Ответы:

1. Цикл «пока» или цикл «при»



  1. нц пока условие

команды

кц


нц

команды

кц_при условие


3. справа, сверху, снизу, слева свободно и логические связки И, ИЛИ, НЕ.

4. Пока выполняется условие или при его не достижении.


5. Да, можно. Но можно ее решить и с использованием цикла «при».

2 мин.

8. Домашнее задание.

Дать информацию и инструктаж по домашнему заданию

Объяснительно-иллюстративный (инструктаж)

Фронтальная

Устное сообщение учителя по слайду 15.

Слушают и записывают в дневник.

2 мин.


Название документа Цикл при.pptx

Команды повторения - ЦИКЛЫ Основные алгоритмические конструкции (8 класс, ФГО...
Домашнее задание Решить задачу, прислать решение в электронный дневник (текст...
использовать Робот алг дз нач нц пока снизу не свободно закрасить вправо кц в...
нц пока справа не свободно закрасить вверх кц вверх нц пока справа не свобод...
Цикл «пока» = вахтер на входе в школу
Цикл «пока» – цикл с предусловием. Т.е. проверка условия выполняется перед вы...
Нарушитель обнаружен на 3 этаже!
использовать Робот алг нач нц закрасить вправо кц_при снизу свободно нц вправ...
Цикл «при» – цикл с постусловием (или с послеусловием) Т.е. проверка условия...
Тема урока: Цикл «при» нц 	команды кц_при условие
Условия для Робота в Кумире: слева справа снизу сверху свободно слева справа...
Два цикла, решающие одну и ту же задачу: Цикл с предусловием Цикл с постуслов...
Домашнее задание Используем только циклы с постусловием!
1 из 15

Описание презентации по отдельным слайдам:

№ слайда 1 Команды повторения - ЦИКЛЫ Основные алгоритмические конструкции (8 класс, ФГО
Описание слайда:

Команды повторения - ЦИКЛЫ Основные алгоритмические конструкции (8 класс, ФГОС) Автор: учитель информатики МБОУ «Лицей» г. Арзамас Мурзина Ольга Ивановна

№ слайда 2 Домашнее задание Решить задачу, прислать решение в электронный дневник (текст
Описание слайда:

Домашнее задание Решить задачу, прислать решение в электронный дневник (текст, программа):

№ слайда 3 использовать Робот алг дз нач нц пока снизу не свободно закрасить вправо кц в
Описание слайда:

использовать Робот алг дз нач нц пока снизу не свободно закрасить вправо кц вправо вправо вправо нц пока справа свободно закрасить вправо закрасить кц

№ слайда 4 нц пока справа не свободно закрасить вверх кц вверх нц пока справа не свобод
Описание слайда:

нц пока справа не свободно закрасить вверх кц вверх нц пока справа не свободно закрасить вверх кц кон

№ слайда 5 Цикл «пока» = вахтер на входе в школу
Описание слайда:

Цикл «пока» = вахтер на входе в школу

№ слайда 6 Цикл «пока» – цикл с предусловием. Т.е. проверка условия выполняется перед вы
Описание слайда:

Цикл «пока» – цикл с предусловием. Т.е. проверка условия выполняется перед вызовом команд из тела цикла. Если условие не выполняется при первой же проверке, то команды из тела цикла не будут вызваны ни разу!

№ слайда 7 Нарушитель обнаружен на 3 этаже!
Описание слайда:

Нарушитель обнаружен на 3 этаже!

№ слайда 8
Описание слайда:

№ слайда 9 использовать Робот алг нач нц закрасить вправо кц_при снизу свободно нц вправ
Описание слайда:

использовать Робот алг нач нц закрасить вправо кц_при снизу свободно нц вправо кц_при снизу стена кон

№ слайда 10 Цикл «при» – цикл с постусловием (или с послеусловием) Т.е. проверка условия
Описание слайда:

Цикл «при» – цикл с постусловием (или с послеусловием) Т.е. проверка условия выполняется после вызова команд из тела цикла. Если условие не выполняется при первой же проверке, то команды из тела цикла будут вызваны один раз.

№ слайда 11 Тема урока: Цикл «при» нц 	команды кц_при условие
Описание слайда:

Тема урока: Цикл «при» нц команды кц_при условие

№ слайда 12 Условия для Робота в Кумире: слева справа снизу сверху свободно слева справа
Описание слайда:

Условия для Робота в Кумире: слева справа снизу сверху свободно слева справа снизу сверху стена клетка закрашена

№ слайда 13 Два цикла, решающие одну и ту же задачу: Цикл с предусловием Цикл с постуслов
Описание слайда:

Два цикла, решающие одну и ту же задачу: Цикл с предусловием Цикл с постусловием нцпока снизу не свободно закрасить вправо кц нц закрасить вправо кц_приснизу свободно

№ слайда 14
Описание слайда:

№ слайда 15 Домашнее задание Используем только циклы с постусловием!
Описание слайда:

Домашнее задание Используем только циклы с постусловием!



57 вебинаров для учителей на разные темы
ПЕРЕЙТИ к бесплатному просмотру
(заказ свидетельства о просмотре - только до 11 декабря)


Автор
Дата добавления 17.08.2016
Раздел Информатика
Подраздел Конспекты
Просмотров47
Номер материала ДБ-158648
Получить свидетельство о публикации
Похожие материалы

Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.
Специальное предложение
Вверх