Добавить материал и получить бесплатное свидетельство о публикации в СМИ
Эл. №ФС77-60625 от 20.01.2015
Свидетельство о публикации

Автоматическая выдача свидетельства о публикации в официальном СМИ сразу после добавления материала на сайт - Бесплатно

Добавить свой материал

За каждый опубликованный материал Вы получите бесплатное свидетельство о публикации от проекта «Инфоурок»

(Свидетельство о регистрации СМИ: Эл №ФС77-60625 от 20.01.2015)

Инфоурок / Информатика / Другие методич. материалы / Годовая контрольная работа по информатике 10 класс
ВНИМАНИЮ ВСЕХ УЧИТЕЛЕЙ: согласно Федеральному закону № 313-ФЗ все педагоги должны пройти обучение навыкам оказания первой помощи.

Дистанционный курс "Оказание первой помощи детям и взрослым" от проекта "Инфоурок" даёт Вам возможность привести свои знания в соответствие с требованиями закона и получить удостоверение о повышении квалификации установленного образца (180 часов). Начало обучения новой группы: 28 июня.

Подать заявку на курс
  • Информатика

Годовая контрольная работа по информатике 10 класс

библиотека
материалов

Годовая контрольная работа по информатике и ИКТ за 2014-2015 учебный год.

  1. Вариант и 2 Вариант

1.Как представлено число 263 в восьмеричной системе счисления?

1. В коробке лежат 64 цветных карандаша. Сообщение о том, что достали белый карандаш, несет 4 бита информации. Сколько белых карандашей было в коробке?

2.Дано: hello_html_m242e1807.gif, hello_html_24b9e5b6.gif. Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству hello_html_4668a754.gif?

1) 110100112 2) 110011102 3) 110010102 4) 110011002

2. В электронной таблице значение формулы =СРЗНАЧ(A3:D4) равно 5. Чему равно значение формулы =СРЗНАЧ(A3:C4), если значение формулы =СУММ(D3:D4)равно 4?

3. Для какого числа X истинно высказывание

(X(X-16) > -64)(X > 8)

1) 5 2) 6 3) 7 4) 8

3.Объем сообщения – 7,5 Кбайт. Известно, что данное сообщение содержит 7680 символов. Какова мощность алфавита?

4. Грунтовая дорога проходит последовательно через населенные пункты А, B, С и D. При этом длина дороги между А и В равна 80 км, между В и С – 50 км, и между С и D – 10 км. Между А и С построили новое асфальтовое шоссе длиной 40 км. Оцените минимально возможное время движения велосипедиста из пункта А в пункт В, если его скорость по грунтовой дороге – 20 км/час, по шоссе – 40 км/час.

X

Y

Z

F

1

0

0

0

0

1

1

1

1

0

1

1



4.Дан фрагмент таблицы истинности выражения F. Какое выражение соответствует F?

1) X Z Y 2) ¬Z (X Y)

3) ¬(X Y) Z 4) ¬X ¬(Y Z)


5. Для групповых операций с файлами используются маски имен файлов. Определите, какое из указанных имен файлов не удовлетворяет маске: ??pri*.?*

1) caprika.wow 2) weprik.cpp

3) otopri.c 4) reprint.be

5.В электронной таблице значение формулы =СРЗНАЧ(A6:C6) равно (-2). Чему равно значение формулы =СУММ(A6:D6), если значение ячейки D6 равно 5?


6.Цепочка из трех бусин формируется по следующему правилу: на первом месте стоит одна из бусин Б, В, Г. На втором – одна из бусин А, Б, В. На третьем месте – одна из бусин А, В, Г, не стоящая в цепочке на первом или втором месте. Какая из цепочек создана по этому правилу?

1) АГБ 2) ВАА 3) БГВ 4) ГБА

6.Производится двухканальная (стерео) звукозапись с частотой дискретизации 44,1 кГц и глубиной кодирования 24 бит. Запись длится 1 минуту, ее результаты записываются в файл, сжатие данных не производится. Найти размер файла, выраженный в мегабайтах?


7.Метеорологическая станция ведет наблюдение за влажностью воздуха. Результатом одного измерения является целое число от 0 до 100 процентов, которое записывается при помощи минимально возможного количества бит. Станция сделала 80 измерений. Определите информационный объем результатов наблюдений.

1) 80 бит 2) 70 байт 3) 80 байт 4) 560 байт

7. В некоторой стране автомобильный номер длиной 7 символов составляется из заглавных букв (всего используется 18 букв) и десятичных цифр в любом порядке. Каждый символ кодируется одинаковым и минимально возможным количеством бит, а каждый номер – одинаковым и минимально возможным количеством байт. Определите объем памяти, необходимый для хранения 60 автомобильных номеров.

8.В корзине лежат черные и белые шары. Среди них 18 черных шаров. Сообщение о том, что достали белый шар, несет 2 бита информации. Сколько всего шаров в корзине?

8. У исполнителя УТРОИТЕЛЬ две команды, которым присвоены номера:

1. вычти 1 2. умножь на 3

Запишите порядок команд в программе получения из числа 3 числа 16, содержащей не более 5 команд, указывая лишь номера команд.

9. Сколько секунд потребуется модему, передающему сообщения со скоростью 24800 бит/с, чтобы передать цветное растровое изображение размером 140x260 пикселей, при условии, что цвет каждого пикселя кодируется тремя байтами

9. Сколько секунд потребуется модему, передающему сообщения со скоростью 28800 бит/с, чтобы передать цветное растровое изображение размером 640x480 пикселей, при условии, что цвет каждого пикселя кодируется тремя байтами?

9. На рисунке приведен фрагмент электронной таблицы. Чему будет равно значение ячейки B4, в которую записали формулу =СУММ(A1:С2;C3)?


A

B

C

D

1

1

2

3


2

4

5

6


3

7

8

8


4






10. Определите значение переменной S после выполнения следующего фрагмента программы:

S:=0; i:=9;

while i > 1 do begin

S := S + i div 2;

i := i - 1;

end;


10. Определите значение переменной b после выполнения фрагмента алгоритма.

hello_html_14dc9107.gif

11.В терминологии сетей TCP/IP маской сети называется двоичное число, определяющее, какая часть IP-адреса узла сети относится к адресу сети, а какая — к адресу самого узла в этой сети. Обычно маска записывается по тем же правилам, что и IP-адрес. Адрес сети получается в результате применения поразрядной конъюнкции к заданному IP-адресу узла и маске. По заданным IP-адресу узла и маске определите адрес сети.
IP-адрес узла: 217.9.191.133
Маска: 255.255.192.0

Начало формы

При записи ответа выберите из приведенных в таблице чисел четыре элемента IP-адреса и запишите в нужном порядке соответствующие им буквы, без использования точек.

A

B

C

D

E

F

G

H

0

9

16

64

128

142

192

217





Подайте заявку сейчас на любой интересующий Вас курс переподготовки, чтобы получить диплом со скидкой 50% уже осенью 2017 года.


Выберите специальность, которую Вы хотите получить:

Обучение проходит дистанционно на сайте проекта "Инфоурок".
По итогам обучения слушателям выдаются печатные дипломы установленного образца.

ПЕРЕЙТИ В КАТАЛОГ КУРСОВ

Краткое описание документа:

 

В результате изучения информатики и ИКТ на базовом уровне ученик должен

знать/понимать

  • Основные технологии создания, редактирования, оформления, сохранения, передачи информационных объектов различного типа с помощью современных программных средств информационных и коммуникационных технологий;

  • Назначение и виды информационных моделей, описывающих реальные объекты и процессы; 

  • Назначение и функции операционных систем;

уметь
Оперировать различными видами информационных объектов, в том числе с помощью компьютера, соотносить полученные результаты с реальными объектами;


  • Распознавать и описывать информационные процессы в социальных, биологических и технических системах;

  • Использовать готовые информационные модели, оценивать их соответствие реальному объекту целям моделирования;

  • Оценивать достоверность информации, сопоставляя различные источники;

  • Иллюстрировать учебные работы с использованием средств информационных технологий;

  • Создавать информационные объекты сложной структуры, в том числе гипертекстовые документы;

  • Просматривать, создавать, редактировать, сохранять записи в базах данных, получать необходимую информацию по запросу пользователя;

  • Наглядно представлять числовые показатели и динамику их изменения с помощью программ деловой графики;

  • Соблюдать правила техники безопасности и гигиенические рекомендации при использовании средств ИКТ;

  • Использовать приобретенные знания и умения в практической деятельности и повседневной жизни для: 

 


  • Эффективного применения информационных образовательных ресурсов в учебной деятельности в том числе самообразовании;

  • Ориентации в информационном пространстве, работы с распространенными автоматизированными информационными системами;

  • Автоматизации коммуникационной деятельности;

  • Соблюдения этических и правовых норм при работе с информацией;

  • Эффективной организации индивидуального информационного пространства.
Автор
Дата добавления 16.05.2015
Раздел Информатика
Подраздел Другие методич. материалы
Просмотров3221
Номер материала 535131
Получить свидетельство о публикации
Похожие материалы

Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.
Специальное предложение
Вверх