247032
столько раз учителя, ученики и родители
посетили сайт «Инфоурок»
за прошедшие 24 часа
+Добавить материал
и получить бесплатное
свидетельство о публикации
в СМИ №ФС77-60625 от 20.01.2015
Дистанционные курсы профессиональной переподготовки и повышения квалификации для педагогов

Дистанционные курсы для педагогов - курсы профессиональной переподготовки от 6.900 руб.;
- курсы повышения квалификации от 1.500 руб.
Престижные документы для аттестации

ВЫБРАТЬ КУРС СО СКИДКОЙ 50%

ВНИМАНИЕ: Скидка действует ТОЛЬКО сейчас!

(Лицензия на осуществление образовательной деятельности № 5201 выдана ООО "Инфоурок")

ИнфоурокИнформатикаПрезентацииPower Point –та Visual basic –тің мүмкіндіктерін пайдаланып, тест құрастыру

Power Point –та Visual basic –тің мүмкіндіктерін пайдаланып, тест құрастыру

библиотека
материалов

Описание презентации по отдельным слайдам:

1 слайд
Описание слайда:

2 слайд
Описание слайда:

3 слайд
Описание слайда:

4 слайд
Описание слайда:

5 слайд
Описание слайда:

6 слайд
Описание слайда:

7 слайд
Описание слайда:

Краткое описание документа:

Нигметова Венера Курманбаевна

Құрманғазы ауданы

Сафон селосы

Ф.Энгельс атындағы орта мектебі

 

Қазіргі кезде компьютерді пайдаланып оқушыларды тоқсан ішінде бірнеше рет тестілеу - олардың ағымдық білімін бағалаудың негізгі әдістерінің бірі. MS Office өнімінің  Power Point және Excel электрондық кестесі –мұғалімге оқушы білімін тексеруге және оқушының өзбетімен жұмыстануына тест бағдарламасын құруда ең қажетті әрі жеңіл бағдарламалар деп санаймын. Сондықтан да Power Point- та Visual Basic программалау тілінің   мүмкіндіктерін  және Excel электрондық кестесінде формулаларды қолданып бірнеше сұрақтан тұратын тест бағдарламасын құрастырып  шықтым.

Бағдарламалық өнімдерді құрастырудағы мақсатым –  мұғалімдерге жүргізілетін пәндері бойынша тексеру  тестін жүргізуде   көмек көрсету. Әр түрлі пәндер бойынша оқушыларға тест жұмыстарын тез әрі өз бетінше құруға көмектеседі.

Тест қорытындысы  оқушының берген жауабына қарай ұпай және бағамен көрсетіліп отырады.

 

 

 

 

 

 

 

 

 

Қазіргі кезде дербес компьютерлерді пайдаланушылар арасында Windows  операциялық жүйелері жанұясы танымал және бағдарлама жасауға қызыққандар, осы жүйеде жұмыс жасайтын бағдарламалар жазуға ынталанады. Бұл күнделікті өмірге ақпараттық технологиялардың  енуімен және дамуымен байланысты. Егер де адам компьютермен жұмыс жасаса, онда ол адамда ерте ме, кеш пе ынта, кейбір кездері бағдарламаларды үйрену қажеттілігі туындайды.

Есептеуіш техниканың дамуы, бағдарламаны қамтамасыз жасау  құралдарына деген эффективті қажеттілік, бағдарламалау тілдерінің пайда болуына әкелді, олардың ішінде келесілерді  Borland Delphi  және  Microsoft  Visual Basic көрсетуге болады.  Тез жасау жүйесінің негізіне көрнекі жобалау технологиясы және оқиғалы  бағдарламалау жатады.

Microsoft  Visual Basic Windows –қа кәсіби деңгейлі интерфейсі бар қолданбалы бағдарлама жасауға мүмкіндік береді.

            Осы жобада программаларды тестілеу Visual Basic  бағдарламалау ортасының мүмкіндіктері арқылы жүзеге асады.

  Мақсатым - Visual Basic визуалды  жобалау ортасында мектепте программаны тестілеу бағдарламасын құру болып  табылады. Тест оқушы білімінің деңгейін ғана анықтап қана қоймайды, оның ойын жүйелеп, жылдам есептеуіне, логикалық ойлау, есептеу дағдыларының қалыптасуына, тез шешім қабылдау қасиетінің дамуына тиімді әсер етеді. Тест оқушының білім дәрежесін қандай екендігін анықтайтын және ол білімді түрлі жағдайларда қолдана білуін тексеруге мүмкіндік беретін тиімді жол.

І. Power Point- та Visual Basic-тің  көмегімен тест құрамыз. Ол ұшін жаңа презентация құрамыз. Power Point параметрлері батырмасынан Разработчик менюін  шығарып аламыз.  (1 сурет)

Visual Basic-тің көмегімен әр түрлі типті сұрақтарды, яғни бір жауапты таңдау, жауапты ұяшыққа енгізу, бірнеше жауапты таңдау мүмкіндігін беретін тест құрастыруға болады. Тест жауаптарын батырма, жалауша немесе  қосқышты шерту арқылы таңдауға болады.

 (2 сурет)

Батырманы редакторлеу және программа жазу үшін батырма үстіне екі рет шертеміз.  microsoft Visual basic терезесі ашылады. Келесі функцияларды қараймыз: Caption – батырма аты.  CommandButton өшіреміз де өзімізге қажетті аты енгіземіз. Мысалы "1".  Font режимінде батырмадағы әріп өлшемі мен стилі қойылады.

  (3 сурет)

Программасы:   n – сұрақтар санын санайтын айнымалы, k – дұрыс жауаптар санын санайтын айнымалы. Бұл бірінші сұрақ болғандықтан, оларды 0 –ге тең деп береміз. K дұрыс жауаптар батырмасын,  ал  n әрбір жауцаптар батырмачсын басқанда өсіп отырады. MsgBox ол тырнақшаға алынған мәтінді қосымша терезеге шығаратын команда. SlideShowWindows(1).View.Next командасы мәтінді жаңа слайдқа аударады.

 (4 сурет)

Сұрақтарды қарапайым режимде жазып, дұрыс жауаптарды таңдау үшін  Қосқышты (переключатель) қосамыз. Батырманы қосу мысалындағыдай, Қосқышты жазамыз. Тағы да «Жауапты қабылдау» деген батырманы қосамыз да оны да өңдеп жаңа слайдқа көшеміз. (3 слайд)

Батырмаға екі рет шертіп программа терезесін шақырамыз.төмендегі программаны жазамыз

3 сұрақтың жауабын енгізу  үшін  «Өріс» батырмасын таңдаймыз. Тағы да «Жауапты қабылдау» деген батырманы қосамыз да оны да өңдеп жаңа слайдқа көшеміз. (4 слайд)

 

Бірнеше жауапты таңдауға болатын слайд құраймыз. Ол үшін Разработчик панелінен «Жалауша» батырмасын қойып, жоғарыдағы мысалдардай жауаптарды жазамыз. (5  слайд)

Суретті таңдауға болатын слайд құрамыз. Разработчик панелінен  батырмасын таңдап суреттерді кірістіріп, өңдейміз. (6 слайд)

 

Тест жауабын өңдейтін форма құрамыз. Мәтіндерді қарапайым режимде енгізіп, нәтижені көрсететін батырмаларды қосамыз.  Нәтижені көрсету үшін «Нәтиже» батырмасын қосамыз. (7 слайд)  

 

ІІ. Excel электрондық кестесінде формулаларды қолданып тест құраймыз.

Үлгі бойынша тапсырма мәтінін тереміз. А бағанына тест сұрақтары мен жауаптарын енгіземіз.

  1. В29 ұяшығына барлық жауаптарды санайтын формцула енгіземіз. =СУММ(B6:B24) 

  2. С29 ұяшығына дұрыс жауаптарды  санайтын формула енгіземіз. =B8+B14+B17+B22

  3.  D29 ұяшығы Формат Число Процентный =ЕСЛИ(B29=4; C29/B29;)

  4. Бағаларды көру үшін В32 ұяшығына =ЕСЛИ(D29>=80%; "5";"  ") формуласын,  С32 ұяшығына =ЕСЛИ(И(D29<80%;D29>=60%);"4";"  ")формуласын,  D32 ұяшығына =ЕСЛИ(И(D29<60%;D29>=40%);"3";"  ") формуласын,  Е32 ұяшығына =ЕСЛИ(И(D29<40%; D29>=0%); "2";"  ") формуласын енгіземіз.

Бағалау шкаласы (әркім өз қалауымен өзгерте алады)

«5» - 80-100%, «4» - 60-79%,«3» - 40-59%, «2» - 0-39%

Тестті қолдану: В бағанына дұрыс жауаптардың тұсына 1 санын енгіземіз.

 

Общая информация

Номер материала: 293036

Вам будут интересны эти курсы:

Курс повышения квалификации «Табличный процессор MS Excel в профессиональной деятельности учителя математики»
Курс повышения квалификации «Методика преподавания информатики в начальных классах»
Курс повышения квалификации «Внедрение системы компьютерной математики в процесс обучения математике в старших классах в рамках реализации ФГОС»
Курс профессиональной переподготовки «Информатика: теория и методика преподавания в образовательной организации»
Курс «Фирменный стиль» (Corel Draw, Photoshop)
Курс «1С: Предприятие 7.7»
Курс «3D Studio MAX»
Курс повышения квалификации «Использование компьютерных технологий в процессе обучения в условиях реализации ФГОС»
Курс повышения квалификации «Введение в программирование на языке С (СИ)»
Курс профессиональной переподготовки «Управление в сфере информационных технологий в образовательной организации»
Курс профессиональной переподготовки «Теория и методика обучения информатике в начальной школе»
Курс профессиональной переподготовки «Математика и информатика: теория и методика преподавания в образовательной организации»
Курс повышения квалификации «Современные тенденции цифровизации образования»
Курс повышения квалификации «Современные языки программирования интегрированной оболочки Microsoft Visual Studio C# NET., C++. NET, VB.NET. с использованием структурного и объектно-ориентированного методов разработки корпоративных систем»
Курс повышение квалификации «Применение интерактивных образовательных платформ на примере платформы Moodle»
Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.