Добавить материал и получить бесплатное свидетельство о публикации в СМИ
Эл. №ФС77-60625 от 20.01.2015
Инфоурок / Информатика / Другие методич. материалы / Раздаточный материал на тему "Циклические алгоритмы"

Раздаточный материал на тему "Циклические алгоритмы"

  • Информатика

Поделитесь материалом с коллегами:



Карточка 1

алг

нач

цел s,k

s:=95

нц для k от 19 до 14 шаг – 1

s:=s-4

кц

вывод s

кон


алг

нач

цел s,k

s:=5

нц для k от 11 до 17

s:=s+7

кц

вывод s

кон



алг

нач

цел s,k

s:=20; k:=5

нц пока s<50

s:=s+5

k:=k+1

кц

вывод k

кон


алг

нач

цел s,k

s:=20; k:=5

нц пока s<50

s:=s+k*2

k:=k+1

кц

вывод k

кон


алг

нач

цел s,k

s:=60

нц для k от 5 до 10

s:=s-k

кц

вывод s

кон


алг

нач

цел s,k

s:=60

нц для k от - 4 до 6

s:=s+2*k

кц

вывод s

кон




Ответ



Карточка 2


алг

нач

цел s,k

s:=100; k:=7

нц

s:=s-k

k:=k+1

кц при k>10

вывод s+k

кон


алг

нач

цел s,k

s:=0; k:=15

нц

s:=s+k

k:=k-3

кц при k<10

вывод s-k

кон


алг

нач

цел s,k

s:=1

нц для k от 1 до 10

s:=(k-3)*s

кц

вывод s

кон


алг

нач

цел s,k

s:= - 2

нц для k от -1 до 8

s:=(k-2)*s

кц

вывод s

кон


алг

нач

цел z,n

z:=0

нц для n от 1 до 20

если n > 10 то

z:=z+n

иначе z:=z-n

все

кц

вывод z

кон


алг

нач

цел z,n

z:=0

нц для n от 1 до 10

если z<5 то

z:=z+2*n

иначе z:=n-z

все

кц

вывод z

кон




Ответ


Автор
Дата добавления 12.09.2016
Раздел Информатика
Подраздел Другие методич. материалы
Просмотров16
Номер материала ДБ-190615
Получить свидетельство о публикации
Похожие материалы

Включите уведомления прямо сейчас и мы сразу сообщим Вам о важных новостях. Не волнуйтесь, мы будем отправлять только самое главное.
Специальное предложение
Вверх