1210179
столько раз учителя, ученики и родители
посетили официальный сайт ООО «Инфоурок»
за прошедшие 24 часа
Добавить материал и получить бесплатное
свидетельство о публикации
в СМИ №ФС77-60625 от 20.01.2015
Инфоурок Информатика КонспектыТворческое задание №1, Информатика, 8 класс

Творческое задание №1, Информатика, 8 класс

IV Международный дистанционный конкурс «Старт» Идёт приём заявок Для дошкольников и учеников 1-11 классов 16 предметов ОРГВЗНОС 25 Р. ПОДАТЬ ЗАЯВКУ
библиотека
материалов

Творческое задание №1


  1. Задача 1.


На даче родители Маши вскопали грядки. Грядок целых восемь, работы много… Мама предложила Маше помочь ей высадить морковку. Необходимо найти оптимальное начальное положение для начала работы и посадить морковку на грядки, оставив тропинки для прополки и сбора урожая. Помоги Маше при помощи Робота справиться с задачей, результатом выполнения которой будут закрашенные клетки (места посадки семян).

hello_html_m40b72f44.png


  1. Решение:

В Алгоритме Огород используем цикл с параметром:
нц … раз … кц

Оптимальное положение для начала работы в начале тропинки: hello_html_m40b72f44.png

hello_html_68ba0ed2.gif

В основном алгоритме в цикле от 1 до 4 повторяем команды:

вверх; левая_грядка; правая грядка; вверх.

Используем два вспомогательных алгоритма: левая_грядка и правая_грядка, каждый из них обеспечивает закрашивание клеток на соответствующей грядке.


Программа для Робота

использовать Робот

алг Огород

нач

нц 4 раз

вверх

Левая_грядка

Правая_грядка

вверх

кц

кон

алг Левая_грядка

нач

нц пока слева свободно

влево

закрасить

кц

нц пока не сверху свободно

вправо

кц

кон

алг Правая_грядка

нач

нц пока справа свободно

вправо

закрасить

кц

нц пока не сверху свободно

влево

кц

кон

Окно Робота в Кумире

hello_html_5fbe6ca4.png




  1. Задача 2.

    После того, как Маша справилась с посадками морковки, она решила сделать на даче клумбу в форме цветка, в которую затем посадить красивые цветы. Но еще не решила, сколько лепестков ей выбрать для клумбы. Поэтому она хотела бы посмотреть, как будет выглядеть клумба с разным числом лепестков. Умная "Черепашка" должна научить Машу нарисовать чертеж клумбы из N лепестков. Составьте алгоритм для Черепашки.

    Решение:

    В основном алгоритме flower используем процедуру lepestok , которая рисует две дуги, составляющие лепесток цветка.

    Параметр :N в основном алгоритме flower :N позволяет нарисовать чертеж с заданным числом лепестков (N).


    Среда MSW Logo


    to flower :N

    repeat :N[

    lepestok

    rt 360/:N

    ]

    end

    to lepestok

    repeat 2[

    repeat 90[

    fd 1 rt 1

    ]

    rt 90

    ]

    end


    hello_html_m32f75578.png

  2. Задача 3

Мама купила Маше ящик конфет и разрешила взять в 1-й день 1 конфету, а во все последующие дни количество, возрастающее в арифметической прогрессии с шагом 1. Сколько конфет можно взять девочке в N-й день?


  1. Решение

program konfety;

var

day, N, d, k : integer;

begin

read(N);

k:= 0;

for day := 1 to N do begin

d := d + 1;

k := k + d;

end;

write(k)

end.


Курс профессиональной переподготовки
Учитель информатики
Курс профессиональной переподготовки
Учитель математики и информатики
Найдите материал к любому уроку,
указав свой предмет (категорию), класс, учебник и тему:
также Вы можете выбрать тип материала:
Краткое описание документа:

Задача 1. 

На даче родители Маши вскопали грядки. Грядок целых восемь, работы много… Мама предложила Маше помочь ей высадить морковку.  Необходимо найти оптимальное начальное положение для начала работы и посадить морковку на грядки, оставив тропинки для прополки и сбора урожая. Помоги Маше при помощи Робота справиться с задачей, результатом выполнения которой будут закрашенные клетки (места посадки семян).

Задача 2. 

После того, как Маша справилась с посадками морковки, она  решила сделать на даче клумбу в форме цветка, в которую затем посадить красивые цветы. Но еще не решила, сколько лепестков ей выбрать для клумбы. Поэтому она хотела бы посмотреть, как будет выглядеть клумба с разным числом лепестков. Умная "Черепашка" должна научить Машу нарисовать чертеж клумбы из N лепестков. Составьте алгоритм для Черепашки.

 

Общая информация
ВНИМАНИЮ УЧИТЕЛЕЙ: хотите организовать и вести кружок по ментальной арифметике в своей школе? Спрос на данную методику постоянно растёт, а Вам для её освоения достаточно будет пройти один курс повышения квалификации (72 часа) прямо в Вашем личном кабинете на сайте "Инфоурок".

Пройдя курс Вы получите:
- Удостоверение о повышении квалификации;
- Подробный план уроков (150 стр.);
- Задачник для обучающихся (83 стр.);
- Вводную тетрадь «Знакомство со счетами и правилами»;
- БЕСПЛАТНЫЙ доступ к CRM-системе, Личному кабинету для проведения занятий;
- Возможность дополнительного источника дохода (до 60.000 руб. в месяц)!

Пройдите дистанционный курс «Ментальная арифметика» на проекте "Инфоурок"!

Подать заявку
IV Международный дистанционный конкурс «Старт» Для дошкольников и учеников 1-11 классов Рекордно низкий оргвзнос 25 Р. 16 предметов ПОДАТЬ ЗАЯВКУ
Оставьте свой комментарий
Авторизуйтесь, чтобы задавать вопросы.