Инфоурок / Информатика / Конспекты / Творческое задание №1, Информатика, 8 класс

Творческое задание №1, Информатика, 8 класс



Московские документы для аттестации!

124 курса профессиональной переподготовки от 4 795 руб.
274 курса повышения квалификации от 1 225 руб.

Для выбора курса воспользуйтесь поиском на сайте KURSY.ORG


Вы получите официальный Диплом или Удостоверение установленного образца в соответствии с требованиями государства (образовательная Лицензия № 038767 выдана ООО "Столичный учебный центр" Департаментом образования города МОСКВА).

ДИПЛОМ от Столичного учебного центра: KURSY.ORG


библиотека
материалов

Творческое задание №1


  1. Задача 1.


На даче родители Маши вскопали грядки. Грядок целых восемь, работы много… Мама предложила Маше помочь ей высадить морковку. Необходимо найти оптимальное начальное положение для начала работы и посадить морковку на грядки, оставив тропинки для прополки и сбора урожая. Помоги Маше при помощи Робота справиться с задачей, результатом выполнения которой будут закрашенные клетки (места посадки семян).

hello_html_m40b72f44.png


  1. Решение:

В Алгоритме Огород используем цикл с параметром:
нц … раз … кц

Оптимальное положение для начала работы в начале тропинки: hello_html_m40b72f44.png

hello_html_68ba0ed2.gif

В основном алгоритме в цикле от 1 до 4 повторяем команды:

вверх; левая_грядка; правая грядка; вверх.

Используем два вспомогательных алгоритма: левая_грядка и правая_грядка, каждый из них обеспечивает закрашивание клеток на соответствующей грядке.


Программа для Робота

использовать Робот

алг Огород

нач

нц 4 раз

вверх

Левая_грядка

Правая_грядка

вверх

кц

кон

алг Левая_грядка

нач

нц пока слева свободно

влево

закрасить

кц

нц пока не сверху свободно

вправо

кц

кон

алг Правая_грядка

нач

нц пока справа свободно

вправо

закрасить

кц

нц пока не сверху свободно

влево

кц

кон

Окно Робота в Кумире

hello_html_5fbe6ca4.png




  1. Задача 2.

    После того, как Маша справилась с посадками морковки, она решила сделать на даче клумбу в форме цветка, в которую затем посадить красивые цветы. Но еще не решила, сколько лепестков ей выбрать для клумбы. Поэтому она хотела бы посмотреть, как будет выглядеть клумба с разным числом лепестков. Умная "Черепашка" должна научить Машу нарисовать чертеж клумбы из N лепестков. Составьте алгоритм для Черепашки.

    Решение:

    В основном алгоритме flower используем процедуру lepestok , которая рисует две дуги, составляющие лепесток цветка.

    Параметр :N в основном алгоритме flower :N позволяет нарисовать чертеж с заданным числом лепестков (N).


    Среда MSW Logo


    to flower :N

    repeat :N[

    lepestok

    rt 360/:N

    ]

    end

    to lepestok

    repeat 2[

    repeat 90[

    fd 1 rt 1

    ]

    rt 90

    ]

    end


    hello_html_m32f75578.png

  2. Задача 3

Мама купила Маше ящик конфет и разрешила взять в 1-й день 1 конфету, а во все последующие дни количество, возрастающее в арифметической прогрессии с шагом 1. Сколько конфет можно взять девочке в N-й день?


  1. Решение

program konfety;

var

day, N, d, k : integer;

begin

read(N);

k:= 0;

for day := 1 to N do begin

d := d + 1;

k := k + d;

end;

write(k)

end.


Очень низкие цены на курсы переподготовки от Московского учебного центра для педагогов

Специально для учителей, воспитателей и других работников системы образования действуют 65% скидки при обучении на курсах профессиональной переподготовки.

После окончания обучения выдаётся диплом о профессиональной переподготовке установленного образца с присвоением квалификации (признаётся при прохождении аттестации по всей России).

Подайте заявку на интересующий Вас курс сейчас: KURSY.ORG


Краткое описание документа:

Задача 1. 

На даче родители Маши вскопали грядки. Грядок целых восемь, работы много… Мама предложила Маше помочь ей высадить морковку.  Необходимо найти оптимальное начальное положение для начала работы и посадить морковку на грядки, оставив тропинки для прополки и сбора урожая. Помоги Маше при помощи Робота справиться с задачей, результатом выполнения которой будут закрашенные клетки (места посадки семян).

Задача 2. 

После того, как Маша справилась с посадками морковки, она  решила сделать на даче клумбу в форме цветка, в которую затем посадить красивые цветы. Но еще не решила, сколько лепестков ей выбрать для клумбы. Поэтому она хотела бы посмотреть, как будет выглядеть клумба с разным числом лепестков. Умная "Черепашка" должна научить Машу нарисовать чертеж клумбы из N лепестков. Составьте алгоритм для Черепашки.

 

Общая информация

Номер материала: 546092

Похожие материалы

Получите наградные документы сразу с 38 конкурсов за один орг.взнос: Подробнее ->>