723732
столько раз учителя, ученики и родители
посетили официальный сайт ООО «Инфоурок»
за прошедшие 24 часа
Добавить материал и получить бесплатное
свидетельство о публикации
в СМИ №ФС77-60625 от 20.01.2015

Скидка 0%

112 курсов профессиональной переподготовки от 4720 руб.

268 курсов повышения квалификации от 1120 руб.

МОСКОВСКИЕ ДОКУМЕНТЫ ДЛЯ АТТЕСТАЦИИ

Лицензия на осуществление образовательной деятельности №038767 выдана 26 сентября 2017 г. Департаменотом образования города Москвы

Проект «Инфоурок» совместно с Министерством финансов РФ приглашает учителей и всех желающих к участию в Марафоне финансовой грамотности Все участники получат бесплатные документы Принять участие
Инфоурок Информатика Другие методич. материалыКонтрольная работа «Алгоритмы»

Контрольная работа «Алгоритмы»

Выберите документ из архива для просмотра:

Выбранный для просмотра документ Контрольная работа.doc

библиотека
материалов

ВАРИАНТ 1

1.ВСТАВЬ ПРОПУЩЕННУЮ КОМАНДУ ТАКИМ ОБРАЗОМ, ЧТОБЫ ПОЛУЧИЛАСЬ ПРОГРАММА РИСОВАНИЯ ОРНАМЕНТА (орнамент 1)


hello_html_m5629d34a.pngВЫУЧИ орнамент_1 [

ПОВТОРИ 10 [ПР 90 ВП 20 ……. ВП 20]

]



2. Нарисуй объект, который получится при выполнении последовательности команд. Укажите на рисунке конечное положение черепашки.

по

пр 45 вп 45 пр 45 вп 20 пр 45 вп 45

пр 135 вп 80 нд 70 лв 90 вп 50

пр 90 вп 60 пр 90 вп 50

пп

пр 90 вп 20 пр 90 вп 10

по

вп 20 лв 90 вп 20 лв 90

вп 20 лв 90 вп 20

пп

3. Чему равно N если на экране после выполнения алгоритма должен получиться правильный пятиугольник?

ПОВТОРИ 6 [ВП 40 ПР N]

4. Что появится на экране в результате выполнения алгоритма?

ПОВТОРИ 10 [ВП 5 ПР 45]

5. Что появится на экране в результате выполнения алгоритма?

ПОВТОРИ 5 [ ПОВТОРИ 4 [ ВП 40 ПР 90] ПР 120]

6. Что появится на экране в результате выполнения алгоритма?

ПОВТОРИ 4 [ ПОВТОРИ 3 [ ВП 10 ПР 120] ПР 120]

7. Составьте алгоритмы рисования фигур (используя циклы и вспомогательный алгоритм)

hello_html_73dbb293.pnghello_html_m4e856534.png


ВАРИАНТ 2

1. ВСТАВЬ ПРОПУЩЕННУЮ КОМАНДУ ТАКИМ ОБРАЗОМ, ЧТОБЫ ПОЛУЧИЛАСЬ ПРОГРАММА РИСОВАНИЯ ОРНАМЕНТА (орнамент 2)

hello_html_m74f90180.png

ВЫУЧИ орнамент_2 [

ПОВТОРИ 8 [ВП 10 ПР 90 ВП 10 ….. ВП 10 ПР 90 ВП 10 НД 20 ПР 90]

]

2. Нарисуй объект, который получится при выполнении последовательности команд. Укажите на рисунке конечное положение черепашки.

по

вп 10 лв 90 вп 60 лв 90 вп 60 лв 90 вп 60

лв 90 вп 20 пр 90 вп 10 лв 45 вп 15 лв 45

вп 10 лв 45 вп 15 лв 45 вп 10

пп

вп 30 лв 45

по

вп 30 лв 90 вп 30 лв 90 вп 30 лв 90 вп 30

пп

3. Чему равно N если на экране после выполнения алгоритма должен получиться правильный шестиугольник?

ПОВТОРИ 7 [ВП 40 ПР N]

4. Что появится на экране в результате выполнения алгоритма?

ПОВТОРИ 4 [ВП 5 ПР 120]

5. Что появится на экране в результате выполнения алгоритма?

ПОВТОРИ 4 [ ПОВТОРИ 3 [ ВП 10 ПР 120] ПР 90]

6. Что появится на экране в результате выполнения алгоритма?

ПОВТОРИ 3 [ ПОВТОРИ 5 [ ВП 10 ПР 72] ПР 120]

7. Составьте алгоритмы рисования фигур (используя циклы и вспомогательный алгоритм)

hello_html_m33203597.png

hello_html_m18c483aa.png


Курс профессиональной переподготовки
Учитель информатики
Найдите материал к любому уроку,
указав свой предмет (категорию), класс, учебник и тему:
также Вы можете выбрать тип материала:
Краткое описание документа:
Контрольная    работа   «Алгоритмы»     представляет   собой    набор   заданий  по    вставке    пропущенных команд  таким образом,  чтобы  получилась программа для создания орнамента.Чему равно числоесли   на   экране   после   выполнения алгоритма   должен   получиться   правильный   пятиугольник?  Составить   алгоритмы    рисования   фигур    (используя   циклы   и   вспомогательный   алгоритм).Учитель используя контрольную работу (два варианта)  может подобрать подобные задания для разработки своего варианта контрольной работы. Цель: проверка знаний учащихся по программированию.
ВНИМАНИЮ УЧИТЕЛЕЙ: хотите организовать и вести кружок по ментальной арифметике в своей школе? Спрос на данную методику постоянно растёт, а Вам для её освоения достаточно будет пройти один курс повышения квалификации (72 часа) прямо в Вашем личном кабинете на сайте "Инфоурок".

Пройдя курс Вы получите:
- Удостоверение о повышении квалификации;
- Подробный план уроков (150 стр.);
- Задачник для обучающихся (83 стр.);
- Вводную тетрадь «Знакомство со счетами и правилами»;
- БЕСПЛАТНЫЙ доступ к CRM-системе, Личному кабинету для проведения занятий;
- Возможность дополнительного источника дохода (до 60.000 руб. в месяц)!

Пройдите дистанционный курс «Ментальная арифметика» на проекте "Инфоурок"!

Подать заявку


Вам будут интересны эти курсы:

Курс профессиональной переподготовки «Информатика: теория и методика преподавания в образовательной организации»
Курс профессиональной переподготовки «Информационные технологии в профессиональной деятельности: теория и методика преподавания в образовательной организации»
Курс повышения квалификации «Использование компьютерных технологий в процессе обучения в условиях реализации ФГОС»
Курс повышения квалификации «Специфика преподавания информатики в начальных классах с учетом ФГОС НОО»
Курс повышения квалификации «Применение MS Word, Excel в финансовых расчетах»
Курс профессиональной переподготовки «Управление в сфере информационных технологий в образовательной организации»
Курс профессиональной переподготовки «Математика и информатика: теория и методика преподавания в образовательной организации»
Курс повышения квалификации «Специфика преподавания дисциплины «Информационные технологии» в условиях реализации ФГОС СПО по ТОП-50»
Курс повышения квалификации «Применение интерактивных образовательных платформ на примере платформы Moodle»
Оставьте свой комментарий
Авторизуйтесь, чтобы задавать вопросы.