Выдаём удостоверения и дипломы установленного образца

Получите 5% кэшбэк!

Запишитесь на один из 793 курсов и получите 5% кэшбэк стоимости курса на карту

Выбрать курс
Инфоурок Информатика ПрезентацииПрезентация по информатике на тему "Конструирование алгоритмов" (9 класс)

Презентация по информатике на тему "Конструирование алгоритмов" (9 класс)

Скачать материал
библиотека
материалов
КОНСТРУИРОВАНИЕ  АЛГОРИТМОВАЛГОРИТМИЗАЦИЯ И ПРОГРАММИРОВАНИЕ

Описание презентации по отдельным слайдам:

1 слайд КОНСТРУИРОВАНИЕ  АЛГОРИТМОВАЛГОРИТМИЗАЦИЯ И ПРОГРАММИРОВАНИЕ
Описание слайда:

КОНСТРУИРОВАНИЕ АЛГОРИТМОВ
АЛГОРИТМИЗАЦИЯ И ПРОГРАММИРОВАНИЕ

2 слайд Ключевые слова последовательное построение алгоритма
 вспомогательный алгорит
Описание слайда:

Ключевые слова
последовательное построение алгоритма
вспомогательный алгоритм
формальные параметры
фактические параметры
рекурсивный алгоритм

3 слайд Последовательное построение алгоритмаНачало Исходные 
данныеПостановка
задачи
Описание слайда:

Последовательное построение алгоритма
Начало
Исходные
данные
Постановка
задачи
Результат
Конец
Я совершенный исполнитель: всё знаю и всё умею!

4 слайд Последовательное построение алгоритмаУпрощение команд
постановки задачиЗадача
Описание слайда:

Последовательное построение алгоритма
Упрощение команд
постановки задачи
Задача разбивается на более простые части
Решение каждой части задачи формулируется
в отдельной команде (предписании)
Предписания, выходящие за пределы
возможностей исполнителя, представляют
в виде более простых команд
Не могу решить поставленную задачу!?

5 слайд Разработка алгоритма методом последовательного уточнения для исполнителя Робо
Описание слайда:

Разработка алгоритма методом последовательного уточнения для исполнителя Робот
Робот находится в некоторой клетке горизонтального коридора. Ни одна из клеток коридора не закрашена.
Робот должен закрасить все клетки этого коридора и вернуться в исходное положение.

6 слайд Укрупнённый план действий Робота 1. Закраска всех клеток коридора левее исход
Описание слайда:

Укрупнённый план действий Робота
1. Закраска всех клеток коридора левее исходной
2. Возвращение в исходное положение
3. Закраска всех клеток коридора правее исходной
4. Возвращение в исходное положение
5. Закраска исходной клетки
Начало
Конец

7 слайд 1. Закраска всех клеток коридора, находящихся  левее Робота:Детализация плана
Описание слайда:

1. Закраска всех клеток коридора, находящихся левее Робота:
Детализация плана действий Робота
влево
нц пока сверху стена и снизу стена
закрасить; влево
кц
Положение Робота после выполнения этого алгоритма:

8 слайд 2. Возвращение Робота в коридор в исходную точку: вправо
нц пока клетка закра
Описание слайда:

2. Возвращение Робота в коридор в исходную точку:
вправо
нц пока клетка закрашена
вправо
кц
Детализация плана действий Робота
Положение Робота после выполнения этого алгоритма:

9 слайд 3. Закраска всех клеток коридора, находящихся правее Робота:вправо
нц пока св
Описание слайда:

3. Закраска всех клеток коридора, находящихся правее Робота:
вправо
нц пока сверху стена и снизу стена
закрасить; вправо
кц
Детализация плана действий Робота
Положение Робота после выполнения этого алгоритма:

10 слайд 4.Возвращение Робота в коридор в исходную точку: влево
нц пока клетка закраше
Описание слайда:

4.Возвращение Робота в коридор в исходную точку:
влево
нц пока клетка закрашена
влево
кц
5. По команде закрасить Робот закрашивает исходную точку.
Детализация плана действий Робота

11 слайд алг
нач
   влево
   нц пока сверху стена и снизу стена
      закрасить; влево
Описание слайда:

алг
нач
влево
нц пока сверху стена и снизу стена
закрасить; влево
кц
вправо
нц пока клетка закрашена
вправо
кц
вправо
нц пока сверху стена и снизу стена
закрасить; вправо
кц
влево
нц пока клетка закрашена
влево
кц
закрасить
кон
Программа для Робота

12 слайд Вспомогательный алгоритм Вспомогательный алгоритм - алгоритм, целиком использ
Описание слайда:

Вспомогательный алгоритм
Вспомогательный алгоритм - алгоритм, целиком используемый в составе другого алгоритма.
Блок «предопределённый процесс»
Вспомогательный алгоритм делает структуру алгоритма более простой и понятной.

13 слайд Алгоритм вычисления степени  y = ax, где x - целое число, a    0.
Описание слайда:

Алгоритм вычисления степени
y = ax, где x - целое число, a 0.



1, при x = 0
y = ax, при x >0,
, при x <0.
Обозначим алгоритм возведения числа в степень st(a, n, y).
Это вспомогательный алгоритм.

14 слайд Блок-схема решения задачи:Начало y данетst (a, x, y)a, x, yx = 0y := 1Конец x
Описание слайда:

Блок-схема решения задачи:
Начало
y
да
нет
st (a, x, y)
a, x, y
x = 0
y := 1
Конец
x > 0
st (1/a, -x, y)
да
нет

15 слайд Формальные параметры используются при описании алгоритма. 
Фактические параме
Описание слайда:

Формальные параметры используются при описании алгоритма.
Фактические параметры - те величины, для которых будет исполнен вспомогательный алгоритм.
Типы, количество и порядок следования формальных и фактических параметров должны совпадать.
Формальные и фактические параметры

16 слайд Схема вызова вспомогательного алгоритмаОсновной алгоритм






…Имя вспомогат
Описание слайда:

Схема вызова вспомогательного алгоритма
Основной алгоритм







Имя вспомогательного
алгоритма (список
фактических параметров)

Вспомогательный алгоритм

Формальные аргументы
Формальные аргументы

17 слайд Пример. Алгоритм вычисления степени с натуральным показателем n для любого ве
Описание слайда:

Пример. Алгоритм вычисления степени с натуральным показателем n для любого вещественного числа а, представленный в виде рекурсивного алгоритма
Рекурсивный алгоритм
Начало
a, n
st (a, n-1,y)
y :=a*y
y
Конец
Алгоритм, в котором прямо или косвенно содержится ссылка на него же как на вспомогательный алгоритм, называют рекурсивным.

18 слайд Снежинка КохаПример. Рассмотрим алгоритм построения геометрической фигуры, ко
Описание слайда:

Снежинка Коха
Пример. Рассмотрим алгоритм построения геометрической фигуры, которая называется снежинкой Коха. Шаг процедуры построения состоит в замене средней трети каждого из имеющихся отрезков двумя новыми той же длины.
С каждым шагом фигура становится всё причудливее. Граница снежинки Коха - положение кривой после выполнения бесконечного числа шагов.
Начальное положение
Первый шаг
Второй шаг
Третий шаг

19 слайд Самое главноеМетод последовательного построения алгоритма:  
исходная задача
Описание слайда:

Самое главное
Метод последовательного построения алгоритма:
исходная задача разбивается на несколько частей, каждая из которых проще всей задачи, и решение каждой части формулируется в отдельной команде;
если получаются команды, выходящие за пределы возможностей исполнителя, то они представляются в виде совокупности ещё более простых предписаний;
процесс продолжается до тех пор, пока все предписания не будут понятны исполнителю.
Вспомогательный алгоритм - алгоритм, целиком используемый в составе другого алгоритма.
Алгоритм, в котором прямо или косвенно содержится ссылка на него же как на вспомогательный алгоритм, называют рекурсивным.

20 слайд Вопросы и заданияПочему при решении сложной задачи затруднительно
 сразу конк
Описание слайда:

Вопросы и задания
Почему при решении сложной задачи затруднительно
сразу конкретизировать все необходимые действия?
В чём заключается метод последовательного уточнения при построении алгоритма?
Какая связь между методом последовательного построения алгоритма и такими процессами, как написание сочинения или подготовка к многодневному туристическому походу?
Известен рост каждого из N учеников 9А класса и М учеников 9Б класса.
Опишите укрупнёнными блоками алгоритм сравнения среднего роста учеников этих классов.
В ряду из десяти клеток правее Робота некоторые клетки закрашены. Последняя закрашенная клетка может примыкать к стене.
Составьте алгоритм, который закрашивает клетки выше и ниже каждой закрашенной клетки.
Проверьте работу алгоритма в следующих случаях:
Для чего нужны вспомогательные алгоритмы?
Опишите процесс выполнения команды вызова вспомогательного алгоритма в основном алгоритме.
Сталкивались ли вы с идеей формальных и фактических параметров при изучении математики и физики?
Приведите пример.
Какие алгоритмы называют рекурсивными?
Приведите пример рекурсии из жизни.
Составьте алгоритмы, под управлением которых Робот закрасит указанные клетки.
а
б
в

21 слайд Опорный конспектМетод последовательного построения алгоритма - один из основн
Описание слайда:

Опорный конспект
Метод последовательного построения алгоритма - один из основных методов конструирования алгоритмов.
Упрощение команд
постановки задачи
Задачу разбивают на более простые
Решение каждой части задачи формулируют
в отдельной команде
Предписания, выходящие за пределы возможностей
исполнителя, представляют в виде более простых команд
Вспомогательный алгоритм - алгоритм, целиком используемый в составе другого алгоритма.

  • Если Вы считаете, что материал нарушает авторские права либо по каким-то другим причинам должен быть удален с сайта, Вы можете оставить жалобу на материал.
    Пожаловаться на материал
Курс повышения квалификации
Курс профессиональной переподготовки
Учитель математики и информатики
Курс профессиональной переподготовки
Учитель информатики
Скачать материал
Найдите материал к любому уроку,
указав свой предмет (категорию), класс, учебник и тему:
также Вы можете выбрать тип материала:
Проверен экспертом
Общая информация
Учебник: «Информатика», Босова Л.Л., Босова А.Ю.
Тема: § 2.3. Конструирование алгоритмов
Скачать материал

Вам будут интересны эти курсы:

Курс повышения квалификации «Информационные технологии в деятельности учителя физики»
Курс повышения квалификации «Внедрение системы компьютерной математики в процесс обучения математике в старших классах в рамках реализации ФГОС»
Курс повышения квалификации «Организация работы по формированию медиаграмотности и повышению уровня информационных компетенций всех участников образовательного процесса»
Курс профессиональной переподготовки «Информатика: теория и методика преподавания в образовательной организации»
Курс повышения квалификации «Облачные технологии в образовании»
Курс повышения квалификации «Сетевые и дистанционные (электронные) формы обучения в условиях реализации ФГОС по ТОП-50»
Курс повышения квалификации «Использование компьютерных технологий в процессе обучения в условиях реализации ФГОС»
Курс профессиональной переподготовки «Теория и методика обучения информатике в начальной школе»
Курс профессиональной переподготовки «Математика и информатика: теория и методика преподавания в образовательной организации»
Курс повышения квалификации «Современные тенденции цифровизации образования»
Курс повышения квалификации «Специфика преподавания дисциплины «Информационные технологии» в условиях реализации ФГОС СПО по ТОП-50»

Оставьте свой комментарий

Авторизуйтесь, чтобы задавать вопросы.